summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-05-16 19:15:43 +0200
committerHans de Graaff <graaff@gentoo.org>2019-05-16 19:15:43 +0200
commit3c35ed60ae4e0ed8c515e90dc09f3e1c7f211e3b (patch)
tree4af6a9f05d5d71619e150f96bfc0faacb2fb3966 /dev-ruby/actionpack/actionpack-5.2.2.1.ebuild
parentdev-ruby/activestorage: cleanup (diff)
downloadgentoo-3c35ed60ae4e0ed8c515e90dc09f3e1c7f211e3b.tar.gz
gentoo-3c35ed60ae4e0ed8c515e90dc09f3e1c7f211e3b.tar.bz2
gentoo-3c35ed60ae4e0ed8c515e90dc09f3e1c7f211e3b.zip
dev-ruby/actionpack: cleanup
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/actionpack/actionpack-5.2.2.1.ebuild')
-rw-r--r--dev-ruby/actionpack/actionpack-5.2.2.1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-ruby/actionpack/actionpack-5.2.2.1.ebuild b/dev-ruby/actionpack/actionpack-5.2.2.1.ebuild
deleted file mode 100644
index 4911a4b5d53e..000000000000
--- a/dev-ruby/actionpack/actionpack-5.2.2.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eapi7-ver
-
-DESCRIPTION="Eases web-request routing, handling, and response"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- ~dev-ruby/actionview-${PV}
- dev-ruby/rack:2.0
- >=dev-ruby/rack-test-0.6.3:*
- >=dev-ruby/rails-html-sanitizer-1.0.2:1
- dev-ruby/rails-dom-testing:2
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha:0.14
- dev-ruby/bundler
- >=dev-ruby/capybara-2.13:2
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/rack-cache-1.2:1.2
- www-servers/puma
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
- rm ../Gemfile.lock || die
-}