summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-01-26 08:28:23 +0100
committerHans de Graaff <graaff@gentoo.org>2016-01-26 08:30:21 +0100
commit63140e2fc5e772f112f390561d70d24ae9da720e (patch)
treeb80e4780795f4ba8a8bfb1997593577d0124de16 /dev-ruby/actionpack
parentdev-ruby/activeresource: add rails 3.2.22.1 (diff)
downloadgentoo-63140e2fc5e772f112f390561d70d24ae9da720e.tar.gz
gentoo-63140e2fc5e772f112f390561d70d24ae9da720e.tar.bz2
gentoo-63140e2fc5e772f112f390561d70d24ae9da720e.zip
dev-ruby/actionpack: add rails 3.2.22.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/Manifest1
-rw-r--r--dev-ruby/actionpack/actionpack-3.2.22.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-ruby/actionpack/Manifest b/dev-ruby/actionpack/Manifest
index aae64050b989..e9c9dc071b62 100644
--- a/dev-ruby/actionpack/Manifest
+++ b/dev-ruby/actionpack/Manifest
@@ -1,3 +1,4 @@
+DIST rails-3.2.22.1.tgz 3570617 SHA256 0678ec5677e6f70a20aa398b323a3d926531e1da266734ec90c34e111512b0fc SHA512 29b9e7aca818ed08111cc6306edfcbf88969ab2cbb0f36b9a189f8a29c2dec966e3a453d7b9ee9fc0cf06f0786aa493839440a2d6fb338b13b801978b08f4656 WHIRLPOOL b797311ab5420c4663b1617e5fabdc30a66619f1b6a16aa68ed96f5e38f4daff89cecc8bf9f3d7a702f17ae7da6bedf128adad2a3120f50a25ff85aff5cb6527
DIST rails-3.2.22.tgz 3569215 SHA256 a14fbd69cd1750589cb6f4a79926058595de832dab89372fb479feadc99f0aba SHA512 7321e5fa12cc3f7d6e7c2284f37c183c9bcbe1c9f067c2be5ebdd10f550b0eff561b20558cf885f30b24951bfa88287b3e0fb421eee14579a88a2bcffeaff3ce WHIRLPOOL de54798cbcbf9a0c6d66346267cfbb15991478cc6b4982f9e3a3a80db734af6553f9749b18188c4dc5fa82c60c0294312f648a0e4b5bcb46896bfee75be4dbc0
DIST rails-4.0.13.tgz 3761572 SHA256 a693a8c5f767d153e765634cecb6356855ca51b6554b3af1a38888023a204a51 SHA512 3f2cca90187f800d1ec57fc6cbc58c1f3213113a94d1dee7d9cfd3dc0264b7f3a9c6cfc6dd95ef2fb3aa7d8ca5d6da50cedecc288ff8ff7e5305dc0309b4365d WHIRLPOOL a5b3f7f828a88d04b5687b3217b40903192ccea5eca36ca58cbb2baeec7471241fe5529f13688bd1f6396a384cf282c94bfaf54ee1cfafdf5ef400707dee7d01
DIST rails-4.1.13.tgz 3726822 SHA256 94112f3398c5ffd5e53ce959969c133b35386ade0a9d845eaead4237a5546335 SHA512 8fef27cfbe898fc691562d9a6d543816c3e5c08c4c114b01115024e573b6d49568bca13da9d4574cfe0b76cc778c734e4a24def7047c90fb1c6d1c78553bcee3 WHIRLPOOL 321e60e7f51026e6c79c9f1cf128b349dbab08ed17d8f20fb034f1317c8498edcdaebf166fa30995abc80c6a4cd691408b3b4046adf11086899cd995e94c7d0a
diff --git a/dev-ruby/actionpack/actionpack-3.2.22.1.ebuild b/dev-ruby/actionpack/actionpack-3.2.22.1.ebuild
new file mode 100644
index 000000000000..0428bb99698f
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.2.22.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# The default test task tries to test activerecord with SQLite as well.
+RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Eases web-request routing, handling, and response"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/rack-cache-1.2
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/rack-1.4.5:1.4
+ >=dev-ruby/rack-test-0.6.1:0.6
+ >=dev-ruby/journey-1.0.4:1.0
+ >=dev-ruby/sprockets-2.2.1:2.2
+ >=dev-ruby/erubis-2.7.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.13
+ dev-ruby/bundler
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ >=dev-ruby/tzinfo-0.3.29:0
+ >=dev-ruby/uglifier-1.0.3
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|nokogiri\|execjs\)/d" \
+ -e 'agem "i18n", "~>0.6.11"' ../Gemfile || die
+
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+
+ sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
+
+ # Avoid fragile tests depending on hash ordering
+ sed -i -e '/cookie_3=chocolate/ s:^:#:' test/controller/integration_test.rb || die
+ sed -i -e '/test_to_s/,/end/ s:^:#:' test/template/html-scanner/tag_node_test.rb || die
+ sed -i -e '/"name":"david"/ s:^:#:' test/controller/mime_responds_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_element_hash/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+ sed -i -e '/test_option_html_attributes_with_multiple_hashes/, / end/ s:^:#:' test/template/form_options_helper_test.rb || die
+
+ # Avoid fragile test that gets more output than it expects.
+ sed -i -e '/test_locals_option_to_assert_template_is_not_supported/,/end/ s:^:#:' test/controller/render_test.rb || die
+
+ # Avoid test broken by security updates in i18n.
+ sed -i -e '/test_number_to_i18n_currency/,/end/ s:^:#:' test/template/number_helper_i18n_test.rb || die
+
+ # Avoid test that chokes on bad UTF-8.
+ sed -i -e '/test_handles_urls_with_bad_encoding/,/^ end/ s:^:#:' test/dispatch/static_test.rb || die
+}