summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-06-07 20:31:30 +0200
committerHans de Graaff <graaff@gentoo.org>2022-06-07 20:31:30 +0200
commitfd74626300a0d531bdd6965b7af6aa2a555777c0 (patch)
tree5a3895cc8ceb29628c701ae845d171e673f111a1 /dev-ruby/jwt
parentdev-ruby/octokit: add 4.24.0 (diff)
downloadgentoo-fd74626300a0d531bdd6965b7af6aa2a555777c0.tar.gz
gentoo-fd74626300a0d531bdd6965b7af6aa2a555777c0.tar.bz2
gentoo-fd74626300a0d531bdd6965b7af6aa2a555777c0.zip
dev-ruby/jwt: add 2.4.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/jwt')
-rw-r--r--dev-ruby/jwt/Manifest1
-rw-r--r--dev-ruby/jwt/jwt-2.4.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/jwt/Manifest b/dev-ruby/jwt/Manifest
index 7dfef404bedd..6760dad08963 100644
--- a/dev-ruby/jwt/Manifest
+++ b/dev-ruby/jwt/Manifest
@@ -1,2 +1,3 @@
DIST jwt-2.2.3.tar.gz 50675 BLAKE2B 904a2b9be80ece10cc046d35df784ecc4991c3b09a79c2e2e461003596e9212409ed5840282ce632d3ff499754c505cd899ca95945f562883869ff3c50c4399a SHA512 ebefbf8f825afc1a78329088012118ed681a61bdf9e1c6a3fa125d46105092f1f26a4bc88791788c0290009dbc0427128d655a301c034ac07caf14216744962c
DIST jwt-2.3.0.tar.gz 53312 BLAKE2B 4653a786d0f5da0d7c7e160f5b0c189f0eab78d045d5af441561c953d6d42fc74d6baff95e54dd9bfd47b3245f3b628e25f99e37016631ef282d95564a08cb1d SHA512 a4dfbb119575d9b5f883c2789734180f092adc75e05310de2e523e352f47469243868480e06f9bfabfa2a48e174ea669e69bd73e0fd002c4f66134462ffe2653
+DIST jwt-2.4.0.tar.gz 59280 BLAKE2B e7ff827c0f8d0514feaea43f5915d83b4be4ee538890250a390cf9a5df3f372d5bff3d90b741d0024c9e89ad28e581626a330b1fb400d2616454a1f964d358e4 SHA512 2bb409a8b2ae2e2330744e3efe306bfc1755c70244f2d7d4dd8ed824c7960f42baf6ec3ee80ed74c0590a3a61b92f61edb157db001d4c4f28005bb50c60bf74f
diff --git a/dev-ruby/jwt/jwt-2.4.0.ebuild b/dev-ruby/jwt/jwt-2.4.0.ebuild
new file mode 100644
index 000000000000..2151906e7d9c
--- /dev/null
+++ b/dev-ruby/jwt/jwt-2.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-jwt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+ruby_add_bdepend "test? ( dev-ruby/rbnacl )"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.start/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}