summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-09-14 19:19:49 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-09-14 19:20:47 -0500
commit5ce242c58408ee4cce339d42a464c749c0f3faf3 (patch)
tree4597ce00b2048826784df5886f141251b64dcaf1 /dev-ruby/puppetdb-termini
parentapp-admin/puppetdb: add 7.11.1 (diff)
downloadgentoo-5ce242c58408ee4cce339d42a464c749c0f3faf3.tar.gz
gentoo-5ce242c58408ee4cce339d42a464c749c0f3faf3.tar.bz2
gentoo-5ce242c58408ee4cce339d42a464c749c0f3faf3.zip
dev-ruby/puppetdb-termini: add 7.11.1
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/puppetdb-termini')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.11.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index a4577c1289db..853ea11e84ec 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_7.10.1-1stretch_all.deb 22156 BLAKE2B 52b1060fcf177b37229303ef93f90424f2b6b29eadf8041aa733d20f6b417c16e163891c44bc6f7845957ced10db132c705d6d6031041abace2f8f66f3d64964 SHA512 b273ac57558c9255d342010d9f3ada729596582311b3bbe658bf1505bd457041d0f5948c35c37bad585c931a66a66dcadcc71960de695c126715ef53d08295c5
DIST puppetdb-termini_7.11.0-1stretch_all.deb 22662 BLAKE2B b5b0d19829d6570076b4861bef85342d7ac925250fec6a892a7106319585851800ebdf9e947d8ef18d764d1abccef104acce82820a73511f9f92468e9c5c0998 SHA512 0450787b4411192214f05a8ca87b683a0792910a3aed3ec1680a2810e1566f0817b424d6ba3bdd95803f3ad6fb3f98ef8efb648064318dbcae39c23072d1bd85
+DIST puppetdb-termini_7.11.1-1stretch_all.deb 22652 BLAKE2B 776f7254062c4864236236101e79a8010ecc83a468c8b6dd14d005c4045fc695494cbe7fd468ad642bb6a13d3f8578db3c5a92981e03a21d4622a1ef5a9fc106 SHA512 5c2f6279f5ed8cdb6401a9b87f9c8e2459f1c5e1b4327224b5db9b9349ae4c20ed3237cc0e0a5aa4cf89763296cc9198cbfd33780fad224bbbaf0e11cbb29e97
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.11.1.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.11.1.ebuild
new file mode 100644
index 000000000000..d8ffebf1040f
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.11.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="amd64 ~arm64 ~ppc x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}