summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-04-30 12:06:13 +0200
committerDavid Seifert <soap@gentoo.org>2023-04-30 12:06:13 +0200
commit4675519c0830dd4bda84118a0edc9138a1a7d9a3 (patch)
treed64cfb7a588cbf2172c4f13aaf956f09d4f43533 /dev-ruby/rspec-expectations
parentdev-ruby/rspec-mocks: drop 2.99.2-r1 (diff)
downloadgentoo-4675519c0830dd4bda84118a0edc9138a1a7d9a3.tar.gz
gentoo-4675519c0830dd4bda84118a0edc9138a1a7d9a3.tar.bz2
gentoo-4675519c0830dd4bda84118a0edc9138a1a7d9a3.zip
dev-ruby/rspec-expectations: drop 2.99.2
Closes: https://bugs.gentoo.org/831586 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/Manifest1
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-ruby/rspec-expectations/Manifest b/dev-ruby/rspec-expectations/Manifest
index 4cc46320bae8..85bafe4f7704 100644
--- a/dev-ruby/rspec-expectations/Manifest
+++ b/dev-ruby/rspec-expectations/Manifest
@@ -1,4 +1,3 @@
-DIST rspec-expectations-2.99.2-git.tgz 106884 BLAKE2B 5b31c8681306d5c688f62fc3fc6adf7be6cabad6df6fd16195c71787d73495924233d793633fa041a94d796f63c9ff97c58e6f4a75bdc09dfbe56e770bb6a5c9 SHA512 6042cafe225b2b16df458c7bf69e1694b637afcac6f6195e35a0be199432610457ccaa3e7e4bd114b27a7a6c3d530d94f4c0603c65f469cbadc55bd3f75b6f3a
DIST rspec-expectations-3.11.0-git.tgz 214878 BLAKE2B f830a0a31fb0e7cd6639e711e4daa9faa98e514b6a1dd864c383259d199dc617c6c7ff45dc65f37cf53d3c4581c6ecb9148e42b77f3c37541d8985714d62af23 SHA512 209eabafe92db3de1a78524d98facda16b3f5fef11f8f0c8c74bc6fc68529c8d9a835a8196e84b8b8bdf828d548d4b00bb1acdd607cab14dad7874f55a42b0c6
DIST rspec-expectations-3.11.1-git.tgz 217396 BLAKE2B b9660b22f0b23a5436d98ffe2b21b58c947765ab5cf7d245bf265faead46a5326fc403ad55ee2fcd72d96c8c29fc996715ecc74c9521ec4ca34daa9d5bc0f819 SHA512 1941056eb2f2205f583f335993e25030b433cb0463992d74d5c568c7bbab4313fc6e7e14ada5147064b14d6da49326e3c3cb342408cfe9b38d350c9470e5cdf9
DIST rspec-expectations-3.12.0-git.tgz 217524 BLAKE2B f9638e2e5c83020818b2de4c06074b7d70f02655a50d598ecfcd8c79e1abb2ec351c5b7aed1ec0ea84fde140fc1a04349a6f2edbffda7cb697135ac0b5788b0c SHA512 51a80b5d45e8ca61a829f2130c60433999c6d5c60343d25f737bdb9d6864e89a156b29b549250f7c4248d5ba7a0cef11eb28e55d3023274051eb11f2d0361c83
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
deleted file mode 100644
index 006ae650cb53..000000000000
--- a/dev-ruby/rspec-expectations/rspec-expectations-2.99.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.3"
-
-ruby_add_bdepend "test? (
- >=dev-ruby/rspec-core-2.99.0:2
- >=dev-ruby/rspec-mocks-2.14.0:2
- )"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Remove the Gemfile to avoid running through 'bundle exec'
- rm Gemfile || die
-
- # Remove .rspec options to avoid dependency on newer rspec when
- # bootstrapping.
- rm .rspec || die
-
- # fix up the gemspecs
- sed -i \
- -e '/git ls/d' \
- -e '/add_development_dependency/d' \
- "${RUBY_FAKEGEM_GEMSPEC}" || die
-
- # Avoid a weird, and failing, test testing already installed code.
- sed -e '/has an up-to-date caller_filter file/,/end/ s:^:#:' -i spec/rspec/expectations_spec.rb || die
-}
-
-each_ruby_prepare() {
- sed -i -e 's/of Fixnum/of Integer/' spec/rspec/expectations/expectation_target_spec.rb spec/rspec/matchers/be_instance_of_spec.rb || die
-}