summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/simple-rss
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/simple-rss')
-rw-r--r--dev-ruby/simple-rss/Manifest1
-rw-r--r--dev-ruby/simple-rss/files/simple-rss-1.2.3-no-media-rss.patch49
-rw-r--r--dev-ruby/simple-rss/metadata.xml5
-rw-r--r--dev-ruby/simple-rss/simple-rss-1.3.1-r1.ebuild29
-rw-r--r--dev-ruby/simple-rss/simple-rss-1.3.1.ebuild29
5 files changed, 113 insertions, 0 deletions
diff --git a/dev-ruby/simple-rss/Manifest b/dev-ruby/simple-rss/Manifest
new file mode 100644
index 000000000000..cc349792e592
--- /dev/null
+++ b/dev-ruby/simple-rss/Manifest
@@ -0,0 +1 @@
+DIST simple-rss-1.3.1.gem 35840 SHA256 5718ccaf2989525bf855207197b1ab190a2e04e6fc74ed0edd68abcef5db5b53 SHA512 a24eca178f0777ba1747e420a883fae7650767cb212fd3dbb89ea35d81d1d0766ab6ac891d19abcc88ed7a2209890a4fbf3827eab6ffb0c11ffe69e4abaa6f4a WHIRLPOOL 1a2399428b1279273c8430510c71b70ff2e918fe627a6f38f73424f94da46a9b241897532af985213574255e94b04e53757e4700ab2e737b6092f8380ccf07d8
diff --git a/dev-ruby/simple-rss/files/simple-rss-1.2.3-no-media-rss.patch b/dev-ruby/simple-rss/files/simple-rss-1.2.3-no-media-rss.patch
new file mode 100644
index 000000000000..9b06898d0209
--- /dev/null
+++ b/dev-ruby/simple-rss/files/simple-rss-1.2.3-no-media-rss.patch
@@ -0,0 +1,49 @@
+Remove tests depending on media_rss.xml, because it is not shipped in
+the gem and the upstream VCS is not available.
+
+http://rubyforge.org/tracker/index.php?func=detail&aid=28359&group_id=893&atid=3517
+
+--- test/base/base_test.rb.orig 2010-07-08 21:16:48.625863508 +0200
++++ test/base/base_test.rb 2010-07-08 21:17:06.038612667 +0200
+@@ -3,7 +3,6 @@
+ def setup
+ @rss09 = SimpleRSS.parse open(File.dirname(__FILE__) + '/../data/rss09.rdf')
+ @rss20 = SimpleRSS.parse open(File.dirname(__FILE__) + '/../data/rss20.xml')
+- @media_rss = SimpleRSS.parse open(File.dirname(__FILE__) + '/../data/media_rss.xml')
+ @atom = SimpleRSS.parse open(File.dirname(__FILE__) + '/../data/atom.xml')
+ end
+
+@@ -29,26 +28,6 @@
+ assert_equal Time.parse("Fri Sep 09 02:52:31 PDT 2005"), @rss09.channel.dc_date
+ end
+
+- def test_media_rss
+- assert_equal 20, @media_rss.items.size
+- assert_equal "Uploads from herval", @media_rss.title
+- assert_equal "http://www.flickr.com/photos/herval/", @media_rss.channel.link
+- assert_equal "http://www.flickr.com/photos/herval/4671960608/", @media_rss.items.first.link
+- assert_equal "http://www.flickr.com/photos/herval/4671960608/", @media_rss.items.first[:link]
+- assert_equal "http://farm5.static.flickr.com/4040/4671960608_10cb945d5c_o.jpg", @media_rss.items.first.media_content_url
+- assert_equal "image/jpeg", @media_rss.items.first.media_content_type
+- assert_equal "3168", @media_rss.items.first.media_content_height
+- assert_equal "4752", @media_rss.items.first.media_content_width
+- assert_equal "Woof?", @media_rss.items.first.media_title
+- assert_equal "http://farm5.static.flickr.com/4040/4671960608_954d2297bc_s.jpg", @media_rss.items.first.media_thumbnail_url
+- assert_equal "75", @media_rss.items.first.media_thumbnail_height
+- assert_equal "75", @media_rss.items.first.media_thumbnail_width
+- assert_equal "herval", @media_rss.items.first.media_credit
+- assert_equal "photographer", @media_rss.items.first.media_credit_role
+- assert_equal "pets frodo", @media_rss.items.first.media_category
+- assert_equal "urn:flickr:tags", @media_rss.items.first.media_category_scheme
+- end
+-
+ def test_rss20
+ assert_equal 10, @rss20.items.size
+ assert_equal "Technoblog", @rss20.title
+@@ -69,4 +48,4 @@
+ def test_bad_feed
+ assert_raise(SimpleRSSError) { SimpleRSS.parse(open(File.dirname(__FILE__) + '/../data/not-rss.xml')) }
+ end
+-end
+\ No newline at end of file
++end
diff --git a/dev-ruby/simple-rss/metadata.xml b/dev-ruby/simple-rss/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/simple-rss/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/simple-rss/simple-rss-1.3.1-r1.ebuild b/dev-ruby/simple-rss/simple-rss-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..b2f98b12cc93
--- /dev/null
+++ b/dev-ruby/simple-rss/simple-rss-1.3.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple, flexible, extensible, and liberal RSS and Atom reader for Ruby"
+HOMEPAGE="http://simple-rss.rubyforge.org/"
+LICENSE="LGPL-2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec )"
+
+all_ruby_prepare() {
+ # Avoid dependency on bundler
+ sed -i -e '/bundler/d' Rakefile || die
+
+ # https://github.com/cardmagic/simple-rss/pull/14
+ sed -i -e 's/README/README.markdown/' Rakefile || die
+}
diff --git a/dev-ruby/simple-rss/simple-rss-1.3.1.ebuild b/dev-ruby/simple-rss/simple-rss-1.3.1.ebuild
new file mode 100644
index 000000000000..742c70ecde15
--- /dev/null
+++ b/dev-ruby/simple-rss/simple-rss-1.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple, flexible, extensible, and liberal RSS and Atom reader for Ruby"
+HOMEPAGE="http://simple-rss.rubyforge.org/"
+LICENSE="LGPL-2"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec )"
+
+all_ruby_prepare() {
+ # Avoid dependency on bundler
+ sed -i -e '/bundler/d' Rakefile || die
+
+ # https://github.com/cardmagic/simple-rss/pull/14
+ sed -i -e 's/README/README.markdown/' Rakefile || die
+}