summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flo@geekplace.eu>2024-03-18 14:25:59 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-03-18 14:43:10 +0100
commitd133270058d45f273f30170e13049576a20a7bc2 (patch)
tree78723d083ee4b4d6c01829e118e14b69aff59a41 /dev-tex
parentsys-apps/util-linux: backport fix for LVM2 metadata parsing, basename w/ musl... (diff)
downloadgentoo-d133270058d45f273f30170e13049576a20a7bc2.tar.gz
gentoo-d133270058d45f273f30170e13049576a20a7bc2.tar.bz2
gentoo-d133270058d45f273f30170e13049576a20a7bc2.zip
dev-tex/hevea: add 2.36
Closes: https://bugs.gentoo.org/927003 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/hevea/Manifest1
-rw-r--r--dev-tex/hevea/hevea-2.36.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-tex/hevea/Manifest b/dev-tex/hevea/Manifest
index fa43aedd0b3a..c7e259115d4c 100644
--- a/dev-tex/hevea/Manifest
+++ b/dev-tex/hevea/Manifest
@@ -1 +1,2 @@
DIST hevea-2.35.tar.gz 1006773 BLAKE2B 80a8f80955a4eee641c53784cbe4543072062d0bf4d757fe0c8270d6370d54495eeab3a9279bd992dc45b80b23de0438ee4fe6fa932981c777b25782c42ca4a8 SHA512 dc1a5179489626176b1fcae47a9c7eb4cf9c1c6127c749cb938808697ccd6179277089fb20f4d5da7b82056d15b1d64acd9ba9884d1950a74d98c98864b4180a
+DIST hevea-2.36.tar.gz 1007317 BLAKE2B d8e6d3490b02b990e992a343a287ae5ff1f32624722760df52aa703d8989ef802b9f297ec97576b96937edb70d1a35910ba11fd88ac675254368451ee68ad044 SHA512 9335666f5f77ff33b61ef3817feaff6e58ff9896a4e1478ecab893086177f66420020c174594ff0290c2c19ea5a46f52a03daf50e6e502dc9c2f2545463effa2
diff --git a/dev-tex/hevea/hevea-2.36.ebuild b/dev-tex/hevea/hevea-2.36.ebuild
new file mode 100644
index 000000000000..51948f1e861c
--- /dev/null
+++ b/dev-tex/hevea/hevea-2.36.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
+HOMEPAGE="https://hevea.inria.fr/"
+SRC_URI="https://hevea.inria.fr/distri/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+# - hevea's imagen script calls gs from app-text/ghostscript-gpl, hence
+# the RDEPEND (https://bugs.gentoo.org/927003).
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt=]"
+RDEPEND="
+ ${DEPEND}
+ app-text/ghostscript-gpl
+ dev-texlive/texlive-latexextra
+"
+BDEPEND="dev-ml/ocamlbuild"
+
+# bug #734350
+QA_FLAGS_IGNORED=(
+ /usr/bin/bibhva
+ /usr/bin/hevea
+ /usr/bin/esponja
+ /usr/bin/hacha
+)
+
+src_compile() {
+ rm -f config.sh || die
+
+ emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/share/texmf-site/tex/latex/hevea" config.sh
+
+ if use ocamlopt; then
+ emake PREFIX=/usr
+ else
+ emake PREFIX=/usr TARGET=byte
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ emake DESTDIR="${ED}" PREFIX=/usr install
+ else
+ emake DESTDIR="${ED}" PREFIX=/usr TARGET=byte install
+ fi
+
+ dodoc README CHANGES
+}
+
+# If texmf-update is present this means we have a latex install; update it so
+# that hevea.sty can be found
+# Do not (r)depend on latex though because hevea does not need it itself
+# If latex is installed later, it will see hevea.sty
+
+pkg_postinst() {
+ if [[ -z "${ROOT}" ]] && [[ -x "${EPREFIX}"/usr/sbin/texmf-update ]] ; then
+ "${EPREFIX}"/usr/sbin/texmf-update || die "texmf-update returned non-zero exit status ${?}"
+ fi
+}
+
+pkg_postrm() {
+ if [[ -z "${ROOT}" ]] && [[ -x "${EPREFIX}"/usr/sbin/texmf-update ]] ; then
+ "${EPREFIX}"/usr/sbin/texmf-update || die "texmf-update returned non-zero exit status ${?}"
+ fi
+}