summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2017-06-17 23:12:26 -0700
committerDaniel Campbell <zlg@gentoo.org>2017-06-17 23:13:11 -0700
commit78c1b9a8d372476580544910b6e2ffab379c6d54 (patch)
tree00321f99993d9a54c5009d82a9e6062480d7b338 /dev-util/astyle
parentsys-apps/apparmor-utils: restrict tests (diff)
downloadgentoo-78c1b9a8d372476580544910b6e2ffab379c6d54.tar.gz
gentoo-78c1b9a8d372476580544910b6e2ffab379c6d54.tar.bz2
gentoo-78c1b9a8d372476580544910b6e2ffab379c6d54.zip
dev-util/astyle: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/Manifest1
-rw-r--r--dev-util/astyle/astyle-3.0.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-util/astyle/Manifest b/dev-util/astyle/Manifest
index 724f9762026f..5579968a7466 100644
--- a/dev-util/astyle/Manifest
+++ b/dev-util/astyle/Manifest
@@ -1,3 +1,4 @@
DIST astyle_2.04_linux.tar.gz 156974 SHA256 70b37f4853c418d1e2632612967eebf1bdb93dfbe558c51d7d013c9b4e116b60 SHA512 bc0f6351fac4198ab969251342c4e453064b07512a2d06825a93c75daf86b06469c9971f35fbadad872d23368dc546019d8d174e07ceaad6e10007f562fdeffd WHIRLPOOL d9aa3f537885e373d791204652ed5c8d5231be0840ef5dde3714bb8c9c524e327585a51b7b14da1aae2952f7c9248401bc2769290bc5828d15f030f41d95c1fe
DIST astyle_2.05.1_linux.tar.gz 152765 SHA256 fbdfc6f1966a972d19a215927266c76d4183eee235ed1e2bd7ec551c2a270eac SHA512 853bf84cb196f2300ca00fb7f18fe336764f1205ae0674a75c1a019bf734495d8fb3d9b6aca0ea258b6632921fb268906128c1afb80596532489749cd2cbe495 WHIRLPOOL ceef3bfa64632a4fe9afcc332fdf742e60b6e7d21655449372bd6c89db7444eddf6bbfee48684bb9f18e119cf040f36c62544cfc8bb040ed83095e9aed9fce56
DIST astyle_2.06_linux.tar.gz 162037 SHA256 3b7212210dc139e8f648e004b758c0be1b3ceb1694b22a879202d2b833db7c7e SHA512 e2da96b45d06385b284ed3107309dfa4fad904910a729232bdb8554b40332a673d33e1f153ffb2ebb0342c73098b79980628678be9dde45a4d4d23237fe8a8c5 WHIRLPOOL 02696ffbfb7f621d45ff8140f75cda38cce8587349269d9b87aba56a365f4375c7ce1ca67b3c0af8e1c6f627397d016ecc907437b4085599f24d2927b86c7878
+DIST astyle_3.0_linux.tar.gz 172303 SHA256 983e4fe87f20427ddf0d06fa5ba046b5ee95347f9ada33a681af3892426a4ff3 SHA512 77ef75139b08a91829373558753d78a3253f23a2a53a81f591d8877ba31b9a5163fbe8453894366aebbe287051259a568e725ee3b5e68d8ed4852a12d7798f9d WHIRLPOOL a6fb79f6202df85260adbf92ce529efc905bd9aaa093d7fa270d39adf9d34146a365479376dc9271cdc9334cb4f15c782436a1f2d0fdbc03be8a7979c38f23d6
diff --git a/dev-util/astyle/astyle-3.0.ebuild b/dev-util/astyle/astyle-3.0.ebuild
new file mode 100644
index 000000000000..4392d25b3dfd
--- /dev/null
+++ b/dev-util/astyle/astyle-3.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2
+
+DESCRIPTION="Artistic Style is a re-indenter and reformatter for C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="examples java static-libs"
+
+DEPEND="app-arch/xz-utils
+ java? ( >=virtual/jdk-1.6:= )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if use java ; then
+ java-pkg-opt-2_src_prepare
+ sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
+ -e "s:ar crs:$(tc-getAR) crs:" \
+ -i build/gcc/Makefile || die
+ else
+ default
+ fi
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ tc-export CXX
+ default
+}
+
+src_compile() {
+ emake -f ../build/gcc/Makefile -C src \
+ ${PN} \
+ shared \
+ $(usev java) \
+ $(usex static-libs static '')
+}
+
+src_install() {
+ doheader src/${PN}.h
+
+ pushd src/bin >/dev/null || die
+ dobin ${PN}
+
+ # ex: libastyle.so.3.0.0
+ dolib.so lib${PN}.so.${PV}.0
+ # ex: libastyle.so.3
+ dosym lib${PN}.so.${PV}.0 /usr/$(get_libdir)/lib${PN}.so.$(get_major_version)
+ if use java ; then
+ dolib.so lib${PN}j.so.${PV}.0
+ dosym lib${PN}j.so.${PV}.0 /usr/$(get_libdir)/lib${PN}j.so.$(get_major_version)
+ fi
+ if use static-libs ; then
+ dolib lib${PN}.a
+ fi
+ popd >/dev/null || die
+ if use examples ; then
+ docinto examples
+ dodoc -r file/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ local HTML_DOCS=( doc/. )
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -n "$REPLACING_VERSIONS" && "$(get_major_version $REPLACING_VERSIONS)" -lt 3 ]]; then
+ elog "Artistic Style 3.0 introduces new configuration verbiage more fitting"
+ elog "for modern use. Some options that were valid in 2.06 or older are now"
+ elog "deprecated. For more information, consult astyle's release notes at"
+ elog "http://astyle.sourceforge.net/news.html. To view offline, see:"
+ elog
+ elog "${ROOT}usr/share/doc/${P}/html"
+ fi
+}