summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/bcpp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/bcpp')
-rw-r--r--dev-util/bcpp/Manifest2
-rw-r--r--dev-util/bcpp/bcpp-20050725.ebuild40
-rw-r--r--dev-util/bcpp/bcpp-20090630.ebuild42
-rw-r--r--dev-util/bcpp/files/bcpp-20050725-etc-cfg-files.patch22
-rw-r--r--dev-util/bcpp/metadata.xml8
5 files changed, 114 insertions, 0 deletions
diff --git a/dev-util/bcpp/Manifest b/dev-util/bcpp/Manifest
new file mode 100644
index 000000000000..ec0f0aeb89cc
--- /dev/null
+++ b/dev-util/bcpp/Manifest
@@ -0,0 +1,2 @@
+DIST bcpp-20050725.tgz 132649 SHA256 1a4b5e8e741d6be400eb68b7c4a3eebc6dabe29948a72a7a0bccb1db075eaa2a SHA512 0ada3aee998fa6748e7492bfe2e0d6e5417640eaa19aa3342637ee1d162c907d2af4fd2d1ab24661f36798d2d51fa017d9c113b8499b32bf4d521e130aa75323 WHIRLPOOL fff51c65b60351c9a7c55d060754e3e09383b905820ab79aa2f371a894a82d8a3fa5a00b00a066380909c49487e262f99a832022b5f214d564e43b8939fcbdcb
+DIST bcpp-20090630.tgz 138757 SHA256 27b46ab3cef53a658605f350e3982862e17b523e703f23617530a57180200a34 SHA512 660d11c0d8a8d3ccc2a4c14ccb60164a43647fface79ffd86b8d99519e227e32a882fc213a5fef64fd3aee1c409c4bb0a871dfd6d6a09a8ad35e253baef6496b WHIRLPOOL 1fa68efd9874933de2097b87aab0dd586cbc29cf7fc3d4ba6d80984ecb289f01d8093e82fbca3f8077300887a8d1b1b970ed5bcabb0a766489bdcb23704f7ac2
diff --git a/dev-util/bcpp/bcpp-20050725.ebuild b/dev-util/bcpp/bcpp-20050725.ebuild
new file mode 100644
index 000000000000..dacf2758c5ae
--- /dev/null
+++ b/dev-util/bcpp/bcpp-20050725.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Indents C/C++ source code"
+HOMEPAGE="http://invisible-island.net/bcpp/"
+SRC_URI="ftp://invisible-island.net/bcpp/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-etc-cfg-files.patch"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc CHANGES MANIFEST README VERSION txtdocs/hirachy.txt \
+ txtdocs/manual.txt
+
+ # install our configuration files
+ insinto /etc/bcpp
+ doins bcpp.cfg indent.cfg
+}
+
+pkg_postinst() {
+ elog "Check the documentation for more information on how to"
+ elog "Run bcpp. Please note that in order to get help for"
+ elog "bcpp, please run bcpp -h and not the command by itself."
+ elog ""
+ elog "Configuration files are at /etc/bcpp."
+ elog "To use them, use the -c option followed by the filename."
+}
diff --git a/dev-util/bcpp/bcpp-20090630.ebuild b/dev-util/bcpp/bcpp-20090630.ebuild
new file mode 100644
index 000000000000..a64445f9a6db
--- /dev/null
+++ b/dev-util/bcpp/bcpp-20090630.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Indents C/C++ source code"
+HOMEPAGE="http://invisible-island.net/bcpp/"
+SRC_URI="ftp://invisible-island.net/bcpp/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-20050725-etc-cfg-files.patch"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGES MANIFEST README VERSION txtdocs/hirachy.txt \
+ txtdocs/manual.txt || die "dodoc failed"
+
+ # Install our configuration files.
+ insinto /etc/bcpp
+ doins bcpp.cfg indent.cfg || die "doins failed"
+}
+
+pkg_postinst() {
+ elog "Check the documentation for more information on how to"
+ elog "Run bcpp. Please note that in order to get help for"
+ elog "bcpp, please run bcpp -h and not the command by itself."
+ elog ""
+ elog "Configuration files are at /etc/bcpp."
+ elog "To use them, use the -c option followed by the filename."
+}
diff --git a/dev-util/bcpp/files/bcpp-20050725-etc-cfg-files.patch b/dev-util/bcpp/files/bcpp-20050725-etc-cfg-files.patch
new file mode 100644
index 000000000000..e6ba66cd794c
--- /dev/null
+++ b/dev-util/bcpp/files/bcpp-20050725-etc-cfg-files.patch
@@ -0,0 +1,22 @@
+*** bcpp-20050725/code/bcpp.cpp.orig 2008-07-12 10:07:55.000000000 -0700
+--- bcpp-20050725/code/bcpp.cpp 2008-07-12 10:07:57.000000000 -0700
+***************
+*** 3100,3110 ****
+--- 3100,3116 ----
+ const char* pathSepChar;
+ char backUp;
+ int count = 0;
++ char buf[40];
+
+ // test to see if file is in current directory first !
+ if ((pCfgFile = fopen(pCfgName, "r")) != NULL)
+ return;
+
++ // try /etc/bcpp
++ snprintf(buf, 40, "/etc/bcpp/%s", pCfgName);
++ if ((pCfgFile = fopen(buf, "r")) != NULL)
++ return;
++
+ // environment variable not found, lord knows what it is !
+ if (pSPath == NULL)
+ return;
diff --git a/dev-util/bcpp/metadata.xml b/dev-util/bcpp/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/dev-util/bcpp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>