summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-14 01:54:51 +0000
committerSam James <sam@gentoo.org>2024-01-14 01:54:51 +0000
commitf54f3f3a4933080620a98287006925003de83272 (patch)
tree94401ebfc25a746c0b8e1e2a1ca467d6a677fcf2 /dev-util/bcpp
parentsec-keys/openpgp-keys-thomasdickey: add 20240114 (diff)
downloadgentoo-f54f3f3a4933080620a98287006925003de83272.tar.gz
gentoo-f54f3f3a4933080620a98287006925003de83272.tar.bz2
gentoo-f54f3f3a4933080620a98287006925003de83272.zip
dev-util/bcpp: add 20240111
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/bcpp')
-rw-r--r--dev-util/bcpp/Manifest2
-rw-r--r--dev-util/bcpp/bcpp-20240111.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/bcpp/Manifest b/dev-util/bcpp/Manifest
index 55d8d90db559..b278d0e68e5f 100644
--- a/dev-util/bcpp/Manifest
+++ b/dev-util/bcpp/Manifest
@@ -2,3 +2,5 @@ DIST bcpp-20221002.tgz 151426 BLAKE2B 6978b30ca684ec5e9eb781955679d333e7efdb389a
DIST bcpp-20221002.tgz.asc 729 BLAKE2B 64a211fb84ac6ca2926cb54b06945a908bb19ef15fb8784f4201b29dbc1ebe1be85e8bb0d05d14ebde126508cb33bb9e2d2411fa54b1290246263829d1f4f7f0 SHA512 867b2c04c957daff028a0eaa14ce2c7fd8718dbe9a9af5bf46b293ce51a0a49f823b18978f10f77b7363ff62691683e2945d0d71280185386f19dc7f1cc883d5
DIST bcpp-20230130.tgz 155972 BLAKE2B f51ae04ef75125d2040f9ef2ab9fb5513ad83fc6095b85bc091bf109d43b066723743c02f703b90f5d4faeb368da86d611d9ce46237c10e31b861b473de49282 SHA512 1fd22707313c098ac2a338425029d2c6355e9042b9bba3d2a6c8d4315dc59a33ea1bfc0cf30671ab2eb1c05981c4be5313a20d357bbbbb4f14374772253b4c30
DIST bcpp-20230130.tgz.asc 729 BLAKE2B ffd6266919c8598067b09ac9f855c3b1d93dbd4d6536dbd68a12ccbc5f8cc62e10315e44376fc72d40881e43dfa51676a1af46400aed66bf4c2ac1d4a17b499c SHA512 b52cfa95115726ec7b9575ef8a813fc5d1eb8dc7083b19508d5058b80d41203e70d3cd61a18eea4f35755f77e92ce15c2a1f24db0befb3b62dab3b71065a3955
+DIST bcpp-20240111.tgz 156659 BLAKE2B 9bcb986bd434e8c574a25d5e6a4dab08f5aec342bd60e46110902e7f5d924fff4295fc23ee5fc9190ef10c36fa89b19d9f2baff79150899f7618c06df543ae88 SHA512 e5211f484de3de4b6172d01fa9af50e2ed060cfb81d366575581480c1903dccb13b1e247809e17ae9a3cebc49d52b180b928a6abcad5f5b67b2af745b035e249
+DIST bcpp-20240111.tgz.asc 729 BLAKE2B c9933393c10b77bbeefcef315b6ae8d3df75fc3ee1d1880a661775ca11cd2965864191beae23a51b78be2db995d75f3e9cd0ac44b465905a19a21c7eb8463722 SHA512 50e28e55e533ce9641b2b6c95ae937a546f32ebc41a4c77a336cfb1c3528ba0c9e193fd0320cb145c31e31c941661c9c4dfae5eb1c5aa964af11f891907493a6
diff --git a/dev-util/bcpp/bcpp-20240111.ebuild b/dev-util/bcpp/bcpp-20240111.ebuild
new file mode 100644
index 000000000000..4d86a984f6b4
--- /dev/null
+++ b/dev-util/bcpp/bcpp-20240111.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="Indents C/C++ source code"
+HOMEPAGE="https://invisible-island.net/bcpp/"
+SRC_URI="https://invisible-island.net/archives/${PN}/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-thomasdickey-20240114 )"
+
+src_compile() {
+ emake CPPFLAGS='-DBCPP_CONFIG_DIR=\"/etc/bcpp/\"'
+}
+
+src_install() {
+ default
+ dodoc CHANGES MANIFEST README VERSION txtdocs/hirachy.txt \
+ txtdocs/manual.txt
+
+ insinto /etc/bcpp
+ doins bcpp.cfg indent.cfg
+}
+
+pkg_postinst() {
+ elog "Check the documentation for more information on how to"
+ elog "Run bcpp. Please note that in order to get help for"
+ elog "bcpp, please run bcpp -h and not the command by itself."
+ elog ""
+ elog "Configuration files are at ${EPREFIX}/etc/bcpp."
+ elog "To use them, use the -c option followed by the filename."
+}