summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-01-04 16:40:01 -0800
committerBrian Dolbec <dolsen@gentoo.org>2017-01-05 16:48:14 -0800
commit0f494b7b6f7ba03c6e20de27140a4b1f70a3e495 (patch)
treecc89bc0802dfd67f588095437ac21d47df4caa0d /dev-util/buildbot-www
parentdev-util/buildbot: Version bump (diff)
downloadgentoo-0f494b7b6f7ba03c6e20de27140a4b1f70a3e495.tar.gz
gentoo-0f494b7b6f7ba03c6e20de27140a4b1f70a3e495.tar.bz2
gentoo-0f494b7b6f7ba03c6e20de27140a4b1f70a3e495.zip
dev-util/buildbot-www: Version bump
Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
Diffstat (limited to 'dev-util/buildbot-www')
-rw-r--r--dev-util/buildbot-www/Manifest1
-rw-r--r--dev-util/buildbot-www/buildbot-www-0.9.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/Manifest b/dev-util/buildbot-www/Manifest
index e0f94d655866..3486d87c4080 100644
--- a/dev-util/buildbot-www/Manifest
+++ b/dev-util/buildbot-www/Manifest
@@ -1,2 +1,3 @@
DIST buildbot-www-0.9.0.post1.tar.gz 687998 SHA256 54b6438d46001b97c09b37490e0359d4515357574a9f3f83b796ce4b74897c11 SHA512 e1ed618c7467ac8d3620a9ab1ff14010ed6826562ef117c893cecaab18c06cc4619d9883a45f85ea22b76259bdc1a5bba050afe112aba9449917b7f4c3b3f5ef WHIRLPOOL 870d349a9a52fc9d12a162cd0b5fa94cb9b44c7aacfbaa1d148151e753c11b9fa906f92b85f2858cdc796a2573694c93f560a5fd99ecd19adaed9be68342ed8e
DIST buildbot-www-0.9.1.tar.gz 686034 SHA256 795a951f62d5313543d6cdb848dfd6c658cf58871021ac7b33a153b76de773b6 SHA512 0700d73f1b039571082e9209db09d4faa5ffeeff50db5ac1da9cfade70594b680b083d7421244a0d111b80b36699fee4eb01a9fbbd06248e22c1a38d17b8dc11 WHIRLPOOL fcc86e430918876dc45aa12b5d17e976171eb25a1473e18acd91ec045bbc54eeddd2d5e5917b05bde743241560597243ae246173c1be1ac81d086c5cc6fcef18
+DIST buildbot-www-0.9.2.tar.gz 689448 SHA256 063660ff23874e24b713d16d966beaaff5e0d67c437e3627db834f0631c49f82 SHA512 a5edf4da2a7e626b329b75242a5f1588c6ee95f4f242f155e23c4fd4c4ea4e372ba74cd23508f1ff4a3105f8086ed6171f9631d96cffbe8c7216a3ead9ac2320 WHIRLPOOL 58f2273dc425e6c1219a7dfdc25dcd647a7a94aada970777dd97c5607249ace710fda5c8c728feff703fa7976ac14873595ec4497ff1ddccfd958eecf66d74b4
diff --git a/dev-util/buildbot-www/buildbot-www-0.9.2.ebuild b/dev-util/buildbot-www/buildbot-www-0.9.2.ebuild
new file mode 100644
index 000000000000..602ba2877233
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-0.9.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 )
+
+EGIT_REPO_URI="git://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="http://trac.buildbot.net/ https://github.com/buildbot/buildbot http://pypi.python.org/pypi/buildbot"
+
+MY_V="${PV/_p/p}"
+MY_P="${PN}-${MY_V}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}