summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Strahl <c.a.strahl@gmail.com>2020-01-17 14:04:43 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-20 15:03:09 +0200
commit4f0c44714e498dcdc384a5ccc48fd6f663fea24a (patch)
tree594372427292428830bd45dc458bd52a8ef38dac /dev-util/clion
parentapp-text/ansifilter: amd64 stable wrt bug #705926 (diff)
downloadgentoo-4f0c44714e498dcdc384a5ccc48fd6f663fea24a.tar.gz
gentoo-4f0c44714e498dcdc384a5ccc48fd6f663fea24a.tar.bz2
gentoo-4f0c44714e498dcdc384a5ccc48fd6f663fea24a.zip
dev-util/clion: version bump to 2019.3.2
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Christian Strahl <c.a.strahl@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/clion')
-rw-r--r--dev-util/clion/Manifest1
-rw-r--r--dev-util/clion/clion-2019.3.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-util/clion/Manifest b/dev-util/clion/Manifest
index 9972085fe716..facfaa70a4da 100644
--- a/dev-util/clion/Manifest
+++ b/dev-util/clion/Manifest
@@ -1 +1,2 @@
+DIST clion-2019.3.2.tar.gz 504918530 BLAKE2B fd209977752f2e97c42113d082f0e57de0a4c73c3f18d29ba00872f19f753843c719abc96e1e7c1ba2d8afdfd724ef929e803d1ec009019ee9bef735347ae8a0 SHA512 def10008f685c5bac523c2a15920b41482f4877cdfcc26f3aac2dfdfe2cf0e23ebff236750d4f1b04f0076ec6967c127abaf61f0cb1da5a51d873fd0cd029f2a
DIST clion-2019.3.tar.gz 499054562 BLAKE2B 5655d39a573915431d296e5cc0a0aee1e0aaa95878e885b578a961b53b001ff8327338cf7e8e9a6eb71d758336cb8d71f7b21d94b4aa72504cc8f73df274dee6 SHA512 9d16ae4e2219d5cecb165934a8c378df2125ae6b14f924d04cad6776b985e19ea1957d1fb15e1c75d078eac56b47eaed2dfed02efedbf0d5ff649bab519ecc1c
diff --git a/dev-util/clion/clion-2019.3.2.ebuild b/dev-util/clion/clion-2019.3.2.ebuild
new file mode 100644
index 000000000000..85f96b2ea6bd
--- /dev/null
+++ b/dev-util/clion/clion-2019.3.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils
+
+DESCRIPTION="A complete toolset for C and C++ development"
+HOMEPAGE="https://www.jetbrains.com/clion"
+SRC_URI="https://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( IDEA IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )
+ Apache-1.1 Apache-2.0 BSD BSD-2 CC0-1.0 CDDL-1.1 CPL-0.5 CPL-1.0
+ EPL-1.0 EPL-2.0 GPL-2 GPL-2-with-classpath-exception GPL-3 ISC JDOM
+ LGPL-2.1+ LGPL-3 MIT MPL-1.0 MPL-1.1 OFL public-domain PSF-2 UoI-NCSA ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist mirror splitdebug"
+IUSE="custom-jdk"
+
+# RDEPENDS may cause false positives in repoman.
+# clion requires cmake and gdb at runtime to build and debug C/C++ projects
+RDEPEND="
+ dev-util/cmake
+ sys-devel/gdb
+ !custom-jdk? ( virtual/jdk )"
+
+QA_PREBUILT="opt/${P}/*"
+
+src_prepare() {
+ default
+
+ local remove_me=(
+ bin/gdb/linux
+ bin/lldb/linux
+ bin/cmake
+ license/CMake*
+ lib/pty4j-native/linux/ppc64le
+ )
+
+ use amd64 || remove_me+=( bin/fsnotifier64 lib/pty4j-native/linux/x86_64)
+ use x86 || remove_me+=( bin/fsnotifier lib/pty4j-native/linux/x86)
+
+ use custom-jdk || remove_me+=( jbr )
+
+ rm -rv "${remove_me[@]}" || die
+}
+
+src_install() {
+ local dir="/opt/${P}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{clion.sh,clang/linux/clang{d,-tidy}}
+
+ if use amd64; then
+ fperms 755 "${dir}"/bin/fsnotifier64
+ fi
+ if use arm; then
+ fperms 755 "${dir}"/bin/fsnotifier-arm
+ fi
+ if use x86; then
+ fperms 755 "${dir}"/bin/fsnotifier
+ fi
+
+ if use custom-jdk; then
+ if [[ -d jbr ]]; then
+ fperms 755 "${dir}"/jbr/bin/{jaotc,java,javac,jdb,jjs,jrunscript,keytool,pack200,rmid,rmiregistry,serialver,unpack200}
+ fi
+ fi
+
+ make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
+ newicon "bin/${PN}.svg" "${PN}.svg"
+ make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ dodir /usr/lib/sysctl.d/
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
+}