summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-24 10:54:04 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-24 10:54:04 +0100
commit97b4b62917ed35ee3ca63c98649ac71458b344d9 (patch)
treea1b192e411ba043ea793585de0f71c68019a2ef6 /dev-util/cookiecutter
parentapp-misc/ddcui: add 0.4.2 (diff)
downloadgentoo-97b4b62917ed35ee3ca63c98649ac71458b344d9.tar.gz
gentoo-97b4b62917ed35ee3ca63c98649ac71458b344d9.tar.bz2
gentoo-97b4b62917ed35ee3ca63c98649ac71458b344d9.zip
dev-util/cookiecutter: add 2.5.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-util/cookiecutter')
-rw-r--r--dev-util/cookiecutter/Manifest1
-rw-r--r--dev-util/cookiecutter/cookiecutter-2.5.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/cookiecutter/Manifest b/dev-util/cookiecutter/Manifest
index 03848576fdfc..1acaf6edfa3c 100644
--- a/dev-util/cookiecutter/Manifest
+++ b/dev-util/cookiecutter/Manifest
@@ -1,3 +1,4 @@
DIST cookiecutter-2.1.1.tar.gz 263100 BLAKE2B 6f054cc5e03328db3198443fe1f99bbef285fe03a1f9bf588b4b80d2314da10f6c998221cf6c41bff9c7fdc3c92680290468dfb070ade4a868ab80f941c1f6a4 SHA512 7833bfc0e6d2d32060e099a97a4477114c2e6f9b09f951c4a5519153fd7c1f9659c22596e443392272f4a6f80eabb2a346417bac56ea7ea4108fc6b36fc0072c
DIST cookiecutter-2.3.1.tar.gz 273620 BLAKE2B 0f2122b0c9c46ece8da03d4431d4ace3bcb2541e91d050af940eac7cd617ed0643db4533c2f4d6709de0e0746417cff0a67d63e490f9c5aaeaff9cf239b97189 SHA512 aa93a40dd82f579ebef894a5ad55798e623809804b6d8322f6fa5787e86bd98b79ea81d16ad3e7bf67570f2449f20d4241e13673fc106e58b2111a10c712bb35
DIST cookiecutter-2.4.0.tar.gz 274072 BLAKE2B bd45803a8f232bd9453afc7f9f43170624d130b788e6cb055cfc31b3e58f097032838e65a5807c71b6ebf740e239e26b51edabaff0353152f7e8f4d008ce56d0 SHA512 c0e1ab6bed36bc57bd56becc8d7f7f3526a7257a95ed37819a8814152f2d06fe4bd5dafab66c508be4cd14fb191fd59ffbf559513c55ff84c4b51131771bc4e6
+DIST cookiecutter-2.5.0.tar.gz 276288 BLAKE2B 8f294d39a385909cf9c23511eae2ad28783ff8da767e31744ded45e4ce15857039d913f5449523a20945328547263f4887d73d44a951b4b29b628fc1dc25c229 SHA512 87ab0d21d6bb98c96cad420a52e08aeebe9a47ee34801a423339453e0099c4eb35950e0180af94dd5dd9373a0292a23c6a5c3bde23d3345c06b059da1294c374
diff --git a/dev-util/cookiecutter/cookiecutter-2.5.0.ebuild b/dev-util/cookiecutter/cookiecutter-2.5.0.ebuild
new file mode 100644
index 000000000000..d73849c2b159
--- /dev/null
+++ b/dev-util/cookiecutter/cookiecutter-2.5.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Command-line utility to create projects from cookiecutters (project templates)"
+HOMEPAGE="https://github.com/cookiecutter/cookiecutter"
+SRC_URI="https://github.com/cookiecutter/cookiecutter/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/arrow[${PYTHON_USEDEP}]
+ >=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ <dev-python/click-9.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ <dev-python/jinja-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.23.0[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+DOCS=( README.md HISTORY.md CONTRIBUTING.md )
+
+PATCHES=(
+ "${FILESDIR}/test_cli-1.7.2.patch"
+)
+
+distutils_enable_tests pytest
+# TODO: Package sphinx-click
+# distutils_enable_sphinx docs \
+# dev-python/sphinx-rtd-theme \
+# dev-python/recommonmark
+
+python_test() {
+ epytest -o addopts=
+}