summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-30 10:11:52 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-30 10:48:00 +0200
commit8c69c869b31e690dee5d416b84b9f476788c5010 (patch)
tree657f61ba048cb705fb5eaa60d12ef6dccc03c9d2 /dev-util/dogtail
parentdev-util/devhelp: enable py3.12 (diff)
downloadgentoo-8c69c869b31e690dee5d416b84b9f476788c5010.tar.gz
gentoo-8c69c869b31e690dee5d416b84b9f476788c5010.tar.bz2
gentoo-8c69c869b31e690dee5d416b84b9f476788c5010.zip
dev-util/dogtail: support python 3.12
Closes: https://bugs.gentoo.org/929536 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-util/dogtail')
-rw-r--r--dev-util/dogtail/dogtail-0.9.11.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-util/dogtail/dogtail-0.9.11.ebuild b/dev-util/dogtail/dogtail-0.9.11.ebuild
index 270b9d73ed9e..dd83202fabeb 100644
--- a/dev-util/dogtail/dogtail-0.9.11.ebuild
+++ b/dev-util/dogtail/dogtail-0.9.11.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 xdg
@@ -43,6 +43,5 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-0.9.10-gentoo-paths.patch
sed -e "s:@EPREFIX_USR@:'${EPREFIX}/usr':" -i sniff/sniff || die "sed failed"
- xdg_src_prepare
distutils-r1_src_prepare
}