summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2018-12-28 02:04:42 +0000
committerMichał Górny <mgorny@gentoo.org>2019-04-29 14:28:20 +0200
commit75875502e51e8b8eaa61674d9e8456c61098339b (patch)
treea6318ec93e43d46c06d60edc277269d7ba27b93a /dev-util/flawfinder/flawfinder-2.0.7.ebuild
parentdev-util/flawfinder: add maintainer to metadata.xml file. (diff)
downloadgentoo-75875502e51e8b8eaa61674d9e8456c61098339b.tar.gz
gentoo-75875502e51e8b8eaa61674d9e8456c61098339b.tar.bz2
gentoo-75875502e51e8b8eaa61674d9e8456c61098339b.zip
dev-util/flawfinder: bump to 2.0.7
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Lucas Ramage <ramage.lucas@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/10699 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/flawfinder/flawfinder-2.0.7.ebuild')
-rw-r--r--dev-util/flawfinder/flawfinder-2.0.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/flawfinder/flawfinder-2.0.7.ebuild b/dev-util/flawfinder/flawfinder-2.0.7.ebuild
new file mode 100644
index 000000000000..773f6f36ef09
--- /dev/null
+++ b/dev-util/flawfinder/flawfinder-2.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="https://www.dwheeler.com/flawfinder/"
+SRC_URI="https://www.dwheeler.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i "s/${PN}.1.gz/${PN}.1/g" setup.py || die 'sed failed.'
+ default
+}
+
+src_test() {
+ emake test
+}
+
+python_install_all() {
+ local DOCS=( announcement ChangeLog README.md ${PN}.pdf )
+ distutils-r1_python_install_all
+}