summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-12 03:00:54 +0100
committerSam James <sam@gentoo.org>2023-05-12 03:55:36 +0100
commit173b5091da7b6aa2f775943f24912e1a8616d9a4 (patch)
tree66d477203eede46589e5d9522426ca5a93b536f4 /dev-util/lv2lint
parentdev-python/docker-py: Bump to 6.1.2 (diff)
downloadgentoo-173b5091da7b6aa2f775943f24912e1a8616d9a4.tar.gz
gentoo-173b5091da7b6aa2f775943f24912e1a8616d9a4.tar.bz2
gentoo-173b5091da7b6aa2f775943f24912e1a8616d9a4.zip
dev-util/lv2lint: new package, add 0.16.2
Test dep of media-plugins/mda-lv2. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/lv2lint')
-rw-r--r--dev-util/lv2lint/Manifest1
-rw-r--r--dev-util/lv2lint/files/lv2lint-0.16.2-tests-optional.patch48
-rw-r--r--dev-util/lv2lint/lv2lint-0.16.2.ebuild35
-rw-r--r--dev-util/lv2lint/metadata.xml8
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-util/lv2lint/Manifest b/dev-util/lv2lint/Manifest
new file mode 100644
index 000000000000..bcef3e9e3ddc
--- /dev/null
+++ b/dev-util/lv2lint/Manifest
@@ -0,0 +1 @@
+DIST lv2lint-0.16.2.tar.gz 69506 BLAKE2B db221cb2e5e7a25c1a962ae7b1376adce24d593ca871b444fe3bd1a333aedfddcb02bafd5a3dbf4cf1da015b54dc7ca59e3e37208c1902390c524c6b005a83bc SHA512 8abd393832179f526d15b141a88239af355cdcccd9284e44c3deea2e4d189959242311993d6ef04aea5634d02e01f659cd4141092668cf9b7e13c1d136923ce8
diff --git a/dev-util/lv2lint/files/lv2lint-0.16.2-tests-optional.patch b/dev-util/lv2lint/files/lv2lint-0.16.2-tests-optional.patch
new file mode 100644
index 000000000000..a38d87bff94b
--- /dev/null
+++ b/dev-util/lv2lint/files/lv2lint-0.16.2-tests-optional.patch
@@ -0,0 +1,48 @@
+https://git.open-music-kontrollers.ch/~hp/lv2lint/commit/b9ee588bff38bcdc52859d2b2167e47feadf6a0d.patch
+
+From b9ee588bff38bcdc52859d2b2167e47feadf6a0d Mon Sep 17 00:00:00 2001
+From: Hanspeter Portner <dev@open-music-kontrollers.ch>
+Date: Fri, 5 May 2023 12:04:53 +0200
+Subject: [PATCH] Add build-tests configure option
+
+--- a/meson.build
++++ b/meson.build
+@@ -29,6 +29,7 @@ x11_tests = get_option('x11-tests')
+ reuse = find_program('reuse', required : false)
+
+ version = get_option('version')
++build_tests = get_option('build-tests')
+
+ prefix= get_option('prefix')
+ libdir= get_option('libdir')
+@@ -133,9 +134,11 @@ configure_file(
+ install : true,
+ install_dir : 'bin')
+
+-if reuse.found()
+- test('REUSE', reuse, args : [
+- '--root', meson.current_source_dir(),
+- 'lint'
+- ])
++if build_tests
++ if reuse.found()
++ test('REUSE', reuse, args : [
++ '--root', meson.current_source_dir(),
++ 'lint'
++ ])
++ endif
+ endif
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,7 +1,8 @@
+ # SPDX-FileCopyrightText: Hanspeter Portner <dev@open-music-kontrollers.ch>
+ # SPDX-License-Identifier: CC0-1.0
+
++option('build-tests', type : 'boolean', value : true)
+ option('online-tests', type : 'feature', value : 'disabled')
+ option('elf-tests', type : 'feature', value : 'disabled')
+ option('x11-tests', type : 'feature', value : 'disabled')
+-option('version', type : 'string', value : '0.17.81')
++option('version', type : 'string', value : '0.17.83')
+--
+2.38.4
diff --git a/dev-util/lv2lint/lv2lint-0.16.2.ebuild b/dev-util/lv2lint/lv2lint-0.16.2.ebuild
new file mode 100644
index 000000000000..feeeadef363b
--- /dev/null
+++ b/dev-util/lv2lint/lv2lint-0.16.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Check whether a given LV2 plugin is up to the specification"
+HOMEPAGE="https://git.open-music-kontrollers.ch/~hp/lv2lint"
+SRC_URI="https://git.open-music-kontrollers.ch/~hp/lv2lint/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Artistic-2 CC0-1.0 ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/lilv
+ media-libs/lv2
+ virtual/libelf
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # TODO: on next release (>0.16.2), wire up -Dbuild-tests
+ local emesonargs=(
+ -Db_lto=false
+
+ # See README, these are for runtime tests of *other* things (plugins)
+ -Donline-tests=disabled
+ -Delf-tests=enabled
+ -Dx11-tests=disabled
+ )
+
+ meson_src_configure
+}
diff --git a/dev-util/lv2lint/metadata.xml b/dev-util/lv2lint/metadata.xml
new file mode 100644
index 000000000000..e780015e9754
--- /dev/null
+++ b/dev-util/lv2lint/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>proaudio@gentoo.org</email>
+ <name>Gentoo ProAudio Project</name>
+ </maintainer>
+</pkgmetadata>