summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-10-02 00:38:16 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-10-02 00:49:18 +0200
commitdb4cef3d3556af1b65535199b3a40dc35b987dc1 (patch)
tree96c54a148a7df06b0aa0b02217f9659ea2e76ed3 /dev-util/makepp/makepp-2.0.99.1.ebuild
parentdev-util/checkbashisms: Bump to v2.17.10 (diff)
downloadgentoo-db4cef3d3556af1b65535199b3a40dc35b987dc1.tar.gz
gentoo-db4cef3d3556af1b65535199b3a40dc35b987dc1.tar.bz2
gentoo-db4cef3d3556af1b65535199b3a40dc35b987dc1.zip
dev-util/makepp: Bump to v2.0.99.1
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-util/makepp/makepp-2.0.99.1.ebuild')
-rw-r--r--dev-util/makepp/makepp-2.0.99.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/makepp/makepp-2.0.99.1.ebuild b/dev-util/makepp/makepp-2.0.99.1.ebuild
new file mode 100644
index 000000000000..673b76c61cd9
--- /dev/null
+++ b/dev-util/makepp/makepp-2.0.99.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV=${PV/_}
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="GNU make replacement"
+HOMEPAGE="http://makepp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/2.1/${MY_P}.txz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="dev-lang/perl:="
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # default "all" rule is to run tests :x
+ sed -i '/^all:/s:test::' config.pl || die
+ default
+}
+
+src_configure() {
+ # not an autoconf configure script
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --bindir="${EPREFIX}"/usr/bin \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --mandir="${EPREFIX}"/usr/share/man \
+ --datadir="${EPREFIX}"/usr/share/makepp \
+ || die "configure failed"
+}
+
+src_test() {
+ # work around https://bugzilla.samba.org/show_bug.cgi?id=8728
+ export CCACHE_UNIFY=1
+ ROOT= default
+}