summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-12-22 12:08:44 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-12-22 12:37:24 -0500
commitdb21b95652247c4181a0b92e47421f885d942c66 (patch)
treef712aea4be3aff406f5e5dcd38cce4a88df786a2 /dev-util/mingw64-toolchain
parentpackage.mask: Last rite media-gfx/figurine (diff)
downloadgentoo-db21b95652247c4181a0b92e47421f885d942c66.tar.gz
gentoo-db21b95652247c4181a0b92e47421f885d942c66.tar.bz2
gentoo-db21b95652247c4181a0b92e47421f885d942c66.zip
dev-util/mingw64-toolchain: unset DLLTOOL for cross
Rarely set but, if it is, can result in using llvm-dlltool when it should be using mingw's, and ultimately fails. Closes: https://bugs.gentoo.org/920483 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/mingw64-toolchain')
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
index 1a08ba3e0844..7196f0b85f19 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
@@ -202,7 +202,7 @@ src_compile() {
if [[ ${1} == -x ]]; then
(
# cross-compiling, cleanup and let ./configure handle it
- unset AR AS CC CPP CXX LD NM OBJCOPY OBJDUMP RANLIB RC STRIP
+ unset AR AS CC CPP CXX DLLTOOL LD NM OBJCOPY OBJDUMP RANLIB RC STRIP
CHOST=${CTARGET}
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849