summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2023-01-25 00:42:27 +0100
committerArsen Arsenović <arsen@gentoo.org>2023-01-25 00:43:14 +0100
commitf04373852bead94cabf5d78e8dcb7b588eeeac05 (patch)
treea5bafc598759636c26b184b15aabdeba52500ea8 /dev-util/poke
parentdev-util/poke: Fix minor typo in alpha check (diff)
downloadgentoo-f04373852bead94cabf5d78e8dcb7b588eeeac05.tar.gz
gentoo-f04373852bead94cabf5d78e8dcb7b588eeeac05.tar.bz2
gentoo-f04373852bead94cabf5d78e8dcb7b588eeeac05.zip
dev-util/poke: add 2.90.1
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'dev-util/poke')
-rw-r--r--dev-util/poke/Manifest2
-rw-r--r--dev-util/poke/poke-2.90.1.ebuild119
2 files changed, 120 insertions, 1 deletions
diff --git a/dev-util/poke/Manifest b/dev-util/poke/Manifest
index 06df80592dde..fc8383cb9cd6 100644
--- a/dev-util/poke/Manifest
+++ b/dev-util/poke/Manifest
@@ -1,3 +1,3 @@
DIST poke-2.3.tar.gz 7369945 BLAKE2B fe9274099a9ddacf1f46b7cec1f98cc6c442b24f149efbf4320a74a270dc8bad7cf3f87df817c9968a13ece763573b36f0ec99699cb9c7742b7be9023a4fca39 SHA512 101ef0009676c02f72ffb4889a02c9a161f29f412685249c7166f69077b0cd1b19d940567ebb86894bacf2278a2e138354fd49456f12b05a4c1957f437ff1d86
DIST poke-2.4.tar.gz 7372092 BLAKE2B 64b8b22713bb581c30b624200c0a283a8de548895db2c21d83babbb18a93f3a8975dd7af752bd7ea856242f90035add249fbb62462ac632bec351598bcca0fe5 SHA512 6fa1097a5cbbd4171b6a390934c5648b4c382b8b8c8dd4955bba82cb57107f67e23b39f2df2081904a02f457e6c5b2d10baed710da3ed4b9b9eab3f4127e12bc
-DIST poke-2.90.0.tar.gz 7503533 BLAKE2B d5ceb3ae95025d34ba6efb14b437d9bb4c24c2bbdd782a551ca58ef45044c6059f073816a95a5eafe6d2e44eed5cb32b006a6bdbd74143d1b2ae0f885c131be8 SHA512 44e48988b20ddfebc988be9027455e9dda5a59aef09822967f275645b07155971b6de2e4554560c825df19625e01fc565469488826d6f687c92865f45ab35065
+DIST poke-2.90.1.tar.gz 7512925 BLAKE2B 38c9283f1c0b183b1b74c2ebd347edf6e9a9191d19070f7da32e6b0f520ec8197be3a813bc98160b47363cd11069bdaf84bb528498fe51cf2dcadf0bfa06a25e SHA512 f5823bed61ab64c2cdde83c918716fe64ad5552499023b2f5202130d6b2bab405c9d1cb1e12c7f190749689d86bf36f4edfe140ce748ac4c5f03d219197558d3
diff --git a/dev-util/poke/poke-2.90.1.ebuild b/dev-util/poke/poke-2.90.1.ebuild
new file mode 100644
index 000000000000..6bb0f34eb2c4
--- /dev/null
+++ b/dev-util/poke/poke-2.90.1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common flag-o-matic
+
+DESCRIPTION="Extensible editor for structured binary data"
+HOMEPAGE="https://www.jemarch.net/poke"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/poke.git"
+ REGEN_BDEPEND="
+ >=sys-devel/autoconf-2.62
+ >=sys-devel/automake-1.16
+ sys-apps/gawk
+ sys-apps/help2man
+ sys-apps/texinfo
+ sys-devel/bison
+ sys-devel/flex
+ "
+elif [[ $(ver_cut 2) -ge 90 || $(ver_cut 3) -ge 90 ]]; then
+ SRC_URI="https://alpha.gnu.org/gnu/poke/${P}.tar.gz"
+ REGEN_BDEPEND=""
+else
+ SRC_URI="mirror://gnu/poke/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ REGEN_BDEPEND=""
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="emacs pvm-profiling nbd nls test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boehm-gc:=
+ dev-libs/libatomic_ops
+ sys-devel/gettext
+ sys-libs/readline:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+ nbd? ( sys-libs/libnbd )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( nbd? ( sys-libs/libnbd[uri-support] ) )
+"
+BDEPEND="
+ ${REGEN_BDEPEND}
+ virtual/pkgconfig
+ emacs? ( >=app-editors/emacs-23.1:* )
+ test? (
+ dev-util/dejagnu
+ nbd? ( sys-block/nbdkit )
+ )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_setup() {
+ use emacs && elisp-check-emacs-version
+}
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]]; then
+ ./bootstrap || die
+ fi
+}
+
+src_configure() {
+ # See bug 858461.
+ # Upstream support might happen one day. For context, only one file needs
+ # LTO to be disabled (since it's an autogenerated bytecode interpreter),
+ # others do not. The build system will handle this at some point in the
+ # future. Until then, just filter out LTO.
+ filter-lto
+
+ local myconf=(
+ --with-lispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --enable-hserver
+ $(use_enable nbd libnbd)
+ $(use_enable pvm-profiling)
+ $(use_enable nls)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ cd etc || die
+ elisp-compile *.el
+ fi
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ cd etc || die
+ elisp-install "${PN}" *.el *.elc
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}