summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-08-08 17:41:39 +0200
committerSam James <sam@gentoo.org>2022-08-23 06:26:04 +0100
commitf9d84da1e0a2a148a66b2ff2ab1055ed3d8ea00a (patch)
treefb6eeb5fd7f3963e4acc619e56fd071cb3f74a4a /dev-util/ropper
parentdev-util/ropper: add .gh suffix to tagged distfiles (live) (diff)
downloadgentoo-f9d84da1e0a2a148a66b2ff2ab1055ed3d8ea00a.tar.gz
gentoo-f9d84da1e0a2a148a66b2ff2ab1055ed3d8ea00a.tar.bz2
gentoo-f9d84da1e0a2a148a66b2ff2ab1055ed3d8ea00a.zip
dev-util/ropper: add 1.13.8
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/26786 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/ropper')
-rw-r--r--dev-util/ropper/Manifest1
-rw-r--r--dev-util/ropper/ropper-1.13.8.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/ropper/Manifest b/dev-util/ropper/Manifest
index b34bde057d47..75aed993293a 100644
--- a/dev-util/ropper/Manifest
+++ b/dev-util/ropper/Manifest
@@ -1 +1,2 @@
DIST ropper-1.13.7.tar.gz 1491228 BLAKE2B 24e3f4d2454cad2b4ba8f365a4da4060f0aadc4e78423388024adbf2b58d33276e68ed92f7b778b9a7d9eda057c6a1675a67c43c93df4d378605c08720d97197 SHA512 1d93c4d58454bbd5cfb6a4a7a69f571294613e10e77cae6a65eaf7b9a5c977a3b82c888bd414d1b3e6a1082ba7cd9f2121253bf849dff2a40cdb34acb1371acf
+DIST ropper-1.13.8.gh.tar.gz 1491769 BLAKE2B 8601bcd2287763aa208b227c437362b9799ec1775104b659213e69a77f118bce567e95a0b83a4f0556439a82ee853ebc9aabaa4098b2a700572d1b661213eb25 SHA512 eae2279e1c6bc91af76e8e5d37b7d57c5d2e518d027e293dbd52c6c27dcd8826e73673c55fe581cdefda272b657c8eff2b5eb4fdc4996fec1548709b8371b5d4
diff --git a/dev-util/ropper/ropper-1.13.8.ebuild b/dev-util/ropper/ropper-1.13.8.ebuild
new file mode 100644
index 000000000000..715beb97d20b
--- /dev/null
+++ b/dev-util/ropper/ropper-1.13.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use to display information about binary files in different file formats"
+HOMEPAGE="https://scoding.de/ropper https://github.com/sashs/Ropper"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sashs/Ropper"
+else
+ SRC_URI="https://github.com/sashs/Ropper/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}"/Ropper-${PV}
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="z3"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/capstone[python,${PYTHON_USEDEP}]
+ dev-libs/keystone[python,${PYTHON_USEDEP}]
+ dev-python/filebytes[${PYTHON_USEDEP}]
+ ')
+ z3? ( sci-mathematics/z3[python,${PYTHON_SINGLE_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Remove test which dies on trying to import itself (stub loader, not a real test)
+ rm test.py || die
+
+ distutils-r1_src_prepare
+}