summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-16 06:00:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-16 06:40:09 +0100
commit29fc50316b494a607e01334c642a6f7221f5c0a1 (patch)
treea3c5aabeda95c036361c448460691564a06ccf35 /dev-util/stripe-mock
parentdev-python/cryptography: Bump to 42.0.3 (diff)
downloadgentoo-29fc50316b494a607e01334c642a6f7221f5c0a1.tar.gz
gentoo-29fc50316b494a607e01334c642a6f7221f5c0a1.tar.bz2
gentoo-29fc50316b494a607e01334c642a6f7221f5c0a1.zip
dev-util/stripe-mock: Bump to 0.182.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.182.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 2453f42b1ed0..4f13a56948bb 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1 +1,2 @@
DIST stripe-mock-0.181.0.tar.gz 1510851 BLAKE2B f1cecc0db71aa962d36060b5b5b59d6547e5f94a052ddc92048dcaf2170416118d5b00deff877810fb96fe199b4944b0f22f3d8fd6c09cd1802cba5164fe4c9e SHA512 a1b1f3ce17757233650c5082d795404fe1e18f622719e3dd2a31aa9e9558db72324167e09307f02dc9b4d28e85d9e4101c239d3035aa7746eda20a0484a166d7
+DIST stripe-mock-0.182.0.tar.gz 1531682 BLAKE2B 35a2b81646cd3bcd57b9b45b12bfa19f16be8337ac3261e163fd68daf33b2fce2eb6b655bf17b7858ef6d63296c404dae7798195ec957b7f73752365688b1f0e SHA512 cdfab6c73554e978bec77047eaff74af9d3a3e48f79b7118c8f9603275adcf825076e70fcf84c49bd561de0748c496df5ff4a2cf4d366e39ab82d7c734f8c456
diff --git a/dev-util/stripe-mock/stripe-mock-0.182.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.182.0.ebuild
new file mode 100644
index 000000000000..352d14e2ce00
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.182.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock/"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}