summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-12 14:03:50 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-12 14:06:35 +0100
commit5375e034e1432a6a6e0d941411de59f080123203 (patch)
tree474251cad8613bfcdfdd2b3c8f1719a11e1b6603 /dev-util
parentdev-util/rosdep: Remove old (diff)
downloadgentoo-5375e034e1432a6a6e0d941411de59f080123203.tar.gz
gentoo-5375e034e1432a6a6e0d941411de59f080123203.tar.bz2
gentoo-5375e034e1432a6a6e0d941411de59f080123203.zip
dev-util/rosdep: bump to 0.12.1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rosdep/Manifest1
-rw-r--r--dev-util/rosdep/rosdep-0.12.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/rosdep/Manifest b/dev-util/rosdep/Manifest
index a0d309bc480d..5f796fbb3ed0 100644
--- a/dev-util/rosdep/Manifest
+++ b/dev-util/rosdep/Manifest
@@ -1 +1,2 @@
DIST rosdep-0.11.8.tar.gz 112899 BLAKE2B 863cb6caaa1748477ec6216dbcdaf1c547135e2aaddb533373d20cc84bef51f640ce3544aaf99821c749b953effd594cc1909ca7e05d6fb3e277ae806747c5a8 SHA512 9fe44eb2dbcdfce0ac6df9b4f6926d26fa12d9fe4089976a460448dc6d4ecb893c0c7cb6b6e9f16bd07da0be4088d7d3eb594d2c0fad6f77d8728e2873cbc344
+DIST rosdep-0.12.1.tar.gz 117102 BLAKE2B 42b0f6e7b6b0c2a4219bce24ff74ec01efb61ac0799a89baa5dc7f6b698e8f69a1578f744179252e7123c87c9fb0368b43a9a293609b28f6bfbc32c87b5f4627 SHA512 031bdfb4877865cacfab63a4494807ecf157d8514e89c7ab15e38fcbd4664df1247874975d7b1af42a8a1fc24cb62a558bd6b43732946f3122ffa6448a7631da
diff --git a/dev-util/rosdep/rosdep-0.12.1.ebuild b/dev-util/rosdep/rosdep-0.12.1.ebuild
new file mode 100644
index 000000000000..c2b6878d6ac3
--- /dev/null
+++ b/dev-util/rosdep/rosdep-0.12.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdep"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tool for installing ROS system dependencies"
+HOMEPAGE="http://wiki.ros.org/rosdep"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/ros-infrastructure/rosdep/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-coverage --cover-package=rosdep2 --with-xunit test || die
+}
+
+pkg_postrm() {
+ if [ "${ROOT:-/}" = "/" ] ; then
+ einfo "Removing rosdep default sources list."
+ rm -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list"
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT:-/}" = "/" -a ! -f "${EPREFIX}/etc/ros/rosdep/sources.list.d/20-default.list" ] ; then
+ einfo "Initializing rosdep"
+ rosdep init
+ fi
+}