summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2023-12-19 22:31:07 +0100
committerJonas Stein <jstein@gentoo.org>2023-12-19 22:31:07 +0100
commit6b967d8ae919ccf2f341e23d9a5482590b512b06 (patch)
treef3a63e21a9747683e985b128c865c2a53a56cb39 /dev-util
parentdev-python/PyQt6: cleanup unnecessary (-) (diff)
downloadgentoo-6b967d8ae919ccf2f341e23d9a5482590b512b06.tar.gz
gentoo-6b967d8ae919ccf2f341e23d9a5482590b512b06.tar.bz2
gentoo-6b967d8ae919ccf2f341e23d9a5482590b512b06.zip
dev-util/reuse: new package, add 2.1.0
Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/reuse/Manifest1
-rw-r--r--dev-util/reuse/files/reuse-2.1.0_docs.patch15
-rw-r--r--dev-util/reuse/metadata.xml13
-rw-r--r--dev-util/reuse/reuse-2.1.0.ebuild50
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-util/reuse/Manifest b/dev-util/reuse/Manifest
new file mode 100644
index 000000000000..9a61e30a670b
--- /dev/null
+++ b/dev-util/reuse/Manifest
@@ -0,0 +1 @@
+DIST reuse-2.1.0.gh.tar.gz 260786 BLAKE2B 371c1167e10449ecdbaf0a93dbfa7d50c700daaf71394379a48d1baaae0b1be03728e79fd551da75a3743e06cae1a77e7445482222845d1356a6af3eb39bef46 SHA512 912d713b2c68029cc67a5fbebfca61d96165ae8ae9d927bbdd651cf2130104b297d5c0133f1a46442cba3ec84d00ba92c27414bff770d2250f5a2131c7ad4aef
diff --git a/dev-util/reuse/files/reuse-2.1.0_docs.patch b/dev-util/reuse/files/reuse-2.1.0_docs.patch
new file mode 100644
index 000000000000..a9f19a8ea0a4
--- /dev/null
+++ b/dev-util/reuse/files/reuse-2.1.0_docs.patch
@@ -0,0 +1,15 @@
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -189,9 +189,9 @@
+ """Copy the markdown files from the root of the project into the docs/
+ directory.
+ """
+- copyfile("../README.md", "readme.md")
+- copyfile("../CHANGELOG.md", "history.md")
+- copyfile("../CONTRIBUTING.md", "contributing.md")
++ copyfile("README.md", "docs/readme.md")
++ copyfile("CHANGELOG.md", "docs/history.md")
++ copyfile("CONTRIBUTING.md", "docs/contributing.md")
+
+
+ def setup(app):
diff --git a/dev-util/reuse/metadata.xml b/dev-util/reuse/metadata.xml
new file mode 100644
index 000000000000..22d7a2c8d2d4
--- /dev/null
+++ b/dev-util/reuse/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jstein@gentoo.org</email>
+ <name>Jonas Stein</name>
+ </maintainer>
+ <upstream>
+ <doc>https://reuse.readthedocs.io/</doc>
+ <remote-id type="pypi">reuse</remote-id>
+ <remote-id type="github">fsfe/reuse-tool</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/reuse/reuse-2.1.0.ebuild b/dev-util/reuse/reuse-2.1.0.ebuild
new file mode 100644
index 000000000000..097ea77f1667
--- /dev/null
+++ b/dev-util/reuse/reuse-2.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Manage license information according to the SPDX standard"
+HOMEPAGE="https://reuse.software/
+ https://github.com/fsfe/reuse-tool"
+MY_PN="${PN}-tool"
+SRC_URI="https://github.com/fsfe/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0 CC0-1.0 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/boolean-py-3.8[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/license-expression-1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-debian-0.1.48[${PYTHON_USEDEP}]"
+
+BDEPEND="sys-devel/gettext
+ test? (
+ dev-vcs/git
+ dev-vcs/mercurial
+ )"
+
+PATCHES=( "${FILESDIR}/reuse-2.1.0_docs.patch" )
+
+DOCS=( AUTHORS.rst CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md README.md )
+
+distutils_enable_tests pytest
+
+# dev-python/sphinx-autodoc-typehints will be dropped after 2.1.0
+distutils_enable_sphinx docs \
+ ">=dev-python/furo-2023.3.27" \
+ ">=dev-python/recommonmark-0.7.1" \
+ ">=dev-python/sphinxcontrib-apidoc-0.3.0" \
+ ">=dev-python/sphinx-autodoc-typehints-1.12.0"
+
+python_test() {
+ cd "${T}" || die
+ epytest "${S}"/tests
+}