summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-06-30 20:10:17 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-06-30 20:32:30 -0400
commit6f4e16b5e58cc8fefc98b02ca05f9f8e067effa5 (patch)
tree8602b43ef3c0e69fb9c4cfed18ad471c6a15743e /dev-util
parentsci-libs/gsl: fudge tolerance to fix a flaky test (diff)
downloadgentoo-6f4e16b5e58cc8fefc98b02ca05f9f8e067effa5.tar.gz
gentoo-6f4e16b5e58cc8fefc98b02ca05f9f8e067effa5.tar.bz2
gentoo-6f4e16b5e58cc8fefc98b02ca05f9f8e067effa5.zip
dev-util/maturin: skip failing test_macosx_deployment_target on sparc
Been failing since rust-1.74 likely due to how it does something different for >=1.74, and then there is no reason for this to block stable given 1.4.0 is affected as well. Plus that a macosx deploy test fails seems unlikely to affect building revdeps with the pep517 backend (seems unlikely anyone uses it for more than that on sparc). Bug: https://bugs.gentoo.org/934573 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/maturin/maturin-1.6.0.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-util/maturin/maturin-1.6.0.ebuild b/dev-util/maturin/maturin-1.6.0.ebuild
index 3cacc1f2019a..7ccc0e295185 100644
--- a/dev-util/maturin/maturin-1.6.0.ebuild
+++ b/dev-util/maturin/maturin-1.6.0.ebuild
@@ -549,6 +549,9 @@ python_test() {
# to find the system's dev-python/uv (not worth the trouble)
--skip develop_hello_world::case_2
--skip develop_pyo3_ffi_pure::case_2
+ # fails on sparc since rust-1.74 (bug #934573), skip for now given
+ # should not affect the pep517 backend which is all we need on sparc
+ $(usev sparc '--skip build_context::test::test_macosx_deployment_target')
)
cargo_src_test -- "${skip[@]}"