summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-08-31 14:40:30 -0400
committerMike Pagano <mpagano@gentoo.org>2024-08-31 14:40:30 -0400
commite0dd5255dfa0d54375e3eb0018ca463e7a015a44 (patch)
treea8f34b99caa352448ae66a5791db05ffc9084c55 /dev-util
parentapp-crypt/jitterentropy-rngd: remove empty IUSE (diff)
downloadgentoo-e0dd5255dfa0d54375e3eb0018ca463e7a015a44.tar.gz
gentoo-e0dd5255dfa0d54375e3eb0018ca463e7a015a44.tar.bz2
gentoo-e0dd5255dfa0d54375e3eb0018ca463e7a015a44.zip
dev-util/idea-community: add 2024.2.1
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/idea-community/Manifest2
-rw-r--r--dev-util/idea-community/idea-community-2024.2.1.ebuild135
2 files changed, 137 insertions, 0 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index 5ef60592e792..db804498b08f 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,2 +1,4 @@
DIST idea-community-2024.2.0.2-aarch64.tar.gz 994007824 BLAKE2B 08727c3e808edbb70ec546bbf73aef8abe499a7bb36ab5fd18972318d4cc31aa6485aeccf6b6b40af7fc0c0a136aab229fbb99f7b55d22dd76454f48edc0d6e5 SHA512 45ab7604575c792416dd4c5f44194b590e68d8908fbd25be815409376fc4df1f1560e6e8299237acf32e3ea0bbce3ea03dd1542c687a9e8e23845feb972f4c69
DIST idea-community-2024.2.0.2-amd64.tar.gz 994626688 BLAKE2B f94d3f90349035aa00023fbf8ecc27fa14507a434e0b04f5b2e3db16104c4eb892f8f34544d6bb1d5377e27f5782b4300dca7762704df84baf3aa457137c38ba SHA512 dc63a6a3916a4990cf3b8f013703af01e1f95df02a222d40989e62dbd153f1df24c3b4c6abfbc941143d7d41e322f7d122717ae1376769f8e79ed0d1c6c3980b
+DIST idea-community-2024.2.1-aarch64.tar.gz 880188596 BLAKE2B c688414140ca48921e952590b040c7bf1193b4154fdd5a6e99d867de3f547d8c212c7342c37482bf1d60e5eda3953a3d31b245872d4cfa46361eabc687102af2 SHA512 9beac9d5ec3f5a691de14588dd3c55575c2ec5535964f0e5ff3e7fb494d41b2a76268d13cd527c0c1b894eca3214437214ac805518325b85384955575e4082d5
+DIST idea-community-2024.2.1-amd64.tar.gz 880814955 BLAKE2B b644d1f955b5e7ef26c76aee20044fceb50955f7c5ad83d063f24aca4f38289e3885ae722e360e7f053a46591b8ea6d783fda9314e39e291fd542c1ef5a6647c SHA512 393bcdab1d5738822b8433a6b0c54d4da7ea47f3e48b9fe39057e0ef779031eda5fe290e4fb3f03fdd1a5b136041b7e2a08cbfa4b9a24efa41ef05a8cd079edc
diff --git a/dev-util/idea-community/idea-community-2024.2.1.ebuild b/dev-util/idea-community/idea-community-2024.2.1.ebuild
new file mode 100644
index 000000000000..b61f2c92242b
--- /dev/null
+++ b/dev-util/idea-community/idea-community-2024.2.1.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit desktop wrapper
+
+MY_PV=$(ver_cut 1-3)
+
+DESCRIPTION="A complete toolset for web, mobile and enterprise development"
+HOMEPAGE="https://www.jetbrains.com/idea"
+
+SRC_URI="
+ amd64? ( https://download.jetbrains.com/idea/ideaIC-${MY_PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm64? ( https://download.jetbrains.com/idea/ideaIC-${MY_PV}-aarch64.tar.gz -> ${P}-aarch64.tar.gz )
+ "
+
+S="${WORKDIR}/idea-IC-${PV}"
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
+ codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
+ GPL-2 GPL-2-with-classpath-exception ISC
+ JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
+ MPL-1.0 MPL-1.1 OFL-1.1 ZLIB"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ || (
+ >=dev-java/openjdk-17.0.8.1_p1:17
+ >=dev-java/openjdk-bin-17.0.8.1_p1:17
+ )"
+
+RDEPEND="${DEPEND}
+ sys-libs/glibc
+ media-libs/harfbuzz
+ dev-java/jansi-native
+ dev-libs/libdbusmenu"
+
+BDEPEND="dev-util/patchelf"
+RESTRICT="splitdebug"
+
+QA_PREBUILT="opt/${PN}/*"
+
+src_unpack() {
+
+ default_src_unpack
+ if [ ! -d "$S" ]; then
+ einfo "Renaming source directory to predictable name..."
+ mv $(ls "${WORKDIR}") "idea-IC-${PV}" || die
+ fi
+}
+
+src_prepare() {
+
+ default_src_prepare
+
+ if use amd64; then
+ JRE_DIR=jre64
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-aarch64/libquiche.so
+ else
+ JRE_DIR=jre
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-x86-64/libquiche.so
+ fi
+
+ PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
+
+ # rm LLDBFrontEnd after licensing questions with Gentoo License Team
+ rm -vf "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend
+ rm -vf ${PLUGIN_DIR}/libavplugin*
+ rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
+ rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
+ rm -vf "${S}"/bin/libdbm64*
+ rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
+
+ if [[ -d "${S}"/"${JRE_DIR}" ]]; then
+ for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
+ do
+ if [[ -f "$file" ]]; then
+ patchelf --set-rpath '$ORIGIN' $file || die
+ fi
+ done
+ fi
+
+ rm -vf "${S}"/lib/pty4j-native/linux/x86-64/libpty.so
+
+ sed -i \
+ -e "\$a\\\\" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
+ -e "\$a# package manager. See bug #704494" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
+
+ eapply_user
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+ local dst="${D}${dir}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{format.sh,idea,idea.sh,inspect.sh,restarter,fsnotifier}
+ if use amd64; then
+ JRE_DIR=jre
+ JRE_DIR=jre
+ fi
+
+ JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
+ if [[ -d ${JRE_DIR} ]]; then
+ for jrebin in $JRE_BINARIES; do
+ fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
+ done
+ fi
+
+ # bundled script is always lowercase, and doesn't have -ultimate, -professional suffix.
+ local bundled_script_name="${PN%-*}.sh"
+ make_wrapper "${PN}" "${dir}/bin/$bundled_script_name" || die
+
+ local pngfile="$(find ${dst}/bin -maxdepth 1 -iname '*.png')"
+ newicon $pngfile "${PN}.png" || die "we died"
+
+ make_desktop_entry "/opt/idea-community/bin/idea" "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+
+ # remove bundled harfbuzz
+ rm -f "${D}"/lib/libharfbuzz.so || die "Unable to remove bundled harfbuzz"
+
+ # remove bundled java
+ rm -r ${dst}/jbr || die "Unable to remove bundled java"
+
+}