summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-08-27 11:00:08 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-08-27 14:03:02 +0200
commitffd4b05b5fbbfdb142a42d6117de812a53e0085c (patch)
treee212068c39fbfab468ec937a7637052e0da81d90 /dev-util
parentwww-apps/rutorrent: drop old (diff)
downloadgentoo-ffd4b05b5fbbfdb142a42d6117de812a53e0085c.tar.gz
gentoo-ffd4b05b5fbbfdb142a42d6117de812a53e0085c.tar.bz2
gentoo-ffd4b05b5fbbfdb142a42d6117de812a53e0085c.zip
dev-util/lttng-ust: add 2.13.8
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/lttng-ust/Manifest1
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.13.8.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/Manifest b/dev-util/lttng-ust/Manifest
index 55abe0bc0280..9cb46eed5c4c 100644
--- a/dev-util/lttng-ust/Manifest
+++ b/dev-util/lttng-ust/Manifest
@@ -2,3 +2,4 @@ DIST lttng-ust-2.12.0.tar.bz2 853127 BLAKE2B 6a6655a4aa33ec6318255d05d0e000c19fb
DIST lttng-ust-2.12.1.tar.bz2 859667 BLAKE2B 474d03ac0d3c1102ef085230659545f3e12bc0847cebab598f2998741741cb98ac139812a296992614dd90ed9478040ee0567822eb20e960e0a6489836274394 SHA512 6d5116a88be601f96513535ef7dfda409780cbacaab0831dc76b86070da60d5eac719d7020f70a6821e1c6dbbfae05ddf5a431662ef5a714fc200c2216eeb80e
DIST lttng-ust-2.12.9.tar.bz2 800795 BLAKE2B 467500f7fd0f473a5cd7af6c23e8f0f83516d57ad573f92c48354bbe1ea1d2fea08bd20d7675e7698adf2284a5069fd23d3a929bc11df0ba157a99091b543777 SHA512 5edaa6c015bccd710e7bfea136398e8bc784946c22933a011f4b31b9c13fa772c4f03d0c42543bf0d08a810922498ff1fa56d4bccd9c5b8c4b14925c849c6c9b
DIST lttng-ust-2.13.6.tar.bz2 1351915 BLAKE2B c350a7302e38035ef7c6727ea942907ec606c88862ae875bed0a7c833f233b4159405bcb7a41549dccf3d79491151066d593c52d9f06b95b61c345ccbace62f5 SHA512 15458f8dd0ad6fa96a9cf7569ffabadfddcaa70b822b69b39d4d7dfba3701c9489706b06f12f9d7e376147299fb3cfc6fe1213d46d510bdb7b3dc834271da55f
+DIST lttng-ust-2.13.8.tar.bz2 1358168 BLAKE2B f4f623c9c1a37395312270803c7e845ba76d6075c10cc6bdcfdd6f35d0cb6db9c303a9fb8c33a50e201c84fd772ed60611bfce9e962e27c4d5820b6ef0ac2d66 SHA512 f61f7e1633051a4d515ba28d4945b96a84eab8a8143ef698bbb6857cbaad1acbe238041e43f04d9818bac43f59023be3f3c2154ecf75f180d8233c9d7f65c555
diff --git a/dev-util/lttng-ust/lttng-ust-2.13.8.ebuild b/dev-util/lttng-ust/lttng-ust-2.13.8.ebuild
new file mode 100644
index 000000000000..35566d1089b8
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.13.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please bump the following packages together:
+# dev-util/lttng-modules
+# dev-util/lttng-tools
+# dev-util/lttng-ust
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples numa test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/userspace-rcu-0.12:=
+ numa? ( sys-process/numactl )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-lang/perl )
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ pthread_get_name_np # different from pthread_getname_*, not on linux
+ pthread_set_name_np # different from pthread_setname_*, not on linux
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable examples)
+ $(use_enable numa)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}