summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/colorcvs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/colorcvs')
-rw-r--r--dev-vcs/colorcvs/Manifest1
-rw-r--r--dev-vcs/colorcvs/colorcvs-1.4-r1.ebuild44
-rw-r--r--dev-vcs/colorcvs/files/colorcvs-1.4-prefix.patch20
-rw-r--r--dev-vcs/colorcvs/files/colorcvs-profile.sh3
-rw-r--r--dev-vcs/colorcvs/metadata.xml5
5 files changed, 73 insertions, 0 deletions
diff --git a/dev-vcs/colorcvs/Manifest b/dev-vcs/colorcvs/Manifest
new file mode 100644
index 000000000000..18d30698a541
--- /dev/null
+++ b/dev-vcs/colorcvs/Manifest
@@ -0,0 +1 @@
+DIST colorcvs-1.4.tar.bz2 8376 SHA256 8e4b94ee1f6ee3dd4d545182da0f3b38cc52765e447975f64c70397d800ffa2f SHA512 b8c9f3241318599da40614392045a0bba3952314001f6b411207307e79e20b7dea1a9741d5a84dc91b652319ee434c2c14f03435ce4adbd22160d66181da6e44 WHIRLPOOL 83f59360652e4fccb311e47804dd4a3c5bcad07db45287c429e391a7ed00ca6ea5671114a89fe99d5be8d3c02e3a4ab840153b3048aaa635b9580d29ae30717d
diff --git a/dev-vcs/colorcvs/colorcvs-1.4-r1.ebuild b/dev-vcs/colorcvs/colorcvs-1.4-r1.ebuild
new file mode 100644
index 000000000000..65ec5d3a5d6c
--- /dev/null
+++ b/dev-vcs/colorcvs/colorcvs-1.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils prefix
+
+DESCRIPTION="A tool based on colorgcc to beautify cvs output"
+HOMEPAGE="http://packages.gentoo.org/package/dev-vcs/colorcvs"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ dev-lang/perl
+ dev-vcs/cvs"
+
+src_prepare() {
+ # fix typo
+ sed -i -e 's:compiler_pid:cvs_pid:' ${PN} || die "sed failed"
+ epatch "${FILESDIR}"/${P}-prefix.patch
+ eprefixify colorcvs
+}
+
+src_install() {
+ insinto /etc/profile.d
+ doins "${FILESDIR}/${PN}-profile.sh" || die "doins failed"
+
+ dobin colorcvs || die "dobin failed"
+ dodoc colorcvsrc-sample || die "dodoc failed"
+}
+
+pkg_postinst() {
+ echo
+ einfo "An alias to colorcvs was installed for the cvs command."
+ einfo "In order to immediately activate it do:"
+ einfo "\tsource /etc/profile"
+ echo
+}
diff --git a/dev-vcs/colorcvs/files/colorcvs-1.4-prefix.patch b/dev-vcs/colorcvs/files/colorcvs-1.4-prefix.patch
new file mode 100644
index 000000000000..0a93b49eba0b
--- /dev/null
+++ b/dev-vcs/colorcvs/files/colorcvs-1.4-prefix.patch
@@ -0,0 +1,20 @@
+--- colorcvs.orig 2008-01-26 20:04:54 +0100
++++ colorcvs 2008-01-26 20:05:56 +0100
+@@ -54,7 +54,7 @@
+
+ sub initDefaults
+ {
+- $cvsPath = "/usr/bin/cvs";
++ $cvsPath = "@GENTOO_PORTAGE_EPREFIX@/usr/bin/cvs";
+
+ $nocolor{"dumb"} = "true";
+
+@@ -118,7 +118,7 @@
+ initDefaults();
+
+ # Read the configuration files.
+-for my $configFile ('/etc/colorcvsrc', "$ENV{HOME}/.colorcvsrc") {
++for my $configFile ('@GENTOO_PORTAGE_EPREFIX@/etc/colorcvsrc', "$ENV{HOME}/.colorcvsrc") {
+ if (-f $configFile)
+ {
+ loadPreferences($configFile);
diff --git a/dev-vcs/colorcvs/files/colorcvs-profile.sh b/dev-vcs/colorcvs/files/colorcvs-profile.sh
new file mode 100644
index 000000000000..07ca68c9d132
--- /dev/null
+++ b/dev-vcs/colorcvs/files/colorcvs-profile.sh
@@ -0,0 +1,3 @@
+# set alias for colorcvs
+
+alias cvs='colorcvs'
diff --git a/dev-vcs/colorcvs/metadata.xml b/dev-vcs/colorcvs/metadata.xml
new file mode 100644
index 000000000000..f23b9cae1593
--- /dev/null
+++ b/dev-vcs/colorcvs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>