summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2024-03-17 20:18:31 +0100
committerYixun Lan <dlan@gentoo.org>2024-04-09 06:56:45 +0000
commit3d6defc12044d8e715ef8b5088c0cfbbf60bba34 (patch)
treeff0efbfb7c3b348ed877415f0dbadf8f03291359 /dev-vcs/git-lfs
parentapp-misc/recoll: Add 1.37.4-r1 (diff)
downloadgentoo-3d6defc12044d8e715ef8b5088c0cfbbf60bba34.tar.gz
gentoo-3d6defc12044d8e715ef8b5088c0cfbbf60bba34.tar.bz2
gentoo-3d6defc12044d8e715ef8b5088c0cfbbf60bba34.zip
dev-vcs/git-lfs: Bump to 3.5.1
Also add the GODMODCACHE download command to the huge description block. Closes: https://bugs.gentoo.org/926956 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs/git-lfs')
-rw-r--r--dev-vcs/git-lfs/Manifest2
-rw-r--r--dev-vcs/git-lfs/git-lfs-3.5.1.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index 9b0994b98cf7..16e1b3fd55de 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1,3 +1,5 @@
DIST git-lfs-3.2.0.tar.gz 3270970 BLAKE2B fc235d48e44f8a0f446b05914cd110e6486481482b2884483dcf04198a3275a633cd8090e1591975f8b84ba678c258581e3510fc0d478d5fc72abf6aa98bd5c0 SHA512 c2ba8cecd5b3519a032f446b0c3043352f37f3c67ff3c2304a38beb176f0ae8efd1deaeb8bd54a35d7dd7dcd988da67249c896dffd83fc293b165a3e6bb02d66
DIST git-lfs-3.4.0-deps.tar.xz 19912396 BLAKE2B 0e2e50e7b7566fe93d87f86c4b3a3a3f5f0cefc734af83516a5d3122d101333df5ed65cf848e727a1b7593ffdffeee72108221951313f47775b265f4fbdcb1be SHA512 50f7eba5abd4a3ad83e1cd74d7d413e8f708b796b67d60d404af512823423532e1bbbfaa5385ee668cbdd6ec0bce89b862db571c76e5a3f0d0cee5097ccc73d2
DIST git-lfs-3.4.0.tar.gz 674499 BLAKE2B 8232c7492a453fc5a8855b13cfbf95c64a9c614d740bebebefcc44f6a7e2daddaee0dee3f8d8ba653999b8516c47a491af6449b5daf5e3861f3530d372b213e4 SHA512 ff0d624bc48d9ab4332943af8212652d9959e8f9d6a356a3722047903e01bc1dcf04178b97d58a327d0a381569854034c4a1dc2baea9976a8f20d97d7e637f31
+DIST git-lfs-3.5.1-deps.tar.xz 21401028 BLAKE2B a011061ebae15c7d80d908d46051c95462b617073623be83c067cfc9b028eb8f803f53dcb17a6e19d8e1bfd9c2349db9f7a000d91008b1c375bfc73de4793b25 SHA512 1879624ee84e5d138f8dcb9cb626822d0a2e063705cb424db5c9f9d609af496104655ebb878ec950112b8b39d147141ff86b6474ad8210384dd93318034c19a4
+DIST git-lfs-3.5.1.tar.gz 683872 BLAKE2B c99d85474cb8544ea2fca7daa6fc57affeabeb7bde517366c885360f613012c3b852d95abd647adfda806f0a057c6df355db0cf49f8d408460c0e2498b836ab5 SHA512 7755f8fbf18d5870eb95d13e1af763e9c8b127ecace67c95d54100eb9d735df41b649d1777f7051ba018eacba34f732a51b3bf5f1376dedf4778b5ae0c81cf40
diff --git a/dev-vcs/git-lfs/git-lfs-3.5.1.ebuild b/dev-vcs/git-lfs/git-lfs-3.5.1.ebuild
new file mode 100644
index 000000000000..d834b83cee10
--- /dev/null
+++ b/dev-vcs/git-lfs/git-lfs-3.5.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 2017-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+EGO_PN=github.com/git-lfs/git-lfs
+# Update the ID as it's included in each build.
+COMMIT_ID="e237bb3a364603cbb92cabc34b8401d1ad5d795b"
+
+inherit go-module shell-completion
+
+DESCRIPTION="Command line extension and specification for managing large files with git"
+HOMEPAGE="
+ https://git-lfs.com
+ https://github.com/git-lfs/git-lfs
+"
+
+if [[ "${PV}" = 9999* ]]; then
+ EGIT_REPO_URI="https://${EGO_PN}"
+ inherit git-r3
+else
+ SRC_URI="https://${EGO_PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ # Add the manually vendored tarball.
+ # 1) Create a tar archive optimized to reproduced by other users or devs.
+ # 2) Compress the archive using XZ limiting decompression memory for
+ # pretty constraint systems.
+ # Use something like:
+ # GOMODCACHE="${PWD}"/go-mod go mod download -modcacherw
+ # tar cf $P-deps.tar go-mod \
+ # --mtime="1970-01-01" --sort=name --owner=portage --group=portage
+ # xz -k -9eT0 --memlimit-decompress=256M $P-deps.tar
+ SRC_URI+=" https://files.holgersson.xyz/gentoo/distfiles/golang-pkg-deps/${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
+SLOT="0"
+IUSE="doc test"
+
+BDEPEND="
+ doc? ( dev-ruby/asciidoctor )
+"
+RDEPEND="dev-vcs/git"
+
+RESTRICT+=" !test? ( test )"
+
+DOCS=(
+ CHANGELOG.md
+ CODE-OF-CONDUCT.md
+ CONTRIBUTING.md
+ README.md
+ SECURITY.md
+)
+
+src_compile() {
+ export CGO_ENABLED=0
+
+ # Flags -w, -s: Omit debugging information to reduce binary size,
+ # see https://golang.org/cmd/link/.
+ local mygobuildargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${COMMIT_ID} -s -w"
+ -gcflags=" "
+ -trimpath
+ -v -work -x
+ )
+ ego build "${mygobuildargs[@]}" -o git-lfs git-lfs.go
+
+ if use doc; then
+ for doc in docs/man/*adoc;
+ do asciidoctor -b manpage ${doc} || die "man building failed"
+ done
+ fi
+
+ # Generate auto-completion scripts.
+ # bug 914542
+ ./git-lfs completion bash > "${PN}.bash" || die
+ ./git-lfs completion fish > "${PN}.fish" || die
+ ./git-lfs completion zsh > "${PN}.zsh" || die
+}
+
+src_install() {
+ dobin git-lfs
+ einstalldocs
+
+ # Install auto-completion scripts generated earlier.
+ # bug 914542
+ newbashcomp "${PN}.bash" "${PN}"
+ dofishcomp "${PN}.fish"
+ newzshcomp "${PN}.zsh" "_${PN}"
+
+ use doc && doman docs/man/*.1
+}
+
+src_test() {
+ local mygotestargs=(
+ -ldflags="-X ${EGO_PN}/config.GitCommit=${COMMIT_ID}"
+ )
+ go test "${mygotestargs[@]}" ./... || die
+}
+
+pkg_postinst () {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog ""
+ elog "Run 'git lfs install' once for each user account manually."
+ elog "For more details see https://bugs.gentoo.org/show_bug.cgi?id=733372."
+ fi
+}