summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-12-21 12:33:41 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-12-21 12:54:13 +0100
commitb34520f93b16551587a7f6952b082d17c2408fbe (patch)
tree66268db7432592882c895b143970c023cf977585 /dev-vcs
parentnet-analyzer/zabbix: bump to 6.0.37 (diff)
downloadgentoo-b34520f93b16551587a7f6952b082d17c2408fbe.tar.gz
gentoo-b34520f93b16551587a7f6952b082d17c2408fbe.tar.bz2
gentoo-b34520f93b16551587a7f6952b082d17c2408fbe.zip
dev-vcs/repo: add 2.50.1
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/repo/Manifest1
-rw-r--r--dev-vcs/repo/repo-2.50.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index a5a6cce36965..fa8b107fe9bf 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -1,3 +1,4 @@
DIST repo-2.45.tar.gz 279358 BLAKE2B 1035621e5f4f139ae1a7057ea30bf9431d4a39c46a6dd79dcc89653d5aa628d43ffc1793b27100f64dd14c37c06bfcfeb02a2b16ba5abe3cb6e18bf6dd981dba SHA512 0fc285dd3c2483ff72f791e207448ace85256f03aa75ac2af5982fbac2b190b66a2bc3d44a7b1eca6e7df8500483d9dfb72a1fc79ef74c64eb0a12b020ea93ff
DIST repo-2.46.tar.gz 280784 BLAKE2B 815c616efeed881779db7356f3410f0acf3749867d729fc79241cd1ba2e800aaaac373882d758cc1096d5f30acbdc33731b5ba65828328f9626f3e7fe88cfed3 SHA512 2654cbc116bc10dc6e9e01bde6f76b90b1519cd32226ad6a51053883436e0c901a7709d066be1a606a0ca751e98cfe7dac8c736cfef4c971ef75c6f2a20f57f8
DIST repo-2.48.tar.gz 282062 BLAKE2B 6b5857810a2874b841af65fc1ea6f7d7b49b81f539b7c3f97e4bd89febba2ecb1a2191fa5cfbe1abb2128fb32ac9b444fa761d3b72f4704fa28a4d1c7db96779 SHA512 a3b7019141da6e2be24752e433c87e21b7d08c57671a769b66943bd683c0e7e1cc3c603d4b58366090206e70a49609ffbf35e3da5742f4146611827ab1d8b73d
+DIST repo-2.50.1.tar.gz 285537 BLAKE2B a8995a4ded803e6e7be574dc5922c840b2f424af4b0a79a0bcf6adb1db7e39b8c2b3c9cbe52c2061a63b0a5b318a0aca0cecebfa1a61e986cf7020faa61fa1a6 SHA512 89094bcec2f114e304177455a6770f3c8f97ae7553475fb77367739203c630bd068c0f7d5e2c465e839788ac72637665605d77363554e1b9630a11115a44c9ef
diff --git a/dev-vcs/repo/repo-2.50.1.ebuild b/dev-vcs/repo/repo-2.50.1.ebuild
new file mode 100644
index 000000000000..23b5d26008d7
--- /dev/null
+++ b/dev-vcs/repo/repo-2.50.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The ${PV} tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://github.com/GerritCodeReview/git-repo/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/git-${P}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ newbashcomp completion.bash ${PN}
+ doman man/*.[0-9]
+}