summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/heroes/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/heroes/files')
-rw-r--r--games-action/heroes/files/0.21-cvs-segfault-fix.patch17
-rw-r--r--games-action/heroes/files/heroes-0.21-automake-1.12.patch11
-rw-r--r--games-action/heroes/files/heroes-0.21-gcc4.patch184
-rw-r--r--games-action/heroes/files/heroes-0.21-underlink.patch11
4 files changed, 223 insertions, 0 deletions
diff --git a/games-action/heroes/files/0.21-cvs-segfault-fix.patch b/games-action/heroes/files/0.21-cvs-segfault-fix.patch
new file mode 100644
index 000000000000..99f770631f6c
--- /dev/null
+++ b/games-action/heroes/files/0.21-cvs-segfault-fix.patch
@@ -0,0 +1,17 @@
+===================================================================
+RCS file: /cvsroot/heroes/heroes/src/menus.c,v
+retrieving revision 1.108.2.1
+retrieving revision 1.108.2.2
+diff -u -r1.108.2.1 -r1.108.2.2
+--- heroes/heroes/src/menus.c 2002/06/16 19:16:09 1.108.2.1
++++ heroes/heroes/src/menus.c 2002/08/22 11:45:51 1.108.2.2
+@@ -219,7 +219,8 @@
+ { N_("NEW LEVEL"), editor_menu },
+ /* TRANS: Load an existing level for edition. */
+ { N_("LOAD LEVEL"), editor_selector },
+- { N_("GO BACK"), 0 }
++ { N_("GO BACK"), 0 },
++ { 0, 0 }
+ };
+
+ a_menu *editor_menu_data;
diff --git a/games-action/heroes/files/heroes-0.21-automake-1.12.patch b/games-action/heroes/files/heroes-0.21-automake-1.12.patch
new file mode 100644
index 000000000000..1a645df91acb
--- /dev/null
+++ b/games-action/heroes/files/heroes-0.21-automake-1.12.patch
@@ -0,0 +1,11 @@
+--- heroes-0.21/configure.ac
++++ heroes-0.21/configure.ac
+@@ -112,7 +112,7 @@
+ # Checks for typedefs, structures, and compiler characteristics.
+ # ==============================================================
+
+-AM_C_PROTOTYPES
++AC_C_PROTOTYPES
+ AC_C_CONST
+ AC_TYPE_UID_T dnl This checks for gid_t too.
+ AC_CHECK_TYPES([ssize_t])
diff --git a/games-action/heroes/files/heroes-0.21-gcc4.patch b/games-action/heroes/files/heroes-0.21-gcc4.patch
new file mode 100644
index 000000000000..573db41c0e2e
--- /dev/null
+++ b/games-action/heroes/files/heroes-0.21-gcc4.patch
@@ -0,0 +1,184 @@
+--- src/hedlite.c.old 2006-01-28 14:05:05.000000000 -0700
++++ src/hedlite.c 2006-01-28 14:07:20.000000000 -0700
+@@ -45,7 +45,7 @@
+ #include "dirname.h"
+
+ static a_pcx_image heditrsc;
+-static a_pcx_image tile_set_img;
++static a_pcx_image tile_set_img_local;
+
+ unsigned short int xdalles = 0;
+ unsigned short int ydalles = 0;
+@@ -144,9 +144,9 @@
+ static void
+ copy_tile (int src_, a_pixel *dest)
+ {
+- int i = tile_set_img.width;
++ int i = tile_set_img_local.width;
+ int j;
+- a_pixel *src = tile_set_img.buffer + src_;
++ a_pixel *src = tile_set_img_local.buffer + src_;
+ for (j = 20; j > 0; j--) {
+ fastmem4 (src, dest, 24 >> 2);
+ src += i;
+@@ -157,9 +157,9 @@
+ static void
+ copy_tile_pcx (int src_, a_pixel *dest)
+ {
+- int i = tile_set_img.width;
++ int i = tile_set_img_local.width;
+ int j;
+- a_pixel *src = tile_set_img.buffer + src_;
++ a_pixel *src = tile_set_img_local.buffer + src_;
+ for (j = 20; j > 0; j--) {
+ fastmem4 (src, dest, 24 >> 2);
+ src += i;
+@@ -170,9 +170,9 @@
+ static void
+ copy_tile_transp (int src_, a_pixel *dest)
+ {
+- int i = tile_set_img.width;
++ int i = tile_set_img_local.width;
+ int j, k;
+- a_pixel *src = tile_set_img.buffer + src_;
++ a_pixel *src = tile_set_img_local.buffer + src_;
+ for (j = 20; j > 0; j--) {
+ for (k = 24; k > 0; k--) {
+ if (*src != 0)
+@@ -188,9 +188,9 @@
+ static void
+ copy_tile_transp_pcx (int src_, a_pixel *dest)
+ {
+- int i = tile_set_img.width;
++ int i = tile_set_img_local.width;
+ int j, k;
+- a_pixel *src = tile_set_img.buffer + src_;
++ a_pixel *src = tile_set_img_local.buffer + src_;
+ for (j = 20; j > 0; j--) {
+ for (k = 24; k > 0; k--) {
+ if (*src != 0)
+@@ -555,7 +555,7 @@
+ static void
+ update_middle_panel (void)
+ {
+- rectangle_copy (xdalles, 0, 144, 200, 145, 0, &tile_set_img);
++ rectangle_copy (xdalles, 0, 144, 200, 145, 0, &tile_set_img_local);
+ frame (145 + xdallesdec, ydalles, 23, 19, 15);
+ rectangle_copy (0, 64, 30, 6, 290, 64, &heditrsc);
+ sprintf (nombre, "%u", (xdalles + xdallesdec) / 24);
+@@ -670,7 +670,7 @@
+ curdalled (void)
+ {
+ int i =
+- (xdalles + xdallesdec) / 24 + (ydalles / 20) * (tile_set_img.width / 24);
++ (xdalles + xdallesdec) / 24 + (ydalles / 20) * (tile_set_img_local.width / 24);
+ return i;
+ }
+
+@@ -894,7 +894,7 @@
+ free (tempc);
+ putc (0xC, fpcx);
+ for (i1 = 0; i1 < 768; i1++)
+- putc (tile_set_img.palette.global[i1] << 2, fpcx);
++ putc (tile_set_img_local.palette.global[i1] << 2, fpcx);
+ fclose (fpcx);
+ }
+
+@@ -1225,7 +1225,7 @@
+ }
+ } else if (i == HK_End) {
+ if (mod & HK_MOD_Ctrl) {
+- xdalles = (tile_set_img.width / 24) * 24 - 144;
++ xdalles = (tile_set_img_local.width / 24) * 24 - 144;
+ update_middle_panel ();
+ }
+ } else if (i == HK_PageDown) {
+@@ -1250,7 +1250,7 @@
+ }
+ } else if (i == HK_Right) {
+ if (mod & HK_MOD_Ctrl) {
+- if (xdalles + 168U < tile_set_img.width) {
++ if (xdalles + 168U < tile_set_img_local.width) {
+ xdalles += 24;
+ update_middle_panel ();
+ } else if (xdallesdec < 120) {
+@@ -1337,7 +1337,7 @@
+ } else if (i == HK_Space) {
+ j = curdallep ();
+ level_map[j].number =
+- xdalles + xdallesdec + ydalles * (tile_set_img.width);
++ xdalles + xdallesdec + ydalles * (tile_set_img_local.width);
+ level_map[j].type = ddef[curdalled ()].type;
+ level_map[j].info = ddef[curdalled ()].info;
+ gestclav (HK_i, HK_MOD_None);
+@@ -1351,9 +1351,9 @@
+ level_map[j].collision[3] = 0;
+ }
+ for (j = hplaninfo.xt * hplaninfo.yt - 1; j >= 0; j--) {
+- k = (((level_map[j].number % tile_set_img.width) / 24) +
+- (level_map[j].number / (tile_set_img.width * 20)) *
+- (tile_set_img.width / 24));
++ k = (((level_map[j].number % tile_set_img_local.width) / 24) +
++ (level_map[j].number / (tile_set_img_local.width * 20)) *
++ (tile_set_img_local.width / 24));
+ level_map[j].type = ddef[k].type;
+ if (level_map[j].type != t_tunnel) {
+ if (level_map[j].type == t_anim || i == 0x1749)
+@@ -1404,7 +1404,7 @@
+ if (mod & HK_MOD_Ctrl) {
+ for (j = hplaninfo.xt * hplaninfo.yt - 1; j >= 0; j--) {
+ level_map[j].number = xdalles + xdallesdec +
+- ydalles * (tile_set_img.width);
++ ydalles * (tile_set_img_local.width);
+ level_map[j].type = ddef[curdalled ()].type;
+ level_map[j].info = ddef[curdalled ()].info;
+ }
+@@ -1414,7 +1414,7 @@
+
+ level_map[j].number =
+ (((j % hplaninfo.xt) + (j / hplaninfo.xt)) & 1) * 20 *
+- tile_set_img.width;
++ tile_set_img_local.width;
+ update_left_panel ();
+ }
+ } else if (i == HK_F3) {
+@@ -1427,7 +1427,7 @@
+ if (level_map[curdallep ()].sprite == 0)
+
+ level_map[curdallep ()].sprite =
+- (short int) (xdalles + xdallesdec + ydalles * (tile_set_img.width));
++ (short int) (xdalles + xdallesdec + ydalles * (tile_set_img_local.width));
+ else
+ level_map[curdallep ()].sprite = 0;
+ update_left_panel ();
+@@ -1707,17 +1707,17 @@
+ hplaninfo.tile_set_name), ".pie");
+
+ pcx_load_from_rsc ("editor-img", &heditrsc);
+- pcx_load (tile_set_name, &tile_set_img);
++ pcx_load (tile_set_name, &tile_set_img_local);
+
+ /* read the tileset definition */
+- XCALLOC_ARRAY (ddef, (tile_set_img.width / 24) * 10);
++ XCALLOC_ARRAY (ddef, (tile_set_img_local.width / 24) * 10);
+ if (!((ftmp = fopen (dallepie, "rb")) == NULL))
+- fread (ddef, sizeof (a_tile_info), (tile_set_img.width / 24) * 10, ftmp);
++ fread (ddef, sizeof (a_tile_info), (tile_set_img_local.width / 24) * 10, ftmp);
+ fclose (ftmp);
+
+ outwayinit ();
+ XCALLOC_ARRAY (hedit_buffer, xbuf * 200);
+- set_pal (tile_set_img.palette.global, 0, 256 * 3);
++ set_pal (tile_set_img_local.palette.global, 0, 256 * 3);
+ rectangle_copy (0, 0, 30, 200, 290, 0, &heditrsc);
+ strupr (levelnomshort);
+ draw_text (levelnomshort, 305, 29, 8, 1);
+@@ -1767,7 +1767,7 @@
+ free (ddef);
+ free (level_map);
+ img_free (&heditrsc);
+- img_free (&tile_set_img);
++ img_free (&tile_set_img_local);
+ }
+
+ free (dallepie);
diff --git a/games-action/heroes/files/heroes-0.21-underlink.patch b/games-action/heroes/files/heroes-0.21-underlink.patch
new file mode 100644
index 000000000000..4b805aebc707
--- /dev/null
+++ b/games-action/heroes/files/heroes-0.21-underlink.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.am.old 2011-06-10 11:32:03.905618275 +0200
++++ src/Makefile.am 2011-06-10 11:32:15.539347083 +0200
+@@ -42,7 +42,7 @@
+ heroeslvl_SOURCES = heroeslvl.c
+
+ heroes_LDADD = lvl/libhlvl.a media/libhmcommon.a ../lib/libheroes.a \
+- $(INTLLIBS) $(LIBALT_LOCAL_XLDADD) $(LIBALT_XLDADD)
++ $(INTLLIBS) $(LIBALT_LOCAL_XLDADD) $(LIBALT_XLDADD) -lm
+ heroes_LDFLAGS = $(LIBALT_XLDFLAGS)
+
+ ## Depend upon Makefile because the value of LIBALT_LOCAL_LDADD might