summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/monkey-bubble
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/monkey-bubble')
-rw-r--r--games-arcade/monkey-bubble/Manifest1
-rw-r--r--games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch30
-rw-r--r--games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch45
-rw-r--r--games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-gnome-doc.patch38
-rw-r--r--games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-noesound.patch19
-rw-r--r--games-arcade/monkey-bubble/metadata.xml9
-rw-r--r--games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild44
7 files changed, 186 insertions, 0 deletions
diff --git a/games-arcade/monkey-bubble/Manifest b/games-arcade/monkey-bubble/Manifest
new file mode 100644
index 000000000000..307730afe51d
--- /dev/null
+++ b/games-arcade/monkey-bubble/Manifest
@@ -0,0 +1 @@
+DIST monkey-bubble-0.4.0.tar.gz 5360713 SHA256 eb96293a0fadbbfc3cd3ae0bbb557d9bf8a4dd8edccdd8ce1b913e8ba49a1c89 SHA512 def3603972462e19d99d0d1dd86d522386d64cbb4190b1361d0d94bc175f476738619ba34fb78451669456a9365f157a96feb4d996870b37acc9d9e68024ae34 WHIRLPOOL 0a86f6a8a2d81b6c6ef58f565683ac0aecd5a6eb6fba468d35d9986ce94ab55b4fb1d3bde8dfb04fb1e3a107b7c4bcb4d8eed463c81df5d2f1435bf316656c7b
diff --git a/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch
new file mode 100644
index 000000000000..1e8822d0f871
--- /dev/null
+++ b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-asneeded.patch
@@ -0,0 +1,30 @@
+--- monkey-bubble-0.3.2/src/net/Makefile.am.orig
++++ monkey-bubble-0.3.2/src/net/Makefile.am
+@@ -28,10 +28,10 @@
+ monkey_srv_LDFLAGS =
+
+ monkey_srv_LDADD = \
+- $(MONKEY_SRV_LIBS) \
+ libmonkeynet.a \
+ ../monkey/libmonkey.a \
+- ../util/libmonkeyutil.a
++ ../util/libmonkeyutil.a \
++ $(MONKEY_SRV_LIBS) -lm
+
+ $(libmonkeynet_a_OBJECTS): $(marshal_sources)
+
+--- monkey-bubble-0.3.2/src/ui/Makefile.am.orig
++++ monkey-bubble-0.3.2/src/ui/Makefile.am
+@@ -50,10 +50,10 @@
+
+
+ monkey_bubble_LDADD = \
+- $(UI_LIBS) \
+ ../monkey/libmonkey.a \
+ ../view/libmonkeyview.a \
+ ../util/libmonkeyutil.a \
+ ../net/libmonkeynet.a \
+ ../audio/libmonkeyaudio.a \
+- ../input/libmbinput.a
++ ../input/libmbinput.a \
++ $(UI_LIBS) -lm
diff --git a/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch
new file mode 100644
index 000000000000..67109beff7f7
--- /dev/null
+++ b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-glib-single-include.patch
@@ -0,0 +1,45 @@
+Index: monkey-bubble-0.4.0/src/net/message-handler.c
+===================================================================
+--- monkey-bubble-0.4.0.orig/src/net/message-handler.c
++++ monkey-bubble-0.4.0/src/net/message-handler.c
+@@ -28,7 +28,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <arpa/inet.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <sys/time.h>
+ #include <time.h>
+
+Index: monkey-bubble-0.4.0/src/net/simple-server.c
+===================================================================
+--- monkey-bubble-0.4.0.orig/src/net/simple-server.c
++++ monkey-bubble-0.4.0/src/net/simple-server.c
+@@ -31,13 +31,12 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <arpa/inet.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <sys/time.h>
+ #include <time.h>
+
+
+ #include <glib-object.h>
+-#include <glib.h>
+
+ #include "simple-server.h"
+ #include "message-handler.h"
+Index: monkey-bubble-0.4.0/src/ui/main.c
+===================================================================
+--- monkey-bubble-0.4.0.orig/src/ui/main.c
++++ monkey-bubble-0.4.0/src/ui/main.c
+@@ -15,7 +15,7 @@
+ #include <gtk/gtk.h>
+ #include <gst/gst.h>
+ #include <bonobo/bonobo-i18n.h>
+-#include <glib/gthread.h>
++#include <glib.h>
+ #include <libgnomeui/gnome-ui-init.h>
+
+ #include <math.h>
diff --git a/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-gnome-doc.patch b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-gnome-doc.patch
new file mode 100644
index 000000000000..801ae84d9bab
--- /dev/null
+++ b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-gnome-doc.patch
@@ -0,0 +1,38 @@
+--- help/C/monkey-bubble.xml
++++ help/C/monkey-bubble.xml
+@@ -23,7 +23,7 @@
+ <publishername>GNOME Documentation Project</publishername>
+ </publisher>
+ <authorgroup>
+- <author>
++ <author role="maintainer">
+ <firstname>Thomas</firstname>
+ <surname>Cataldo</surname>
+ <affiliation>
+@@ -55,6 +55,7 @@
+ manual, follow the directions in the
+ <ulink url="ghelp:gnome-feedback" type="help">GNOME Feedback Page</ulink>. </para>
+ </legalnotice>
++ <abstract role="description"><para>Monkey Bubble manual</para></abstract>
+ </articleinfo>
+
+ <indexterm>
+--- help/fr/monkey-bubble.xml
++++ help/fr/monkey-bubble.xml
+@@ -22,7 +22,7 @@
+ <publishername>Projet de documentation GNOME</publishername>
+ </publisher>
+ <authorgroup>
+- <author>
++ <author role="maintainer">
+ <firstname>Thomas</firstname>
+ <surname>Cataldo</surname>
+ <affiliation>
+@@ -47,6 +47,7 @@
+ <title>Votre avis</title>
+ <para>Pour signaler un probl&egrave;me ou faire une suggestion concernant l'application Monkey Bubble ou le pr&eacute;sent manuel, proc&eacute;dez comme indiqu&eacute;&agrave; la <ulink url="ghelp:gnome-feedback" type="help">GNOME Feedback Page</ulink>.</para>
+ </legalnotice>
++ <abstract role="description"><para>Monkey Bubble manual</para></abstract>
+ </articleinfo>
+
+ <indexterm>
diff --git a/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-noesound.patch b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-noesound.patch
new file mode 100644
index 000000000000..be0a9a924a47
--- /dev/null
+++ b/games-arcade/monkey-bubble/files/monkey-bubble-0.4.0-noesound.patch
@@ -0,0 +1,19 @@
+monkey-bubble-0.4.0: don't require the esd header.
+
+2010-07-12 Sven Herzberg
+2012-01-07 Martin von Gagern
+
+References:
+https://github.com/mquinson/monkey-bubble/commit/299623f8e6b0b6090e98
+https://bugs.gentoo.org/397997
+
+--- monkey-bubble-0.4.0.orig/src/ui/main.c
++++ monkey-bubble-0.4.0/src/ui/main.c
+@@ -11,7 +11,6 @@
+ #include "ui-main.h"
+ #include "input-manager.h"
+
+-#include <esd.h>
+ #include <gtk/gtk.h>
+ #include <gst/gst.h>
+ #include <bonobo/bonobo-i18n.h>
diff --git a/games-arcade/monkey-bubble/metadata.xml b/games-arcade/monkey-bubble/metadata.xml
new file mode 100644
index 000000000000..b4647c10eaf6
--- /dev/null
+++ b/games-arcade/monkey-bubble/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>mr_bones_@gentoo.org</email>
+<name>Michael Sterrett</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild b/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild
new file mode 100644
index 000000000000..62ad1740c948
--- /dev/null
+++ b/games-arcade/monkey-bubble/monkey-bubble-0.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome2
+
+DESCRIPTION="A Puzzle Bobble clone"
+HOMEPAGE="http://www.monkey-bubble.org/"
+SRC_URI="http://home.gna.org/monkeybubble/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=dev-libs/glib-2.12:2
+ >=gnome-base/libglade-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/librsvg-2.0
+ >=gnome-base/gconf-2.0
+ media-libs/gstreamer:0.10
+ >=dev-libs/libxml2-2.6.7"
+DEPEND="${RDEPEND}
+ app-text/rarian
+ app-text/gnome-doc-utils
+ dev-util/intltool"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-gnome-doc.patch \
+ "${FILESDIR}"/${P}-noesound.patch \
+ "${FILESDIR}"/${P}-glib-single-include.patch
+ # bug 260895
+ sed -i -e 's/ -Werror//' $(find . -name Makefile.am) || die
+ sed -i \
+ -e '/^Icon/s/.png//' \
+ -e '/^Categories/s/Application;//' \
+ monkey-bubble.desktop.in || die
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ gnome2_src_prepare
+}