summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-03-11 22:38:39 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-05-26 09:36:33 +0300
commit5673186acd87d77631b0b1b2ced9238491bedf18 (patch)
treeb91391e58056a46ec736279578d999aa6cd9ca7a /games-arcade/oshu/oshu-9999.ebuild
parentdev-libs/nspr: add 4.34 (diff)
downloadgentoo-5673186acd87d77631b0b1b2ced9238491bedf18.tar.gz
gentoo-5673186acd87d77631b0b1b2ced9238491bedf18.tar.bz2
gentoo-5673186acd87d77631b0b1b2ced9238491bedf18.zip
games-arcade/oshu: Version bump, 2.0.2
Closes: https://bugs.gentoo.org/834370 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/24499 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-arcade/oshu/oshu-9999.ebuild')
-rw-r--r--games-arcade/oshu/oshu-9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/games-arcade/oshu/oshu-9999.ebuild b/games-arcade/oshu/oshu-9999.ebuild
index 5ebae7bfdcd6..cf543ede25bd 100644
--- a/games-arcade/oshu/oshu-9999.ebuild
+++ b/games-arcade/oshu/oshu-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake xdg
@@ -27,11 +27,19 @@ RDEPEND="
media-libs/sdl2-image
x11-libs/cairo
x11-libs/pango
- media-video/ffmpeg:=
+ >media-video/ffmpeg-5:=
"
DEPEND="${RDEPEND}"
+src_unpack() {
+ default
+
+ if [[ ${PV} = *9999 ]]; then
+ git-r3_src_unpack
+ fi
+}
+
src_prepare() {
if use osu-skin; then
eapply "${FILESDIR}/oshu-2.0.0-use_unpacked_osu-skin.patch"
@@ -43,8 +51,8 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- '-DOSHU_DEFAULT_SKIN='$(usex osu-skin 'osu' 'minimal')
- '-DOSHU_SKINS=minimal'$(usex osu-skin ';osu' '')
+ -DOSHU_DEFAULT_SKIN=$(usex osu-skin osu minimal)
+ -DOSHU_SKINS=minimal$(usev osu-skin ';osu')
)
cmake_src_configure