summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-09-26 17:43:35 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-26 17:43:35 +0200
commit9b1436c7434d763f06dda60229747997664fb5c5 (patch)
tree4cde8f95f2c817a542334c79b860bcb24b7ff803 /games-arcade
parentdev-lang/lua: Fix for CVE-2022-28805 (diff)
downloadgentoo-9b1436c7434d763f06dda60229747997664fb5c5.tar.gz
gentoo-9b1436c7434d763f06dda60229747997664fb5c5.tar.bz2
gentoo-9b1436c7434d763f06dda60229747997664fb5c5.zip
games-arcade/epiar: request deprecated lua-5.1 API
Closes: https://bugs.gentoo.org/872803 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/epiar/epiar-0.5.1-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/games-arcade/epiar/epiar-0.5.1-r1.ebuild b/games-arcade/epiar/epiar-0.5.1-r1.ebuild
index ba4c0b862a2c..994a9dc22a21 100644
--- a/games-arcade/epiar/epiar-0.5.1-r1.ebuild
+++ b/games-arcade/epiar/epiar-0.5.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
LUA_COMPAT=( lua5-1 )
-inherit autotools lua-single
+inherit autotools flag-o-matic lua-single
DESCRIPTION="Space adventure/combat game"
HOMEPAGE="https://epiar.net/"
@@ -41,6 +41,14 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -DLUA_COMPAT_OPENLIB=1 is required to enable the
+ # deprecated (in 5.1) luaL_openlib API (#872803)
+ append-cppflags -DLUA_COMPAT_OPENLIB=1
+
+ default
+}
+
src_install() {
default