summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/cgoban2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/cgoban2')
-rw-r--r--games-board/cgoban2/Manifest1
-rw-r--r--games-board/cgoban2/cgoban2-2.6.12.ebuild28
-rw-r--r--games-board/cgoban2/files/cgoban212
-rw-r--r--games-board/cgoban2/metadata.xml9
4 files changed, 50 insertions, 0 deletions
diff --git a/games-board/cgoban2/Manifest b/games-board/cgoban2/Manifest
new file mode 100644
index 000000000000..a685dfae8a40
--- /dev/null
+++ b/games-board/cgoban2/Manifest
@@ -0,0 +1 @@
+DIST cgoban-unix-2.6.12.tar.bz2 1180638 SHA256 08547991722300871c54536b0fc8498b93c543cd746e2ff874e0fc2319cce2cf SHA512 70725778ea25d4054d6944a25b512fe247ebc2280395cb0f4ee58e2f3c96dc6405ea3ed2ec03637ea3b3f2d4be470110181b117cedc13fad28bf8f66d146f6a3 WHIRLPOOL 569bc68bbbbca4870d1dd934453d63daa9b9d16ac7387ce6e79b78e6c53020915374b27f318aa75b83ca862b1c07022118901fba3c9da6cfa9429d599b5d1644
diff --git a/games-board/cgoban2/cgoban2-2.6.12.ebuild b/games-board/cgoban2/cgoban2-2.6.12.ebuild
new file mode 100644
index 000000000000..55aa2bc51abc
--- /dev/null
+++ b/games-board/cgoban2/cgoban2-2.6.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="A Java client for the Kiseido Go Server, and a SGF editor"
+HOMEPAGE="http://www.gokgs.com/"
+SRC_URI="mirror://gentoo/cgoban-unix-${PV}.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.3"
+
+S=${WORKDIR}/cgoban
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ sed -e "s:INSTALL_DIR:${GAMES_DATADIR}/${PN}:" \
+ "${FILESDIR}/${PN}" > "${D}${GAMES_BINDIR}/${PN}" || die
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins cgoban.jar
+ prepgamesdirs
+}
diff --git a/games-board/cgoban2/files/cgoban2 b/games-board/cgoban2/files/cgoban2
new file mode 100644
index 000000000000..5a5e067af2ad
--- /dev/null
+++ b/games-board/cgoban2/files/cgoban2
@@ -0,0 +1,12 @@
+#!/bin/sh
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+which java > /dev/null 2>&1 && \
+ java -jar INSTALL_DIR/cgoban.jar "${@}" && \
+ exit 0
+
+echo "No \"java\" binary found in your PATH."
+echo "You should run \"java-config\" to choose your default VM."
+exit 1
diff --git a/games-board/cgoban2/metadata.xml b/games-board/cgoban2/metadata.xml
new file mode 100644
index 000000000000..b4647c10eaf6
--- /dev/null
+++ b/games-board/cgoban2/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>mr_bones_@gentoo.org</email>
+<name>Michael Sterrett</name>
+</maintainer>
+</pkgmetadata>