summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-29 00:19:30 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-29 02:40:56 -0500
commit706909c05d32c53b96e07afa24de97a4135fad55 (patch)
tree66e979c556d90bfc2b99bbcf2cb0f3764bade6e8 /games-fps/rott/rott-1.0.ebuild
parentold (diff)
downloadgentoo-706909c05d32c53b96e07afa24de97a4135fad55.tar.gz
gentoo-706909c05d32c53b96e07afa24de97a4135fad55.tar.bz2
gentoo-706909c05d32c53b96e07afa24de97a4135fad55.zip
old
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-fps/rott/rott-1.0.ebuild')
-rw-r--r--games-fps/rott/rott-1.0.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/games-fps/rott/rott-1.0.ebuild b/games-fps/rott/rott-1.0.ebuild
deleted file mode 100644
index fdfaf9721e56..000000000000
--- a/games-fps/rott/rott-1.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils games
-
-DESCRIPTION="Rise of the Triad for Linux!"
-HOMEPAGE="http://www.icculus.org/rott/"
-SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
- demo? ( http://filesingularity.timedoctor.org/swdata.zip )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~ppc x86"
-IUSE="demo"
-
-RDEPEND="media-libs/libsdl
- media-libs/sdl-mixer"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${P}/rott
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch \
- "${FILESDIR}"/${PV}-custom-datapath.patch \
- "${FILESDIR}"/${P}-gcc41.patch
- use demo || epatch "${FILESDIR}"/${P}-full-version.patch
-}
-
-src_compile() {
- emake clean || die
- emake -j1 EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"${GAMES_DATADIR}/${PN}/\\\"" \
- || die "emake failed"
-}
-
-src_install() {
- dogamesbin rott || die "dogamesbin failed"
- dodoc *.txt ../{README,readme.txt}
- if use demo ; then
- cd "${WORKDIR}"
- insinto "${GAMES_DATADIR}"/${PN}
- doins *.dmo huntbgin.* remote1.rts || die "doins failed"
- fi
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- if ! use demo ; then
- elog "To play the full version, just copy the"
- elog "data files to ${GAMES_DATADIR}/${PN}/"
- fi
-}