summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-12 15:09:19 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-12 15:09:34 +0300
commitb9d1811092e620d5c21de390f6c6a97c4e8459aa (patch)
treed192ae9a6b1e941a64dee4e993e81a93d571eb2d /games-fps
parentmail-client/claws-mail: Stabilize 3.21.0-r1 arm64, #935895 (diff)
downloadgentoo-b9d1811092e620d5c21de390f6c6a97c4e8459aa.tar.gz
gentoo-b9d1811092e620d5c21de390f6c6a97c4e8459aa.tar.bz2
gentoo-b9d1811092e620d5c21de390f6c6a97c4e8459aa.zip
games-fps/wolfgl: treeclean
Bug: https://bugs.gentoo.org/926467 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/wolfgl/Manifest3
-rw-r--r--games-fps/wolfgl/files/0.93-gcc.patch209
-rw-r--r--games-fps/wolfgl/files/0.93-gcc4.patch80
-rw-r--r--games-fps/wolfgl/files/0.93-sample-rate.patch11
-rw-r--r--games-fps/wolfgl/files/0.93-sprite.patch82
-rw-r--r--games-fps/wolfgl/files/wolfgl-0.93-as-needed.patch11
-rw-r--r--games-fps/wolfgl/metadata.xml11
-rw-r--r--games-fps/wolfgl/wolfgl-0.93-r2.ebuild54
8 files changed, 0 insertions, 461 deletions
diff --git a/games-fps/wolfgl/Manifest b/games-fps/wolfgl/Manifest
deleted file mode 100644
index bc615f8e5c70..000000000000
--- a/games-fps/wolfgl/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST sdmdata.zip 557147 BLAKE2B a70a821941175aecfd3edd7746ed54e13181863ddb25bfcc77bf354b1366541b71462739543a1ba9aa548a754b8a88db60eff0cf5d8313097f6d41cb62892b3a SHA512 cf6eae7027acbe6e3da6985639eb36def04254790f6449f5353ffe5edd13a73c01b0a35ef9873f2e97d09ec59e632337c5b3a1a26185befdf4dfa5a161267076
-DIST wolfdata.zip 564771 BLAKE2B 0c1343cae6fbcb695930899fd2ba9e5798af47f4bec984fa15cdca85c9d96e5dd9ed6e5ff2b7bc489251e5be6342ed94a8cb7c626f39564a8599d5d3fe5eb6d2 SHA512 2b14c477e54d14fc543e146fa699f55dabb003bd3bac1e89422a49391cf8f29b5db6967b09c08a82c612f73fe71d624902c180d81481ad42f011f51448652a43
-DIST wolfgl-0.93.tbz2 146132 BLAKE2B b9dbf442be01a516c5cbf1146892d610df881109ca163ec7c1c79bd9ea1c328d8e9401ba5615e1be9c2df5df3940b83fdbe36154c4f0429b617dc6208b6ccf78 SHA512 834dda2eb4e099d70fad52e40760886208c5ca60e687024f1fe51088b94c8cdea7c058d326daa61966946bb70feeee97d0b7fb7c284e98fdec0eb8c503de7e30
diff --git a/games-fps/wolfgl/files/0.93-gcc.patch b/games-fps/wolfgl/files/0.93-gcc.patch
deleted file mode 100644
index a22923393678..000000000000
--- a/games-fps/wolfgl/files/0.93-gcc.patch
+++ /dev/null
@@ -1,209 +0,0 @@
-diff -abur a/common/console.c b/common/console.c
---- a/common/console.c 2000-09-27 16:19:44.000000000 +0200
-+++ b/common/console.c 2003-09-11 19:59:46.037562040 +0200
-@@ -3,6 +3,14 @@
- #include "id_us.h"
- #include "console.h"
-
-+#ifdef _LINUX
-+#include <string.h>
-+#endif
-+
-+#ifdef _LINUX
-+#include <string.h>
-+#endif
-+
- static char con_lines[32][45]; // buffer
- static int con_active; // console is visible
- static int con_current; // current line
-diff -abur a/common/id_in.h b/common/id_in.h
---- a/common/id_in.h 2000-09-27 16:04:26.000000000 +0200
-+++ b/common/id_in.h 2003-09-11 19:32:14.368653880 +0200
-@@ -178,6 +178,7 @@
-
- void IN_Startup();
- void IN_Shutdown();
-+void IN_KeyEvent(unsigned char key);
- void IN_Default(wbool gotit, ControlType in);
- void IN_ClearKeysDown();
- void IN_ReadControl(int player, ControlInfo *info);
-diff -abur a/common/id_vh.c b/common/id_vh.c
---- a/common/id_vh.c 2000-09-26 17:39:36.000000000 +0200
-+++ b/common/id_vh.c 2003-09-11 19:24:57.183116184 +0200
-@@ -230,3 +230,4 @@
-
- }
- */
-\ No newline at end of file
-+
-diff -abur a/common/opengl.c b/common/opengl.c
---- a/common/opengl.c 2000-09-27 16:04:26.000000000 +0200
-+++ b/common/opengl.c 2003-09-11 19:22:35.622636648 +0200
-@@ -1,5 +1,10 @@
- #include <stdio.h>
- #include <stdlib.h>
-+
-+#ifdef _LINUX
-+#include <string.h>
-+#endif
-+
- #include "system.h"
- #include "opengl.h"
- #include "wl_def.h"
-diff -abur a/common/wl_act2.c b/common/wl_act2.c
---- a/common/wl_act2.c 2000-09-27 16:04:26.000000000 +0200
-+++ b/common/wl_act2.c 2003-09-11 19:19:45.511497472 +0200
-@@ -1,5 +1,9 @@
- // WL_ACT2.C
-
-+#ifdef _LINUX
-+#include <stdlib.h>
-+#endif
-+
- #include "wl_def.h"
-
- //=============================================================================
-diff -abur a/common/wl_agent.c b/common/wl_agent.c
---- a/common/wl_agent.c 2003-09-11 20:04:40.738760648 +0200
-+++ b/common/wl_agent.c 2003-09-11 19:57:06.860760592 +0200
-@@ -3,6 +3,10 @@
- #include <string.h>
- #include "wl_def.h"
-
-+#ifdef _LINUX
-+#include <stdlib.h>
-+#endif
-+
- //=============================================================================
- // LOCAL CONSTANTS
- //=============================================================================
-diff -abur a/common/wl_draw.c b/common/wl_draw.c
---- a/common/wl_draw.c 2003-09-11 20:04:40.739760496 +0200
-+++ b/common/wl_draw.c 2003-09-11 19:20:33.512200256 +0200
-@@ -2,6 +2,11 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+
-+#ifdef _LINUX
-+#include <string.h>
-+#endif
-+
- #include "system.h"
- #include "opengl.h"
- #include "wl_def.h"
-diff -abur a/common/wl_menu.c b/common/wl_menu.c
---- a/common/wl_menu.c 2000-09-27 16:04:27.000000000 +0200
-+++ b/common/wl_menu.c 2003-09-11 20:07:38.892677136 +0200
-@@ -5,6 +5,10 @@
- //
- ////////////////////////////////////////////////////////////////////
-
-+#ifdef _LINUX
-+#include "../linux/input.h"
-+#endif
-+
- #include <string.h>
- #include "opengl.h"
- #include "wl_def.h"
-diff -abur a/common/wl_menu.h b/common/wl_menu.h
---- a/common/wl_menu.h 2000-09-26 17:38:31.000000000 +0200
-+++ b/common/wl_menu.h 2003-09-11 18:31:41.593919584 +0200
-@@ -233,3 +233,4 @@
- void NonShareware();
- /*int GetYorN(int x,int y,int pic);
- */
-\ No newline at end of file
-+
-diff -abur a/common/wl_play.c b/common/wl_play.c
---- a/common/wl_play.c 2000-09-27 16:04:27.000000000 +0200
-+++ b/common/wl_play.c 2003-09-11 19:40:31.293109880 +0200
-@@ -1,6 +1,11 @@
- // WL_PLAY.C
-
- #include <memory.h>
-+
-+#ifdef _LINUX
-+#include "../linux/input.h"
-+#endif
-+
- #include "wl_def.h"
- #include "system.h"
-
-diff -abur a/common/wl_state.c b/common/wl_state.c
---- a/common/wl_state.c 2000-09-27 16:04:27.000000000 +0200
-+++ b/common/wl_state.c 2003-09-11 19:23:26.895841936 +0200
-@@ -2,6 +2,10 @@
-
- #include "wl_def.h"
-
-+#ifdef _LINUX
-+#include <stdlib.h>
-+#endif
-+
- //=============================================================================
- // GLOBAL VARIABLES
- //=============================================================================
-diff -abur a/common/wl_text.c b/common/wl_text.c
---- a/common/wl_text.c 2000-09-26 17:40:23.000000000 +0200
-+++ b/common/wl_text.c 2003-09-11 19:19:00.110399488 +0200
-@@ -4,6 +4,10 @@
- #include "wl_def.h"
- #include "system.h"
-
-+#ifdef _LINUX
-+#include <string.h>
-+#endif
-+
- #ifndef SPEAR
-
- void FreeMusic(); // WL_MENU.C
-diff -abur a/linux/sound.c b/linux/sound.c
---- a/linux/sound.c 2000-09-26 17:57:48.000000000 +0200
-+++ b/linux/sound.c 2003-09-11 19:55:16.702507192 +0200
-@@ -9,6 +9,8 @@
- #include <stdlib.h>
-
- #include <sys/time.h>
-+#include <string.h>
-+#include <errno.h>
-
- #include <fcntl.h>
- #include <unistd.h>
-diff -abur a/linux/sound.h b/linux/sound.h
---- a/linux/sound.h 2000-09-26 17:57:48.000000000 +0200
-+++ b/linux/sound.h 2003-09-11 19:44:03.663824624 +0200
-@@ -1,5 +1,8 @@
- void S_LoadSound(int id, void* data, long length);
- void S_PlaySound(int id, int pan);
-+void S_UpdateSound();
-+void S_InitSound();
-+void S_ShutDownSound();
-
- extern int DigitalDevice;
-
-diff -abur a/linux/system.c b/linux/system.c
---- a/linux/system.c 2000-09-26 17:57:48.000000000 +0200
-+++ b/linux/system.c 2003-09-11 19:42:14.955350824 +0200
-@@ -1,9 +1,12 @@
- #include <stdio.h>
-+#include <string.h>
-+#include <unistd.h>
- #include <sys/time.h>
- #include <X11/keysym.h>
- #include <GL/gl.h>
- #include <GL/glx.h>
- #include "wl_def.h"
-+#include "sound.h"
-
- int screen_width, screen_height;
- Display *dpy;
-@@ -117,7 +120,7 @@
- visinfo = glXChooseVisual( dpy, scrnum, attrib );
- if (!visinfo) {
- printf("Error: couldn't get an RGB, Double-buffered visual\n");
-- exit(1);
-+ _exit(1);
- }
-
- /* window attributes */
diff --git a/games-fps/wolfgl/files/0.93-gcc4.patch b/games-fps/wolfgl/files/0.93-gcc4.patch
deleted file mode 100644
index 5dcccd76049b..000000000000
--- a/games-fps/wolfgl/files/0.93-gcc4.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-diff -ur wolfgl-0.93-orig/common/id_ca.c wolfgl-0.93/common/id_ca.c
---- wolfgl-0.93-orig/common/id_ca.c 2006-01-28 16:59:10.000000000 -0500
-+++ wolfgl-0.93/common/id_ca.c 2006-01-28 17:04:26.000000000 -0500
-@@ -252,6 +252,7 @@
- {
- unsigned short ch,chhigh,count,offset;
- unsigned short *copyptr, *inptr, *outptr;
-+ unsigned char *uc_inptr;
-
- length/=2;
-
-@@ -268,13 +269,17 @@
- if (!count)
- {
- // have to insert a word containing the tag byte
-- ch |= *((unsigned char*)inptr)++;
-+ uc_inptr = (unsigned char*)inptr;
-+ ch |= *(uc_inptr)++;
-+ inptr = (unsigned short *)uc_inptr;
- *outptr++ = ch;
- length--;
- }
- else
- {
-- offset = *((unsigned char*)inptr)++;
-+ uc_inptr = (unsigned char*)inptr;
-+ offset = *(uc_inptr)++;
-+ inptr = (unsigned short *)uc_inptr;
- copyptr = outptr - offset;
- length -= count;
- while (count--)
-@@ -287,7 +292,9 @@
- if (!count)
- {
- // have to insert a word containing the tag byte
-- ch |= *((unsigned char*)inptr)++;
-+ uc_inptr = (unsigned char*)inptr;
-+ ch |= *(uc_inptr)++;
-+ inptr = (unsigned short *)uc_inptr;
- *outptr++ = ch;
- length --;
- }
-@@ -806,7 +813,7 @@
-
- for (i=0;i<NUMCHUNKS;i++)
- if (grsegs[i])
-- MM_SetPurge (&(memptr)grsegs[i],3);
-+ MM_SetPurge ((memptr)&grsegs[i],3);
- ca_levelbit<<=1;
- ca_levelnum++;
- }
-@@ -862,7 +869,7 @@
-
- for (i = 0; i < NUMCHUNKS; i++)
- if (grsegs[i])
-- MM_SetPurge (&(memptr)grsegs[i],3);
-+ MM_SetPurge ((memptr)&grsegs[i],3);
- }
-
- //===========================================================================
-diff -ur wolfgl-0.93-orig/common/wl_game.c wolfgl-0.93/common/wl_game.c
---- wolfgl-0.93-orig/common/wl_game.c 2006-01-28 16:59:10.000000000 -0500
-+++ wolfgl-0.93/common/wl_game.c 2006-01-28 17:07:08.000000000 -0500
-@@ -545,13 +545,13 @@
- {
- // solid wall
- tilemap[x][y] = tile;
-- (unsigned short)actorat[x][y] = tile;
-+ actorat[x][y] = tile;
- }
- else
- {
- // area floor
- tilemap[x][y] = 0;
-- (unsigned short)actorat[x][y] = 0;
-+ actorat[x][y] = 0;
- }
- }
-
-
diff --git a/games-fps/wolfgl/files/0.93-sample-rate.patch b/games-fps/wolfgl/files/0.93-sample-rate.patch
deleted file mode 100644
index 6e7156a1c716..000000000000
--- a/games-fps/wolfgl/files/0.93-sample-rate.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/linux/sound.c 2003-09-11 20:28:32.032170976 +0200
-+++ b/linux/sound.c 2003-09-11 20:28:45.111182664 +0200
-@@ -64,7 +64,7 @@
- #define BUFMUL 4
- #define MIXBUFFERSIZE (SAMPLECOUNT*BUFMUL)
-
--#define SAMPLERATE 11025 // Hz
-+#define SAMPLERATE 8000 // Hz
- #define SAMPLESIZE 2 // 16bit
-
- // The actual output device.
diff --git a/games-fps/wolfgl/files/0.93-sprite.patch b/games-fps/wolfgl/files/0.93-sprite.patch
deleted file mode 100644
index 135eb8e26eed..000000000000
--- a/games-fps/wolfgl/files/0.93-sprite.patch
+++ /dev/null
@@ -1,82 +0,0 @@
---- a/common/wl_agent.c 2003-09-11 20:39:02.674298800 +0200
-+++ b/common/wl_agent.c 2003-09-11 20:42:17.229721880 +0200
-@@ -919,32 +919,31 @@
- viewdist = 0x7fffffffl;
- closest = NULL;
-
--// while (1)
-+ while (1)
- {
- oldclosest = closest;
-
- for (check=ob->next ; check ; check=check->next)
- if ((check->flags & FL_SHOOTABLE)
-- //&&
-+ &&
- // (check->flags & FL_VISABLE) &&
--// (abs(check->viewx - centerx) < shootdelta)
-+ (abs(check->viewx - centerx) < shootdelta)
- )
--// {
-+ {
- if (CheckLine(check))
--// if (check->transx < viewdist)
-+ if (check->transx < viewdist)
- {
--// viewdist = check->transx;
-+ viewdist = check->transx;
- closest = check;
-- break;
- }
--// }
-+ }
-
- if (closest == oldclosest)
- return; // no more targets, all missed
-
- // trace a line from player to enemey
--// if (CheckLine(closest))
--// break;
-+ if (CheckLine(closest))
-+ break;
- }
-
- // hit something
---- a/common/wl_draw.c 2003-09-11 20:43:26.473195272 +0200
-+++ b/common/wl_draw.c 2003-09-11 20:46:57.859059736 +0200
-@@ -877,7 +877,7 @@
- tilespot = &tilemap[0][0]+spotloc;
-
- // could be in any of the nine surrounding tiles
-- if ((*visspot) ||
-+ if (1 || (*visspot) ||
- (*(visspot-1) && !*(tilespot-1)) ||
- (*(visspot+1) && !*(tilespot+1)) ||
- (*(visspot-65) && !*(tilespot-65)) ||
-@@ -980,6 +980,8 @@
-
- for (obj = player->next; obj; obj = obj->next)
- {
-+ int sprite;
-+
- if (!areabyplayer[obj->areanumber])
- continue;
- if (!gamestates[obj->state].shapenum)
-@@ -989,10 +991,14 @@
- glTranslated((float)obj->x/(1<<16), (float)obj->y/(1<<16), 0);
- glRotated(-player->angle, 0,0,1);
-
-- if (texture_index[PMSpriteStart+gamestates[obj->state].shapenum] == 0)
-- CreateSprite(PMSpriteStart+gamestates[obj->state].shapenum);
-+ sprite = gamestates[obj->state].shapenum;
-+ if (gamestates[obj->state].rotate)
-+ sprite += CalcRotate(obj);
-+
-+ if (texture_index[PMSpriteStart+sprite] == 0)
-+ CreateSprite(PMSpriteStart+sprite);
- else
-- glBindTexture(GL_TEXTURE_2D, texture_index[PMSpriteStart+gamestates[obj->state].shapenum]);
-+ glBindTexture(GL_TEXTURE_2D, texture_index[PMSpriteStart+sprite]);
-
- glBegin(GL_QUADS);
- glTexCoord2f(0,0);
diff --git a/games-fps/wolfgl/files/wolfgl-0.93-as-needed.patch b/games-fps/wolfgl/files/wolfgl-0.93-as-needed.patch
deleted file mode 100644
index f9da771e1d79..000000000000
--- a/games-fps/wolfgl/files/wolfgl-0.93-as-needed.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/linux/Makefile 2009-02-06 14:27:11.000000000 +0100
-+++ b/linux/Makefile 2009-02-06 14:27:40.000000000 +0100
-@@ -19,7 +19,7 @@
- @echo 'Do not call this file directly'
-
- wolfgl: $(LINUX_OBJS) $(COMMON_OBJS)
-- $(CC) $(LINK_FLAGS) $(COMMON_OBJS) $(LINUX_OBJS) -o $(OUTDIR)/wolfgl
-+ $(CC) $(LDFLAGS) $(COMMON_OBJS) $(LINUX_OBJS) $(LINK_FLAGS) -o $(OUTDIR)/wolfgl
-
- # common directory
-
diff --git a/games-fps/wolfgl/metadata.xml b/games-fps/wolfgl/metadata.xml
deleted file mode 100644
index d601ba94dc9f..000000000000
--- a/games-fps/wolfgl/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">wolfgl</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/games-fps/wolfgl/wolfgl-0.93-r2.ebuild b/games-fps/wolfgl/wolfgl-0.93-r2.ebuild
deleted file mode 100644
index 84efaf3dc759..000000000000
--- a/games-fps/wolfgl/wolfgl-0.93-r2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-#ECVS_SERVER="wolfgl.cvs.sourceforge.net:/cvsroot/wolfgl"
-#ECVS_MODULE="wolfgl"
-#inherit cvs
-
-DESCRIPTION="Wolfenstein and Spear of Destiny port using OpenGL"
-HOMEPAGE="http://wolfgl.sourceforge.net/"
-SRC_URI="mirror://gentoo/${P}.tbz2
- https://downloads.sourceforge.net/wolfgl/wolfdata.zip
- https://downloads.sourceforge.net/wolfgl/sdmdata.zip"
-# https://downloads.sourceforge.net/wolfgl/wolfglx-wl6-${PV}.zip
-# https://downloads.sourceforge.net/wolfgl/wolfglx-sod-${PV}.zip
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-RDEPEND="virtual/opengl"
-DEPEND="${RDEPEND}
- app-arch/unzip
- x11-base/xorg-proto"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-gcc.patch
- "${FILESDIR}"/${PV}-sample-rate.patch
- "${FILESDIR}"/${PV}-sprite.patch
- "${FILESDIR}"/${P}-as-needed.patch
- "${FILESDIR}"/${PV}-gcc4.patch
-)
-
-src_compile() {
- emake -j1 CFLAGS="${CFLAGS}" DATADIR="/usr/share/${PN}"
-}
-
-src_install() {
- newbin linux/SDM/wolfgl wolfgl-sdm
- newbin linux/SOD/wolfgl wolfgl-sod
- newbin linux/WL1/wolfgl wolfgl-wl1
- newbin linux/WL6/wolfgl wolfgl-wl6
-
- insinto /usr/share/${PN}
- doins "${WORKDIR}"/*.{sdm,wl1}
-}
-
-pkg_postinst() {
- elog "This installed the shareware data files for"
- elog "Wolfenstein 3D and Spear Of Destiny."
- elog "If you wish to play the full versions just"
- elog "copy the data files to /usr/share/${PN}/"
-}