summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-25 19:04:12 +0000
committerSam James <sam@gentoo.org>2021-04-25 19:13:31 +0000
commite97bb8a8a1c7d14bf1f42cd397b8065c8a9c9849 (patch)
treeba069294b2f8efbea015f9f7e3fb80008de52b98 /games-fps
parentwww-servers/mongrel2: respect *FLAGS, $(AR) and $(RANLIB) (diff)
downloadgentoo-e97bb8a8a1c7d14bf1f42cd397b8065c8a9c9849.tar.gz
gentoo-e97bb8a8a1c7d14bf1f42cd397b8065c8a9c9849.tar.bz2
gentoo-e97bb8a8a1c7d14bf1f42cd397b8065c8a9c9849.zip
games-fps/darkplaces: fix pre-stripped files, respecting CC
Can't reproduce CFLAGS issue right now. Closes: https://bugs.gentoo.org/739194 Closes: https://bugs.gentoo.org/739200 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/darkplaces/darkplaces-20140513-r1.ebuild23
1 files changed, 18 insertions, 5 deletions
diff --git a/games-fps/darkplaces/darkplaces-20140513-r1.ebuild b/games-fps/darkplaces/darkplaces-20140513-r1.ebuild
index c0fafee1498d..171eaa03f68e 100644
--- a/games-fps/darkplaces/darkplaces-20140513-r1.ebuild
+++ b/games-fps/darkplaces/darkplaces-20140513-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic unpacker
+EAPI=7
+
+inherit desktop flag-o-matic wrapper unpacker
# Latest versions are in http://icculus.org/twilight/darkplaces/files/
MY_PV="${PV/_beta/beta}"
@@ -18,6 +19,7 @@ SRC_URI="http://icculus.org/twilight/${PN}/files/${MY_ENGINE}
lights? (
http://www.fuhquake.net/files/extras/${MY_LIGHTS}
http://www.kgbsyndicate.com/romi/id1.pk3 )"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
@@ -60,14 +62,17 @@ DEPEND="lights? ( || (
!opengl? ( !sdl? ( !dedicated? (
${UIRDEPEND}
${UIDEPEND} ) ) )
- virtual/pkgconfig
+"
+BDEPEND="
app-arch/unzip
+ virtual/pkgconfig
"
-S="${WORKDIR}/${PN}"
dir="/usr/share/quake1"
-opengl_client() { use opengl || ( ! use dedicated && ! use sdl ) }
+opengl_client() {
+ use opengl || ( ! use dedicated && ! use sdl )
+}
src_unpack() {
if use lights ; then
@@ -76,6 +81,7 @@ src_unpack() {
mv *.lit maps/ || die
mv ReadMe.txt rtlights.txt
fi
+
unpack "${MY_ENGINE}"
unpack ./${PN}*.zip
}
@@ -115,6 +121,12 @@ src_prepare() {
src_compile() {
local opts="DP_FS_BASEDIR=\"${dir}\" DP_LINK_TO_LIBJPEG=1"
+ # Protect against people choosing a strip implementation
+ # bug #739194
+ opts+="STRIP=true"
+
+ tc-export CC
+
# Preferred sound is alsa
local sound_api="NULL"
use oss && sound_api="OSS"
@@ -168,6 +180,7 @@ src_install() {
if use lights ; then
insinto "${dir}"/id1
doins -r "${WORKDIR}"/{cubemaps,maps}
+
if use demo ; then
# Set up symlinks, for the demo levels to include the lights
local d