summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/tornado
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/tornado')
-rw-r--r--games-strategy/tornado/Manifest1
-rw-r--r--games-strategy/tornado/files/tornado-1.4-gentoo.patch26
-rw-r--r--games-strategy/tornado/metadata.xml5
-rw-r--r--games-strategy/tornado/tornado-1.4.ebuild38
4 files changed, 70 insertions, 0 deletions
diff --git a/games-strategy/tornado/Manifest b/games-strategy/tornado/Manifest
new file mode 100644
index 000000000000..fd05abfe73ec
--- /dev/null
+++ b/games-strategy/tornado/Manifest
@@ -0,0 +1 @@
+DIST tornado-1.4.tar.gz 54591 SHA256 d0506377c9b80581a6167a9d97233638678943bbc0a32fb714e09cf0e918b791 SHA512 764c18b228a24cdcaf1456af79d1bdb997f200c09bc33d8f54df28f1f995db1b1a3a328550c5561bc8ebd38d4187f472aa1c892d91889e613b9ff42b86bee322 WHIRLPOOL adede7e43642f1c03200c4b903612ba01aaa761f5c74002322bcc98d3abc97680826f4b7aead6aabc6b0fc9f7b6264593cb9ee453e93cf42d5bdf6dd1e7bd17f
diff --git a/games-strategy/tornado/files/tornado-1.4-gentoo.patch b/games-strategy/tornado/files/tornado-1.4-gentoo.patch
new file mode 100644
index 000000000000..fb8966841158
--- /dev/null
+++ b/games-strategy/tornado/files/tornado-1.4-gentoo.patch
@@ -0,0 +1,26 @@
+--- Makefile.old 2009-02-12 12:42:25.000000000 +0100
++++ Makefile 2009-02-12 12:44:52.000000000 +0100
+@@ -1,10 +1,9 @@
+-CC = gcc
+ MAKE = make
+-LDFLAGS = -lncurses
++LDLIBS = -lncurses
+ OBJFILES = main.o draw.o erwin.o network.o scores.o
+-PREFIX = /usr/local
+-LOCALEPATH = /usr/local/share/locale
+-CFLAGS = -Wall -O2 -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\""
++PREFIX = /usr
++LOCALEPATH = /usr/share/locale
++CFLAGS += -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\""
+ VERSION = `grep " VERSION" version.h | sed s/\"//g | sed s/\#define\ VERSION\ //`
+ LOCALES = de
+ MAN = doc/man
+@@ -25,7 +24,7 @@
+ $(MAKE) -C $(MAN) all
+
+ tornado: $(OBJFILES)
+- $(CC) $(LDFLAGS) $(OBJFILES) -o tornado
++ $(CC) $(LDFLAGS) $(OBJFILES) $(LDLIBS) -o tornado
+
+ debug: tornado.6 locales
+ gcc -g -ggdb -Wall -ansi -pedantic -o tornado draw.c main.c erwin.c network.c scores.c -lncurses -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\""
diff --git a/games-strategy/tornado/metadata.xml b/games-strategy/tornado/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/tornado/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-strategy/tornado/tornado-1.4.ebuild b/games-strategy/tornado/tornado-1.4.ebuild
new file mode 100644
index 000000000000..fa428300b3c7
--- /dev/null
+++ b/games-strategy/tornado/tornado-1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Clone of a C64 game - destroy the opponent's house"
+HOMEPAGE="http://kiza.kcore.de/software/tornado/"
+SRC_URI="http://kiza.kcore.de/software/tornado/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "s:PREFIX/bin:${GAMES_BINDIR}:" \
+ -e "s:PREFIX/man:/usr/man:" \
+ -e "s:/var/games:${GAMES_STATEDIR}:" \
+ -e "s:/usr/local:/usr:" \
+ doc/man/tornado.6.in \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ dogamesbin tornado
+ doman doc/man/tornado.6
+ dodoc AUTHOR CREDITS Changelog README TODO
+ insinto "${GAMES_STATEDIR}"
+ doins tornado.scores
+ prepgamesdirs
+ fperms 664 "${GAMES_STATEDIR}/tornado.scores"
+}