summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-30 07:21:47 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-30 07:43:12 -0400
commit79636c2c4ad89a7dc45490fa7db9791536b83f95 (patch)
tree827f08457cc5e9f8f50f7de0d29ac239727fd400 /games-strategy
parentgames-strategy/widelands: add 1.2 (diff)
downloadgentoo-79636c2c4ad89a7dc45490fa7db9791536b83f95.tar.gz
gentoo-79636c2c4ad89a7dc45490fa7db9791536b83f95.tar.bz2
gentoo-79636c2c4ad89a7dc45490fa7db9791536b83f95.zip
games-strategy/widelands: sync live
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/widelands/widelands-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/games-strategy/widelands/widelands-9999.ebuild b/games-strategy/widelands/widelands-9999.ebuild
index 694f1e6b01d3..a573f92451d1 100644
--- a/games-strategy/widelands/widelands-9999.ebuild
+++ b/games-strategy/widelands/widelands-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake python-any-r1 xdg
if [[ ${PV} == 9999 ]]; then
@@ -32,13 +32,16 @@ RDEPEND="
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-ttf
sys-libs/zlib:=[minizip]
- virtual/libintl"
+ virtual/libintl
+"
DEPEND="
${RDEPEND}
- dev-cpp/asio"
+ dev-cpp/asio
+"
BDEPEND="
${PYTHON_DEPS}
- sys-devel/gettext"
+ sys-devel/gettext
+"
src_configure() {
CMAKE_BUILD_TYPE=Release # disables -Werror