summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-15 05:18:44 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-15 05:34:37 -0500
commit9e84876a3a53d4a8d0be682958d7f26f15ab4588 (patch)
treed6bdb9784447db5af2153570dd15d7f4bc9bd823 /games-strategy
parentgames-strategy/widelands: update live, enable py3.13 (diff)
downloadgentoo-9e84876a3a53d4a8d0be682958d7f26f15ab4588.tar.gz
gentoo-9e84876a3a53d4a8d0be682958d7f26f15ab4588.tar.bz2
gentoo-9e84876a3a53d4a8d0be682958d7f26f15ab4588.zip
games-strategy/widelands: add 1.2.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/widelands/Manifest1
-rw-r--r--games-strategy/widelands/widelands-1.2.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/games-strategy/widelands/Manifest b/games-strategy/widelands/Manifest
index 586eed9ef89a..3a45b1008bff 100644
--- a/games-strategy/widelands/Manifest
+++ b/games-strategy/widelands/Manifest
@@ -1 +1,2 @@
+DIST widelands-1.2.1.tar.gz 457853247 BLAKE2B 8af9febc4379f52f2343bff244e7ec3c42e63792e2a93f61446df81a101201d1471d20c8c1b73d6267f5066d3861bfc802227b2abd4b0fc172b447d0b598ddfd SHA512 9a7449096dab8ff07ac12354f4fb659fcbe419381d289e869c134c5b804c8817f9fbffb854283ab0b5bca541e9649f7f0e7658fd2765bc2a8a8f705dc24f01d8
DIST widelands-1.2.tar.gz 457713595 BLAKE2B b89caef369268b31fb70c4b054f1df3651e974763c6b2d82488a662a7edaed19f525177371592f9ad28cc14194044d48862e22b38a3a449c6e7ed0023bf30d09 SHA512 e05812f93defe8b9a3da60e6ba73a65bba47abec3199298f9a778fb42655aba671cb45a2603c2936538de1e0f82892a183ea5e1df15937b9812d369d068fab81
diff --git a/games-strategy/widelands/widelands-1.2.1.ebuild b/games-strategy/widelands/widelands-1.2.1.ebuild
new file mode 100644
index 000000000000..c3f0df651d6b
--- /dev/null
+++ b/games-strategy/widelands/widelands-1.2.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake python-any-r1 xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/widelands/widelands.git"
+else
+ SRC_URI="
+ https://github.com/widelands/widelands/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Game similar to Settlers 2"
+HOMEPAGE="https://www.widelands.org/"
+
+LICENSE="GPL-2+ || ( Apache-2.0 GPL-3 ) BitstreamVera BSD CC-BY-SA-3.0 MIT OFL-1.1"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/icu:=
+ media-libs/glew:0=
+ media-libs/libglvnd
+ media-libs/libpng:=
+ media-libs/libsdl2[opengl,sound,video]
+ media-libs/sdl2-image[jpeg,png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-ttf
+ sys-libs/zlib:=[minizip]
+ virtual/libintl
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/asio
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWL_INSTALL_BASEDIR="${EPREFIX}"/usr/share/doc/${PF}
+ -DWL_INSTALL_BINDIR="${EPREFIX}"/usr/bin
+ -DWL_INSTALL_DATADIR="${EPREFIX}"/usr/share/${PN}
+ -DGTK_UPDATE_ICON_CACHE=OFF
+ -DOPTION_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}