summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/biounzip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/biounzip')
-rw-r--r--games-util/biounzip/Manifest1
-rw-r--r--games-util/biounzip/biounzip-1.1a.ebuild33
-rw-r--r--games-util/biounzip/files/biounzip-1.1a-64bit.patch11
-rw-r--r--games-util/biounzip/metadata.xml8
4 files changed, 53 insertions, 0 deletions
diff --git a/games-util/biounzip/Manifest b/games-util/biounzip/Manifest
new file mode 100644
index 000000000000..b8de7f59135d
--- /dev/null
+++ b/games-util/biounzip/Manifest
@@ -0,0 +1 @@
+DIST biounzip-1.1a.tar.bz2 9894 SHA256 8f6960e4a281f6ce352e499d91de71ccd74536619000a4dfd37d2eb92c740273 SHA512 4eaea5459cf6edaf289951f9048123496a4eb83fcfc39b3efcd2a81894f877d5db843d7448e2c0e3b797b09a70f6f3c133c53525d4f83408306089bd37796a8c WHIRLPOOL 7a0222298cadd1643f4e91cc9a4bced961692ff566eaccbe5d4b37c16453e8c119f5921b536a81eba088e4c35e7dd789d8fc9a36e93ba39de22f83372882eb06
diff --git a/games-util/biounzip/biounzip-1.1a.ebuild b/games-util/biounzip/biounzip-1.1a.ebuild
new file mode 100644
index 000000000000..5385824ed1e5
--- /dev/null
+++ b/games-util/biounzip/biounzip-1.1a.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Unpacks BioZip archives"
+HOMEPAGE="http://biounzip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/biounzip/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P/a/}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-64bit.patch
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} *.c -lz || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc biozip.txt
+}
diff --git a/games-util/biounzip/files/biounzip-1.1a-64bit.patch b/games-util/biounzip/files/biounzip-1.1a-64bit.patch
new file mode 100644
index 000000000000..a8522189d31f
--- /dev/null
+++ b/games-util/biounzip/files/biounzip-1.1a-64bit.patch
@@ -0,0 +1,11 @@
+--- biounzip-1.1-old/biounzip.c 2007-03-08 02:06:16.000000000 +0200
++++ biounzip-1.1/biounzip.c 2007-03-08 02:06:50.000000000 +0200
+@@ -127,7 +127,7 @@
+ void writefile(bzfile *ptr, FILE *fp, char *destdir)
+ {
+ int startpos,returnval,n,debug=0;
+- unsigned long size_uncompressed,size_compressed;
++ unsigned long size_uncompressed = 0, size_compressed = 0;
+ char *fname,*dirname,*fullname,*fullpath;
+ unsigned char *srcbuffer,*dstbuffer;
+ FILE *outfile;
diff --git a/games-util/biounzip/metadata.xml b/games-util/biounzip/metadata.xml
new file mode 100644
index 000000000000..1da8c892301c
--- /dev/null
+++ b/games-util/biounzip/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">biounzip</remote-id>
+ </upstream>
+</pkgmetadata>