summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/qjoypad
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/qjoypad')
-rw-r--r--games-util/qjoypad/Manifest1
-rw-r--r--games-util/qjoypad/files/qjoypad-4.1.0-underlink.patch11
-rw-r--r--games-util/qjoypad/metadata.xml8
-rw-r--r--games-util/qjoypad/qjoypad-4.1.0.ebuild51
4 files changed, 71 insertions, 0 deletions
diff --git a/games-util/qjoypad/Manifest b/games-util/qjoypad/Manifest
new file mode 100644
index 000000000000..9c78b62e0332
--- /dev/null
+++ b/games-util/qjoypad/Manifest
@@ -0,0 +1 @@
+DIST qjoypad-4.1.0.tar.gz 82306 SHA256 b5aa088827a6f7231e43e45fb942917e3f677ef933109a7b41e13a6b443c95ca SHA512 c14705aa24ead7c358dc2c82284ae5145df4eb041f47d4a017391346719b6330a8a1146e37ebd1f5d25d755385b611965b94b5835f9df0f6b2ef5e6a4ea3bc7b WHIRLPOOL d78ba76196899779e14eae78fcb528ca32f4802670c9f0f95faa6db6186c6924293cecffcf4c2e85f0ef5b5bfb77c568092a5eef650aaae9f70bea996c329793
diff --git a/games-util/qjoypad/files/qjoypad-4.1.0-underlink.patch b/games-util/qjoypad/files/qjoypad-4.1.0-underlink.patch
new file mode 100644
index 000000000000..8fde419546a7
--- /dev/null
+++ b/games-util/qjoypad/files/qjoypad-4.1.0-underlink.patch
@@ -0,0 +1,11 @@
+--- qjoypad.pro.old 2011-06-22 06:54:06.001667461 +0200
++++ qjoypad.pro 2011-06-22 06:56:17.580044446 +0200
+@@ -32,7 +32,7 @@
+
+ TEMPLATE = app
+ INCLUDEPATH += .
+-QMAKE_LIBS += -lXtst
++QMAKE_LIBS += -lXtst -lm -lX11
+
+ # Input
+ HEADERS += axis.h \
diff --git a/games-util/qjoypad/metadata.xml b/games-util/qjoypad/metadata.xml
new file mode 100644
index 000000000000..324067672b76
--- /dev/null
+++ b/games-util/qjoypad/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">qjoypad</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/qjoypad/qjoypad-4.1.0.ebuild b/games-util/qjoypad/qjoypad-4.1.0.ebuild
new file mode 100644
index 000000000000..ef1551520cb2
--- /dev/null
+++ b/games-util/qjoypad/qjoypad-4.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils qt4-r2
+
+DESCRIPTION="Translate gamepad/joystick input into key strokes/mouse actions in X"
+HOMEPAGE="http://qjoypad.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjoypad/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libXtst
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/${P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlink.patch
+ # fixup the icon tray support (bug #436426)
+ sed -i \
+ -e '/^icons.extra/d' \
+ -e '/^icons/s:/qjoypad::' \
+ -e 's/icon24.png/qjoypad4-24x24.png/' \
+ -e 's/icon64.png/qjoypad4-64x64.png/' \
+ qjoypad.pro || die
+}
+
+src_configure() {
+ eqmake4 qjoypad.pro PREFIX=/usr DEVDIR=/dev/input
+}
+
+src_install() {
+ local i
+ dobin qjoypad
+ dodoc ../README.txt
+ cd ../icons
+ for i in *; do
+ newicon ${i} ${i/gamepad/qjoypad}
+ done
+ make_desktop_entry qjoypad QJoypad ${PN}4-64x64
+}