summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-calculator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-calculator')
-rw-r--r--gnome-extra/gnome-calculator/Manifest3
-rw-r--r--gnome-extra/gnome-calculator/gnome-calculator-3.14.1.ebuild38
-rw-r--r--gnome-extra/gnome-calculator/gnome-calculator-3.16.1.ebuild39
-rw-r--r--gnome-extra/gnome-calculator/gnome-calculator-3.16.2.ebuild39
-rw-r--r--gnome-extra/gnome-calculator/metadata.xml5
5 files changed, 124 insertions, 0 deletions
diff --git a/gnome-extra/gnome-calculator/Manifest b/gnome-extra/gnome-calculator/Manifest
new file mode 100644
index 000000000000..48657cffc25c
--- /dev/null
+++ b/gnome-extra/gnome-calculator/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-calculator-3.14.1.tar.xz 1302628 SHA256 99cb2451d67d51486c0f54497dd26c0e57d0d984866ddf8678a62ba195fed140 SHA512 5c933704acbea762a9e34154d95f1634d97c6610317eb405bdc9f0a24b3c40e4da3cf5ffd8d9d47d4f4280fafeb335d33a0a214867fa7adc2cb777e80d1f603d WHIRLPOOL a7f120995f06414caaa1534e15ec05814478881a93c3afbea03cb1ae475ff6d606a0a3c58da1b4d7b356b22685453b3d4fc5226841d247b1e1ae01c8208080ee
+DIST gnome-calculator-3.16.1.tar.xz 1436992 SHA256 efceac11837ba0977eb5c3df1ea231628d4d12b8c3ad0f47be77929d97c9180b SHA512 1fadf8182f51728e4714f12beb97033b4ecbf8e94068639bce7089e7ae350eb1053a02edf767dfeeb309bece8711432d5c977c1ccde23b7c303b9c9876673677 WHIRLPOOL 1cbfb20dbce5f080c86199f8dd1703845f9c51add260c3eda9d898d49e200af409a64d704007b6e4cc442a53b0e78f1389701f2896fb34f38917d99c46caacf1
+DIST gnome-calculator-3.16.2.tar.xz 1437060 SHA256 f4c6ca7e0eda0dbb7d5cfb85ee9fe3351b1d8bd1bf05ce890939374b95e230a0 SHA512 f8141eca9eafa42277abd86fab4913e41c432471596f009c344915fc7f481172fcce240ab463597a70ff61c95e225fd0c618ca0fcb15b08c6f14e29b023cf218 WHIRLPOOL 0aca9c143d0c1334aa7c63061eba1606e16bb1593122f3d1d952118d1b8aa2f702c960ba875ac9b11ea1a5b74decae8d9eac7cea53040c34bb26fa0a7731d5a5
diff --git a/gnome-extra/gnome-calculator/gnome-calculator-3.14.1.ebuild b/gnome-extra/gnome-calculator/gnome-calculator-3.14.1.ebuild
new file mode 100644
index 000000000000..2addc5e75bc3
--- /dev/null
+++ b/gnome-extra/gnome-calculator/gnome-calculator-3.14.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A calculator application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calculator"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libxml2:2
+ >=x11-libs/gtk+-3.11.6:3
+ >=x11-libs/gtksourceview-3:3.0
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gnome-utils-2.3
+ !gnome-extra/gcalctool
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ ITSTOOL=$(type -P true) \
+ VALAC=$(type -P true)
+}
diff --git a/gnome-extra/gnome-calculator/gnome-calculator-3.16.1.ebuild b/gnome-extra/gnome-calculator/gnome-calculator-3.16.1.ebuild
new file mode 100644
index 000000000000..8a1e9f864c5d
--- /dev/null
+++ b/gnome-extra/gnome-calculator/gnome-calculator-3.16.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A calculator application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calculator"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libxml2:2
+ dev-libs/mpfr:0
+ >=x11-libs/gtk+-3.11.6:3
+ >=x11-libs/gtksourceview-3.15.1:3.0
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gnome-utils-2.3
+ !gnome-extra/gcalctool
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ ITSTOOL=$(type -P true) \
+ VALAC=$(type -P true)
+}
diff --git a/gnome-extra/gnome-calculator/gnome-calculator-3.16.2.ebuild b/gnome-extra/gnome-calculator/gnome-calculator-3.16.2.ebuild
new file mode 100644
index 000000000000..8a1e9f864c5d
--- /dev/null
+++ b/gnome-extra/gnome-calculator/gnome-calculator-3.16.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A calculator application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Calculator"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libxml2:2
+ dev-libs/mpfr:0
+ >=x11-libs/gtk+-3.11.6:3
+ >=x11-libs/gtksourceview-3.15.1:3.0
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gnome-utils-2.3
+ !gnome-extra/gcalctool
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ ITSTOOL=$(type -P true) \
+ VALAC=$(type -P true)
+}
diff --git a/gnome-extra/gnome-calculator/metadata.xml b/gnome-extra/gnome-calculator/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/gnome-extra/gnome-calculator/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>