summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-17 23:51:21 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-18 00:41:43 +0200
commit5408b64054d39581d331658b52213d43c275bfc6 (patch)
treec07127e0c5a865fadb81a51e8bb61729b212d606 /gnome-extra/gnome-contacts
parentsys-auth/polkit: add missing dependency on g-i-common, bug #627776 (diff)
downloadgentoo-5408b64054d39581d331658b52213d43c275bfc6.tar.gz
gentoo-5408b64054d39581d331658b52213d43c275bfc6.tar.bz2
gentoo-5408b64054d39581d331658b52213d43c275bfc6.zip
gnome-extra/gnome-contacts: fix build with vala-0.35+, bug #627986
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'gnome-extra/gnome-contacts')
-rw-r--r--gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part1.patch29
-rw-r--r--gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part2.patch50
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-3.22.1.ebuild8
3 files changed, 86 insertions, 1 deletions
diff --git a/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part1.patch b/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part1.patch
new file mode 100644
index 000000000000..b9634e6fc041
--- /dev/null
+++ b/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part1.patch
@@ -0,0 +1,29 @@
+From 2ba6e380dd8a3575bd8f4d4e5d8d3883003e9f54 Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Sat, 1 Oct 2016 14:27:55 +0200
+Subject: [PATCH] Don't restrict RowData.details to the generic type "string"
+
+This allows AbstractFieldDetails<G> based values to be assigned,
+like PostalAddressFieldDetails.
+
+Fixes a build-failure with vala 0.35+ due to stricter type-checking.
+---
+ src/contacts-contact-editor.vala | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/contacts-contact-editor.vala b/src/contacts-contact-editor.vala
+index 3372f87..3978887 100644
+--- a/src/contacts-contact-editor.vala
++++ b/src/contacts-contact-editor.vala
+@@ -77,7 +77,7 @@ public class Contacts.ContactEditor : Grid {
+ }
+
+ struct RowData {
+- AbstractFieldDetails<string> details;
++ AbstractFieldDetails details;
+ }
+
+ struct Field {
+--
+2.14.1
+
diff --git a/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part2.patch b/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part2.patch
new file mode 100644
index 000000000000..4cfe861fa509
--- /dev/null
+++ b/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part2.patch
@@ -0,0 +1,50 @@
+From b96b0fc07c49724f252a5cd35f2d028f91529068 Mon Sep 17 00:00:00 2001
+From: Jeena <hello@jeena.net>
+Date: Tue, 15 Aug 2017 16:53:05 +0200
+Subject: [PATCH] Drop unnecessary format-string.
+
+Code got refactored in 3.25/master but it boils down to dropping this
+extra parameter.
+---
+ src/contacts-contact-pane.vala | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/src/contacts-contact-pane.vala b/src/contacts-contact-pane.vala
+index 8e100f2..fce832b 100644
+--- a/src/contacts-contact-pane.vala
++++ b/src/contacts-contact-pane.vala
+@@ -451,7 +451,6 @@ public class Contacts.ContactPane : Notebook {
+ DialogFlags.MODAL,
+ MessageType.ERROR,
+ ButtonsType.OK,
+- "%s",
+ _("You need to enter some data"));
+ dialog.show ();
+ dialog.response.connect ( () => {
+@@ -463,7 +462,6 @@ public class Contacts.ContactPane : Notebook {
+ DialogFlags.MODAL,
+ MessageType.ERROR,
+ ButtonsType.OK,
+- "%s",
+ _("No primary addressbook configured"));
+ dialog.show ();
+ dialog.response.connect ( () => {
+@@ -482,7 +480,6 @@ public class Contacts.ContactPane : Notebook {
+ DialogFlags.MODAL,
+ MessageType.ERROR,
+ ButtonsType.OK,
+- "%s",
+ _("Unable to create new contacts: %s"), e.message);
+ }
+
+@@ -493,7 +490,6 @@ public class Contacts.ContactPane : Notebook {
+ DialogFlags.MODAL,
+ MessageType.ERROR,
+ ButtonsType.OK,
+- "%s",
+ _("Unable to find newly created contact"));
+ }
+
+--
+2.14.1
+
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-3.22.1.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-3.22.1.ebuild
index d1c0351111fd..95083e15f4ef 100644
--- a/gnome-extra/gnome-contacts/gnome-contacts-3.22.1.ebuild
+++ b/gnome-extra/gnome-contacts/gnome-contacts-3.22.1.ebuild
@@ -24,8 +24,9 @@ VALA_DEPEND="
net-libs/telepathy-glib[vala]
"
# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
+# folks-0.11.4 to avoid build issues with vala-0.36, upstream 7a9001b056b4fb1d00375e7b2adeda9b7cf93c90
RDEPEND="
- >=dev-libs/folks-0.9.5:=[eds,telepathy]
+ >=dev-libs/folks-0.11.4:=[eds,telepathy]
>=dev-libs/glib-2.37.6:2
>=dev-libs/libgee-0.10:0.8
>=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
@@ -52,6 +53,11 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${PV}-fix-vala-0.35-part1.patch
+ "${FILESDIR}"/${PV}-fix-vala-0.35-part2.patch
+)
+
src_prepare() {
# Regenerate the pre-generated C sources, bug #471628
if ! use v4l; then