summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-01-22 13:28:46 -0500
committerMike Gilbert <floppym@gentoo.org>2022-01-22 13:28:46 -0500
commit41d5d8b41005c9df85761ab0dc1ea9498cd5ecdf (patch)
tree6f7e08e1d45b5bd2661ad4b3c8a82e19b592f0d3 /gnome-extra/nm-applet
parentdev-python/libarchive-c: add 4.0 (diff)
downloadgentoo-41d5d8b41005c9df85761ab0dc1ea9498cd5ecdf.tar.gz
gentoo-41d5d8b41005c9df85761ab0dc1ea9498cd5ecdf.tar.bz2
gentoo-41d5d8b41005c9df85761ab0dc1ea9498cd5ecdf.zip
gnome-extra/nm-applet: fix build with meson-0.61
Closes: https://bugs.gentoo.org/831829 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'gnome-extra/nm-applet')
-rw-r--r--gnome-extra/nm-applet/files/meson-0.61.patch36
-rw-r--r--gnome-extra/nm-applet/nm-applet-1.22.0-r1.ebuild6
-rw-r--r--gnome-extra/nm-applet/nm-applet-1.24.0.ebuild6
3 files changed, 46 insertions, 2 deletions
diff --git a/gnome-extra/nm-applet/files/meson-0.61.patch b/gnome-extra/nm-applet/files/meson-0.61.patch
new file mode 100644
index 000000000000..e2366c0f64e1
--- /dev/null
+++ b/gnome-extra/nm-applet/files/meson-0.61.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/831829
+https://gitlab.gnome.org/GNOME/network-manager-applet/-/merge_requests/107
+
+From b92fa5ba6d65aaa9e2d1494beaf340a33d9ba07f Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Fri, 21 Jan 2022 22:34:09 +0100
+Subject: [PATCH] meson.build: address meson 0.61 failures
+
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ meson.build | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 33adb632..6178c0eb 100644
+--- a/meson.build
++++ b/meson.build
+@@ -254,7 +254,6 @@ desktop_file_validate = find_program('desktop-file-validate', required: false)
+
+ foreach desktop: desktop_files
+ i18n.merge_file(
+- desktop + '-desktop',
+ input: desktop + '.desktop.in',
+ output: desktop + '.desktop',
+ install: true,
+@@ -275,7 +274,6 @@ endforeach
+ appdata = 'nm-connection-editor.appdata.xml'
+
+ i18n.merge_file(
+- 'desktop',
+ input: appdata + '.in',
+ output: appdata,
+ install: true,
+--
+GitLab
+
diff --git a/gnome-extra/nm-applet/nm-applet-1.22.0-r1.ebuild b/gnome-extra/nm-applet/nm-applet-1.22.0-r1.ebuild
index 57ab47600412..6498d20d7f96 100644
--- a/gnome-extra/nm-applet/nm-applet-1.22.0-r1.ebuild
+++ b/gnome-extra/nm-applet/nm-applet-1.22.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,6 +39,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}/meson-0.61.patch"
+)
+
src_configure() {
local emesonargs=(
-Dappindicator=$(usex appindicator ubuntu no)
diff --git a/gnome-extra/nm-applet/nm-applet-1.24.0.ebuild b/gnome-extra/nm-applet/nm-applet-1.24.0.ebuild
index 769fc0bab392..0d966ed53377 100644
--- a/gnome-extra/nm-applet/nm-applet-1.24.0.ebuild
+++ b/gnome-extra/nm-applet/nm-applet-1.24.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,6 +39,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}/meson-0.61.patch"
+)
+
src_configure() {
local emesonargs=(
-Dappindicator=$(usex appindicator ubuntu no)