summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-08-10 12:45:35 -0400
committerMatt Turner <mattst88@gentoo.org>2023-08-10 12:46:44 -0400
commitc5cb8da51d15da3bb77087a9a4831ce806fa41c4 (patch)
treefed6e116cb3bf935a38f6083fae8bad11e5f51f8 /gnome-extra/zenity
parentwww-client/firefox: disable openh264 useflag by default, bug 912033 (diff)
downloadgentoo-c5cb8da51d15da3bb77087a9a4831ce806fa41c4.tar.gz
gentoo-c5cb8da51d15da3bb77087a9a4831ce806fa41c4.tar.bz2
gentoo-c5cb8da51d15da3bb77087a9a4831ce806fa41c4.zip
gnome-extra/zenity: Version bump to 3.44.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/zenity')
-rw-r--r--gnome-extra/zenity/Manifest1
-rw-r--r--gnome-extra/zenity/zenity-3.44.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/gnome-extra/zenity/Manifest b/gnome-extra/zenity/Manifest
index 3f33831d07bc..90c250ab0d66 100644
--- a/gnome-extra/zenity/Manifest
+++ b/gnome-extra/zenity/Manifest
@@ -1,4 +1,5 @@
DIST zenity-3.44.0.tar.xz 3096684 BLAKE2B bd6cb333e30ca675bd6d49a8117fc81a8d5ffe2870b9d78f897f292b827849cfaee7d92d36ebc9dc784041400b221cca715d40878be0bb2f5aa47ccbf9c10965 SHA512 806fff8f239dfa5da32e75bbc1fc3a6dc50b49ea8e6ca64cead9dd40adfe4741237c25ae5caaac1997ec7f274e9379b6607d254caf8a509aa01f3eba03cb3e7c
DIST zenity-3.44.1.tar.xz 3095920 BLAKE2B 86bfec1f53bfdb5a9cdec68d74de491d08be6c41d4b8b5a0848f833460ab98164dd11fe24f670cba9618fae3b37d03720e62367071679ab7bd2e9d3f1488136e SHA512 b2cb92b501af94bf18ede1b9567a231811c81dd27bc878354b03ec131e6fa1cdfec780c9f34d4ff5994b0993271473455d6a2f76561347a09117c47cae3e105c
+DIST zenity-3.44.2.tar.xz 3095752 BLAKE2B 07d5b9aa673ae1e719bbd8d2ff85394ce19b9e77c36c3b6cf73d6b806dbcb0ab6322d13e66a715ebf5aefc14fa289a31367d0f0abd6ceaa9df7e3d7d12049492 SHA512 60f139b18db9ddf95a9c3481b08a3b99dd56ce457a49d99dc33f59570837e8498e8819bdd130c915a08e40042b2f3af583bd0fe4498adb8152632bd044137f2f
DIST zenity-3.99.0.tar.xz 3084896 BLAKE2B 71a6848cb2684e71eb8bb8b5ca57ad0c602b58326f2426542774e4806f4ea9929880810f3e4cd43e938554a9905d3381712b62f2cb2b0bfb137d6a47bb004904 SHA512 65820dd9f5e60dad14867dc584ac4a2d43f6c259c4eccd021c76f2deb4206a29de17db4eb8a911fff12243a594b624c1aa3781087bcd41308c4ea6c0dc919633
DIST zenity-3.99.1.tar.xz 3086092 BLAKE2B cf43be455f97e1ecf0539339d515415c9f875a5a0ac961f11b6e2fe463362eae400633628132ed67c67c01dd61a39cba2dc247ad3b82449d51867a9d93bda2c1 SHA512 4be34682da266b79e05e56a862e698bd93bb2187b4395b699be8ba63053dac07a0f9598bba411fb1f06dc2fffab78829a791f797e66665ada23d1eac3463b3a8
diff --git a/gnome-extra/zenity/zenity-3.44.2.ebuild b/gnome-extra/zenity/zenity-3.44.2.ebuild
new file mode 100644
index 000000000000..9080ff54a435
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.44.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=x11-libs/gtk+-3.16.0:3[X]
+ >=dev-libs/glib-2.43.4:2
+ libnotify? ( >=x11-libs/libnotify-0.6.1:= )
+ webkit? ( >=net-libs/webkit-gtk-2.8.1:4.1 )
+ x11-libs/libX11
+
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+src_configure() {
+ local emesonargs=(
+ $(meson_use libnotify)
+ $(meson_use webkit webkitgtk)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Not really needed and prevent us from needing perl
+ rm "${ED}/usr/bin/gdialog" || die "rm gdialog failed!"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}