summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-23 18:46:41 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-23 18:46:41 -0700
commit1f1a7c9c63814eb6f9e6963472fbee3e15895e46 (patch)
treed7691532de3741846ad5e3ab779bc273d8b43f2c /gnome-extra
parentgnome-extra/gnome-calendar: Version bump to 42.0 (diff)
downloadgentoo-1f1a7c9c63814eb6f9e6963472fbee3e15895e46.tar.gz
gentoo-1f1a7c9c63814eb6f9e6963472fbee3e15895e46.tar.bz2
gentoo-1f1a7c9c63814eb6f9e6963472fbee3e15895e46.zip
gnome-extra/gnome-system-monitor: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest1
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-42.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
index afdfbd619616..b030507dc16f 100644
--- a/gnome-extra/gnome-system-monitor/Manifest
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -1 +1,2 @@
DIST gnome-system-monitor-41.0.tar.xz 774644 BLAKE2B 9aafaaf77b414435301eebd8bc84f04faa171139a7d9e6e71ad9bae8f097eaf6d637502ab64f0868636f7964a2b76353364ad27ee2b56c3d8f9131e0a7ee1df2 SHA512 1eecddc479f0d9e986f1821a8c4b72246a6995f7853a6b35c8435d1aaa1afd7bc1df0cc0b9748785e4581563985652be19beb12b193ee17439ba4564febf5d20
+DIST gnome-system-monitor-42.0.tar.xz 978208 BLAKE2B ba52048e643eef1dd556dc833fc5ebdf6a07559551c5e28dc46c3d143676571f7704667263f9974d87d6ed3679c15c955178a02e9ed5f69b4bc25c78d9b32e4e SHA512 880093fd75a87993ff8def1db9f6f090edaad43c6dc08564f61b9dbfa8c10df5e6d6a9a9072737d802503b34ba70de7bf7ef5aab2bf055ea68e795ec11a48bdd
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-42.0.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-42.0.ebuild
new file mode 100644
index 000000000000..76f02b713576
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-42.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/stable/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="systemd X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-cpp/glibmm-2.46:2
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gtk+-3.22:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/atkmm-2.28:0
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gui-libs/libhandy-1.5.0:1=
+ >=gnome-base/librsvg-2.35:2
+ >=dev-libs/libxml2-2.0:2
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+ systemd? ( >=sys-apps/systemd-44:0= )
+"
+# eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ >=sys-auth/polkit-0.114
+" # polkit needed at buildtime for ITS rules of policy files, first available in 0.114
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use X wnck)
+ $(meson_use systemd)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}