summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-11-22 19:48:40 -0500
committerSam James <sam@gentoo.org>2024-11-23 15:49:26 +0000
commit10ce536784c8988aedb5d773bb6158b43738d1b2 (patch)
tree35dd09927da14731bce6d2ba1e40dcc8a27d0d29 /gui-libs
parentnet-print/cnrdrvcups-lb: Stabilize 5.80 amd64, #944675 (diff)
downloadgentoo-10ce536784c8988aedb5d773bb6158b43738d1b2.tar.gz
gentoo-10ce536784c8988aedb5d773bb6158b43738d1b2.tar.bz2
gentoo-10ce536784c8988aedb5d773bb6158b43738d1b2.zip
gui-libs/hyprcursor: backport patch for llvm/clang builds
Closes: https://bugs.gentoo.org/944500 Signed-off-by: Julien Roy <julien@jroy.ca> Closes: https://github.com/gentoo/gentoo/pull/39431 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/hyprcursor/files/0.1.10-llvm-fix.patch27
-rw-r--r--gui-libs/hyprcursor/hyprcursor-0.1.10-r1.ebuild30
2 files changed, 57 insertions, 0 deletions
diff --git a/gui-libs/hyprcursor/files/0.1.10-llvm-fix.patch b/gui-libs/hyprcursor/files/0.1.10-llvm-fix.patch
new file mode 100644
index 000000000000..9c8661221b4a
--- /dev/null
+++ b/gui-libs/hyprcursor/files/0.1.10-llvm-fix.patch
@@ -0,0 +1,27 @@
+From f8e8455e998e0ff8b4708220006a479d1d7e4e8b Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Tue, 1 Oct 2024 01:01:47 +0200
+Subject: [PATCH] lib: add missing header for libc++ after 5a95d8512b3e
+
+libhyprcursor/hyprcursor.cpp:23:27: error: implicit instantiation of undefined template 'std::basic_stringstream<char>'
+ 23 | std::stringstream envXdgStream(envXdgData);
+ | ^
+/usr/include/c++/v1/__fwd/sstream.h:29:28: note: template is declared here
+ 29 | class _LIBCPP_TEMPLATE_VIS basic_stringstream;
+ | ^
+---
+ libhyprcursor/hyprcursor.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libhyprcursor/hyprcursor.cpp b/libhyprcursor/hyprcursor.cpp
+index 3a83a26..f7fb82c 100644
+--- a/libhyprcursor/hyprcursor.cpp
++++ b/libhyprcursor/hyprcursor.cpp
+@@ -2,6 +2,7 @@
+ #include "internalSharedTypes.hpp"
+ #include "internalDefines.hpp"
+ #include <array>
++#include <sstream>
+ #include <cstdio>
+ #include <filesystem>
+ #include <zip.h>
diff --git a/gui-libs/hyprcursor/hyprcursor-0.1.10-r1.ebuild b/gui-libs/hyprcursor/hyprcursor-0.1.10-r1.ebuild
new file mode 100644
index 000000000000..c61d5311a6d8
--- /dev/null
+++ b/gui-libs/hyprcursor/hyprcursor-0.1.10-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The hyprland cursor format, library and utilities"
+HOMEPAGE="https://github.com/hyprwm/hyprcursor"
+SRC_URI="https://github.com/hyprwm/hyprcursor/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+# Disable tests since as per upstream, tests require a theme to be installed
+# See also https://github.com/hyprwm/hyprcursor/commit/94361fd8a75178b92c4bb24dcd8c7fac8423acf3
+RESTRICT="test"
+
+RDEPEND="
+ dev-cpp/tomlplusplus
+ >=dev-libs/hyprlang-0.4.2
+ dev-libs/libzip
+ gnome-base/librsvg:2
+ x11-libs/cairo
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.1.10-llvm-fix.patch
+)