summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-17 22:34:26 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-17 22:47:10 -0500
commit537861df99afd410887f92fc4913e921613578cb (patch)
tree5802ee0d5c38b48f1343cd33c3e96002efb46724 /gui-libs
parentdev-cpp/gtkmm: Version bump to 4.4.0 (diff)
downloadgentoo-537861df99afd410887f92fc4913e921613578cb.tar.gz
gentoo-537861df99afd410887f92fc4913e921613578cb.tar.bz2
gentoo-537861df99afd410887f92fc4913e921613578cb.zip
gui-libs/libhandy: Version bump to 1.5.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/libhandy/Manifest1
-rw-r--r--gui-libs/libhandy/libhandy-1.5.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gui-libs/libhandy/Manifest b/gui-libs/libhandy/Manifest
index e83537ad3a30..61ca92abf741 100644
--- a/gui-libs/libhandy/Manifest
+++ b/gui-libs/libhandy/Manifest
@@ -1,2 +1,3 @@
DIST libhandy-1.2.3.tar.xz 491024 BLAKE2B b15e4b12135230ce6e588e005f55edada001abaa3fbdcf2f05b5e05f364beaa8983239f3a562b8600fc07edd6b6b7e834d42a06ec1ec626d7a43d6634ba93d0e SHA512 20ed6708bb517c81d9b8520c522555d7cdaf36f19dd29603a4f86d6d47ec2552af8874605b1866eb634d25afd0a2c18690cb1be6eafce81cac7857890388799e
DIST libhandy-1.4.0.tar.xz 496476 BLAKE2B fca22f75348de5a485aa426f90201217e3f5b9bea664d9625b205990fa2c1a6e7ee32dfeec9a6695fcc9bfd841de1d2d310590ed6c59ec9835cb243f6bba54eb SHA512 a616430873cdd928d7875f776c5b98c66f1ab2f11422dffeed86844cec68cd212eb698413e38da0f0c38fc6c144372519ea1d03c8255fb4f7da9603c1713e6f8
+DIST libhandy-1.5.0.tar.xz 516128 BLAKE2B 51b479b297009f0663b9cd614c350d78dd702e3428f98759219b277d9010f2453142eabda2a9f8318d65b0efb156f0716fd606bf93b157c296648e4a1cb68123 SHA512 cd7706e97bc9d5a7d595c450145bc157b95afaccc1ee26b5490149327fd644eb522b7bbfee92ea2780083c36d69bbd666c52e38a752e78068a5ba0f79b3c56a0
diff --git a/gui-libs/libhandy/libhandy-1.5.0.ebuild b/gui-libs/libhandy/libhandy-1.5.0.ebuild
new file mode 100644
index 000000000000..8af23d0bf4e6
--- /dev/null
+++ b/gui-libs/libhandy/libhandy-1.5.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson xdg vala virtualx
+
+DESCRIPTION="Building blocks for modern adaptive GNOME apps"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libhandy/"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="examples glade gtk-doc +introspection test +vala"
+REQUIRED_USE="vala? ( introspection )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.24.1:3[introspection?]
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.3 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofiling=false # -pg passing
+ $(meson_feature introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use test tests)
+ $(meson_use examples)
+ $(meson_feature glade glade_catalog)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}