summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-07-28 18:28:55 +0200
committerSam James <sam@gentoo.org>2022-07-29 04:16:12 +0100
commit703dd8096ec4a9e83db96a3b34a8f09839b2f113 (patch)
treede3d0a8cf4d26728c02397f0d099767993ddddb1 /gui-libs
parentmedia-gfx/hydrus: Drop 482, add 493 (diff)
downloadgentoo-703dd8096ec4a9e83db96a3b34a8f09839b2f113.tar.gz
gentoo-703dd8096ec4a9e83db96a3b34a8f09839b2f113.tar.bz2
gentoo-703dd8096ec4a9e83db96a3b34a8f09839b2f113.zip
gui-libs/gtk-layer-shell: add 0.7.0
Closes: https://bugs.gentoo.org/852911 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/gtk-layer-shell/Manifest1
-rw-r--r--gui-libs/gtk-layer-shell/gtk-layer-shell-0.7.0.ebuild47
-rw-r--r--gui-libs/gtk-layer-shell/metadata.xml9
3 files changed, 56 insertions, 1 deletions
diff --git a/gui-libs/gtk-layer-shell/Manifest b/gui-libs/gtk-layer-shell/Manifest
index 509c634bf39e..b25e7e1bc005 100644
--- a/gui-libs/gtk-layer-shell/Manifest
+++ b/gui-libs/gtk-layer-shell/Manifest
@@ -1,2 +1,3 @@
DIST gtk-layer-shell-0.1.0.tar.xz 34580 BLAKE2B db815d711e53485e00de2e0b7d238f6c66ddac9ca790d5f31c44eed965ad01ee07392d27552ae21bb1eab4905cc1d5f7dad9c10fd059afb43ba85c7ea1af2aa5 SHA512 3788559405a495d43279b20b9d64e1fb0fb9be4125eb3011a623565938246310c2e81cb6d52db111e42a9cd0739bb273ccf7fcb7c52db8b74a1e44108e061c6d
DIST gtk-layer-shell-0.6.0.tar.gz 133047 BLAKE2B cbfc5f2ae355f1308a21d09bdaf925774223179d310b752c2540666b691a0be4c45c740f79c7a02877c95bcc31293f59643938e80c38687f0f3805534af93ab4 SHA512 ca5367b5f1637a07c28c772e79e5ac84219ff069091077f83c5edbc88be084538a925b3c76e6cc9dcd8d2826ae340b79605875e87209ee4f4d5e27dc4e93a523
+DIST gtk-layer-shell-0.7.0.tar.gz 133511 BLAKE2B 49925796112f7ace01050beb56ebe2ff8a716db56075166c61a7b9d1e4f1b7402c970e14de59404ae9b05f70130542fff7601fee10e0d8780bffa34da0515aa9 SHA512 97463b4bd90318e95576e3f4b05c0acae401b8103b389cb9a0dc7716871d8d8285595ddda76419883c98c6f00fcd4ffdfd9dba48385cb8a6edcbdc7f202e2818
diff --git a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.7.0.ebuild b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.7.0.ebuild
new file mode 100644
index 000000000000..d70f63f960d2
--- /dev/null
+++ b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.7.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wmww/${PN}"
+else
+ SRC_URI="https://github.com/wmww/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Library to create desktop components for Wayland using the Layer Shell protocol"
+HOMEPAGE="https://github.com/wmww/gtk-layer-shell"
+
+LICENSE="MIT-with-advertising LGPL-3+"
+SLOT="0"
+IUSE="examples gtk-doc introspection test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=x11-libs/gtk+-3.24.26:3[introspection?,wayland]
+ >=dev-libs/wayland-1.10.0
+ >=dev-libs/wayland-protocols-1.16
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+ test? ( ${PYTHON_DEPS} )
+"
+
+src_configure() {
+ # note: Next 0.x release should add support for VAPI (vala)
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use gtk-doc docs)
+ $(meson_use test tests)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
diff --git a/gui-libs/gtk-layer-shell/metadata.xml b/gui-libs/gtk-layer-shell/metadata.xml
index cb86c4632351..35b66bf25706 100644
--- a/gui-libs/gtk-layer-shell/metadata.xml
+++ b/gui-libs/gtk-layer-shell/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <name>Haelwenn (lanodan) Monnier</name>
+ <email>contact@hacktivis.me</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">wmww/gtk-layer-shell</remote-id>
</upstream>